Quake 2 OpenGL not working
Why do I get Quake2.exe stopped working when I try to use OpenGL mode on my GTX 285 card with the Nvidia 191.07 driver in Windows 7?
Why do I get Quake2.exe stopped working when I try to use OpenGL mode on my GTX 285 card with the Nvidia 191.07 driver in Windows 7?

#1
Posted 11/03/2009 04:03 AM   
Because it is an old game? try using a more modern source port of the game.
Because it is an old game? try using a more modern source port of the game.

Custom built PC | Intel Core i7 920 @ 2.66GHZ | ASUS P6T Motherboard | 6GB DDR3 1600 RAM | 2x 500GB SATA2 HDD's | Auzentech Forte S/C | Gainward Geforce GTX 560Ti "Phantom 2" 2048MB | Windows 7 Home Premium: Service Pack 1 - x64 | Thermaltake 750watt Toughpower Power Supply | Thermaltake Armor+ MX case.

#2
Posted 11/03/2009 11:54 AM   
[quote name='Franpa' post='944322' date='Nov 3 2009, 09:54 AM']Because it is an old game? try using a more modern source port of the game.[/quote]
It's not working here either, in fact no opengl app is working. 8800gtx and windows xp 195.39 beta.
[quote name='Franpa' post='944322' date='Nov 3 2009, 09:54 AM']Because it is an old game? try using a more modern source port of the game.

It's not working here either, in fact no opengl app is working. 8800gtx and windows xp 195.39 beta.

#3
Posted 11/03/2009 01:03 PM   
[quote name='Keith Weisshar' post='944138' date='Nov 3 2009, 12:03 AM']Why do I get Quake2.exe stopped working when I try to use OpenGL mode on my GTX 285 card with the Nvidia 191.07 driver in Windows 7?[/quote]

I don't have Quake 2 anymore so I can't say for sure. What error message are you getting when you try to start Quake 2?
I'm running Windows XP and found this fix in the nHancer forums for the older OpenGL games.

[url="http://forum.nhancer.com/showthread.php?t=1449"]http://forum.nhancer.com/showthread.php?t=1449[/url]

Using nHancer you can set the OpenGL extension limit. What worked for me with Call of Duty + United Offensive & Anachronox & Soldier of Fortune 2 was setting the extension limit to 4844.
I have no idea if this will work with Windows 7. But I think it's only a driver issue. v191.07 has OpenGL 3.2 support which increases the number of OpenGL extensions. Some old games don't know what to do with that. Anyway, the link above gives you all the info you need.

Hope that helps.
Frank
[quote name='Keith Weisshar' post='944138' date='Nov 3 2009, 12:03 AM']Why do I get Quake2.exe stopped working when I try to use OpenGL mode on my GTX 285 card with the Nvidia 191.07 driver in Windows 7?



I don't have Quake 2 anymore so I can't say for sure. What error message are you getting when you try to start Quake 2?

I'm running Windows XP and found this fix in the nHancer forums for the older OpenGL games.



http://forum.nhancer.com/showthread.php?t=1449



Using nHancer you can set the OpenGL extension limit. What worked for me with Call of Duty + United Offensive & Anachronox & Soldier of Fortune 2 was setting the extension limit to 4844.

I have no idea if this will work with Windows 7. But I think it's only a driver issue. v191.07 has OpenGL 3.2 support which increases the number of OpenGL extensions. Some old games don't know what to do with that. Anyway, the link above gives you all the info you need.



Hope that helps.

Frank

Windows XP Pro SP3
Pentium D Extreme 3.2GHz (dual core + HT)
XFX 8800GT 512 MB
Gigabyte 8I955X Royal
4 GB RAM

#4
Posted 11/03/2009 01:06 PM   
I used the extension limit settings from the NVIDIA Control Panel to fix the issue. I had to add quake2.exe to the Manage 3D Settings program settings and then set extension limit to on and click apply.
[quote name='FrankD3' post='944368' date='Nov 3 2009, 08:06 AM']I don't have Quake 2 anymore so I can't say for sure. What error message are you getting when you try to start Quake 2?
I'm running Windows XP and found this fix in the nHancer forums for the older OpenGL games.

[url="http://forum.nhancer.com/showthread.php?t=1449"]http://forum.nhancer.com/showthread.php?t=1449[/url]

Using nHancer you can set the OpenGL extension limit. What worked for me with Call of Duty + United Offensive & Anachronox & Soldier of Fortune 2 was setting the extension limit to 4844.
I have no idea if this will work with Windows 7. But I think it's only a driver issue. v191.07 has OpenGL 3.2 support which increases the number of OpenGL extensions. Some old games don't know what to do with that. Anyway, the link above gives you all the info you need.

Hope that helps.
Frank[/quote]
I used the extension limit settings from the NVIDIA Control Panel to fix the issue. I had to add quake2.exe to the Manage 3D Settings program settings and then set extension limit to on and click apply.

[quote name='FrankD3' post='944368' date='Nov 3 2009, 08:06 AM']I don't have Quake 2 anymore so I can't say for sure. What error message are you getting when you try to start Quake 2?

I'm running Windows XP and found this fix in the nHancer forums for the older OpenGL games.



http://forum.nhancer.com/showthread.php?t=1449



Using nHancer you can set the OpenGL extension limit. What worked for me with Call of Duty + United Offensive & Anachronox & Soldier of Fortune 2 was setting the extension limit to 4844.

I have no idea if this will work with Windows 7. But I think it's only a driver issue. v191.07 has OpenGL 3.2 support which increases the number of OpenGL extensions. Some old games don't know what to do with that. Anyway, the link above gives you all the info you need.



Hope that helps.

Frank

#5
Posted 11/03/2009 03:22 PM   
[quote name='Keith Weisshar' post='944452' date='Nov 3 2009, 11:22 AM']I used the extension limit settings from the NVIDIA Control Panel to fix the issue. I had to add quake2.exe to the Manage 3D Settings program settings and then set extension limit to on and click apply.[/quote]

Setting extension limit without setting a number turns off ALL extensions. The Nvidia control panel does not offer any way to set the number.
But, if it looks ok to you then maybe it doesn't matter. As I said before, that link provides all this information.

I tried just using the control panel to turn on extension limit on Call of Duty and I got a warning message that some features were not available.
[quote name='Keith Weisshar' post='944452' date='Nov 3 2009, 11:22 AM']I used the extension limit settings from the NVIDIA Control Panel to fix the issue. I had to add quake2.exe to the Manage 3D Settings program settings and then set extension limit to on and click apply.



Setting extension limit without setting a number turns off ALL extensions. The Nvidia control panel does not offer any way to set the number.

But, if it looks ok to you then maybe it doesn't matter. As I said before, that link provides all this information.



I tried just using the control panel to turn on extension limit on Call of Duty and I got a warning message that some features were not available.

Windows XP Pro SP3
Pentium D Extreme 3.2GHz (dual core + HT)
XFX 8800GT 512 MB
Gigabyte 8I955X Royal
4 GB RAM

#6
Posted 11/03/2009 05:12 PM   
I have got Quake 2 working perfectly in win 7 using the EGL engine port, get it here: [url="http://egl.quakedev.com/"]http://egl.quakedev.com/[/url]

If anyone is interested, also got Quake 1 working using the latest Dark Places engine: [url="http://icculus.org/twilight/darkplaces/"]http://icculus.org/twilight/darkplaces/[/url]
I have got Quake 2 working perfectly in win 7 using the EGL engine port, get it here: http://egl.quakedev.com/



If anyone is interested, also got Quake 1 working using the latest Dark Places engine: http://icculus.org/twilight/darkplaces/

#7
Posted 11/03/2009 08:35 PM   
[quote name='FrankD3' post='944541' date='Nov 3 2009, 03:12 PM']Setting extension limit without setting a number turns off ALL extensions. The Nvidia control panel does not offer any way to set the number.
But, if it looks ok to you then maybe it doesn't matter. As I said before, that link provides all this information.

I tried just using the control panel to turn on extension limit on Call of Duty and I got a warning message that some features were not available.[/quote]
How do I do that now? nvidia disabled it on the control panel :angry:
[quote name='FrankD3' post='944541' date='Nov 3 2009, 03:12 PM']Setting extension limit without setting a number turns off ALL extensions. The Nvidia control panel does not offer any way to set the number.

But, if it looks ok to you then maybe it doesn't matter. As I said before, that link provides all this information.



I tried just using the control panel to turn on extension limit on Call of Duty and I got a warning message that some features were not available.

How do I do that now? nvidia disabled it on the control panel :angry:

#8
Posted 11/03/2009 09:03 PM   
[quote name='filipetolhuizen' post='944687' date='Nov 3 2009, 05:03 PM']How do I do that now? nvidia disabled it on the control panel :angry:[/quote]

Whoa! Disabled? I never heard of that being disabled. And I can't understand why it would be disabled. /shock.gif' class='bbc_emoticon' alt=':shock:' />
You can't go to Extension Limit in the game's profile and change it to ON ?

But as I said earlier just setting it to ON is not the best way. You'll need nHancer to set the limit number.
But back to your problem, if I had that issue I'd definitely try nHancer (it's an excellent free program). It should be able to access the profile regardless of what the control panel says. Then if needed you can ask the smart people in the nHancer forum for advice.I've learned a lot there
By the way, the latest nHancer requires .NET v3.5.
[quote name='filipetolhuizen' post='944687' date='Nov 3 2009, 05:03 PM']How do I do that now? nvidia disabled it on the control panel :angry:



Whoa! Disabled? I never heard of that being disabled. And I can't understand why it would be disabled. /shock.gif' class='bbc_emoticon' alt=':shock:' />

You can't go to Extension Limit in the game's profile and change it to ON ?



But as I said earlier just setting it to ON is not the best way. You'll need nHancer to set the limit number.

But back to your problem, if I had that issue I'd definitely try nHancer (it's an excellent free program). It should be able to access the profile regardless of what the control panel says. Then if needed you can ask the smart people in the nHancer forum for advice.I've learned a lot there

By the way, the latest nHancer requires .NET v3.5.

Windows XP Pro SP3
Pentium D Extreme 3.2GHz (dual core + HT)
XFX 8800GT 512 MB
Gigabyte 8I955X Royal
4 GB RAM

#9
Posted 11/03/2009 10:51 PM   
[quote name='FrankD3' post='944758' date='Nov 3 2009, 08:51 PM']Whoa! Disabled? I never heard of that being disabled. And I can't understand why it would be disabled. /shock.gif' class='bbc_emoticon' alt=':shock:' />
You can't go to Extension Limit in the game's profile and change it to ON ?

But as I said earlier just setting it to ON is not the best way. You'll need nHancer to set the limit number.
But back to your problem, if I had that issue I'd definitely try nHancer (it's an excellent free program). It should be able to access the profile regardless of what the control panel says. Then if needed you can ask the smart people in the nHancer forum for advice.I've learned a lot there
By the way, the latest nHancer requires .NET v3.5.[/quote]
I could set it to on only in nHancer, in the nvidia control panel, this option doesn't exist anymore, as well as force mipmaps. I set it to 11a8 on Quake and Hexen II profiles and now they're working again. I got an enhanced gl.dll for Quake 2, which worked with new drivers, only the videos didn't appear.
[quote name='FrankD3' post='944758' date='Nov 3 2009, 08:51 PM']Whoa! Disabled? I never heard of that being disabled. And I can't understand why it would be disabled. /shock.gif' class='bbc_emoticon' alt=':shock:' />

You can't go to Extension Limit in the game's profile and change it to ON ?



But as I said earlier just setting it to ON is not the best way. You'll need nHancer to set the limit number.

But back to your problem, if I had that issue I'd definitely try nHancer (it's an excellent free program). It should be able to access the profile regardless of what the control panel says. Then if needed you can ask the smart people in the nHancer forum for advice.I've learned a lot there

By the way, the latest nHancer requires .NET v3.5.

I could set it to on only in nHancer, in the nvidia control panel, this option doesn't exist anymore, as well as force mipmaps. I set it to 11a8 on Quake and Hexen II profiles and now they're working again. I got an enhanced gl.dll for Quake 2, which worked with new drivers, only the videos didn't appear.

#10
Posted 11/04/2009 12:22 AM   
[quote name='filipetolhuizen' post='944823' date='Nov 3 2009, 08:22 PM']I could set it to on only in nHancer, in the nvidia control panel, this option doesn't exist anymore, as well as force mipmaps.[/quote]

I wonder why they're dropping features like this? This will force everybody to start using nHancer to tweak profiles. Maybe that's their goal?
[quote name='filipetolhuizen' post='944823' date='Nov 3 2009, 08:22 PM']I could set it to on only in nHancer, in the nvidia control panel, this option doesn't exist anymore, as well as force mipmaps.



I wonder why they're dropping features like this? This will force everybody to start using nHancer to tweak profiles. Maybe that's their goal?

Windows XP Pro SP3
Pentium D Extreme 3.2GHz (dual core + HT)
XFX 8800GT 512 MB
Gigabyte 8I955X Royal
4 GB RAM

#11
Posted 11/04/2009 03:14 PM   
[quote name='FrankD3' post='945188' date='Nov 4 2009, 01:14 PM']I wonder why they're dropping features like this? This will force everybody to start using nHancer to tweak profiles. Maybe that's their goal?[/quote]
Their goal is to force us to use that goddamn physx and forget about everything else. It's shipping with every driver making them huge files and I've NEVER used it, ever.
[quote name='FrankD3' post='945188' date='Nov 4 2009, 01:14 PM']I wonder why they're dropping features like this? This will force everybody to start using nHancer to tweak profiles. Maybe that's their goal?

Their goal is to force us to use that goddamn physx and forget about everything else. It's shipping with every driver making them huge files and I've NEVER used it, ever.

#12
Posted 11/04/2009 05:47 PM   
Scroll To Top