Why is vsync not working?
Ok im trying to play fear 2 and i like to play with vsync on ive turned it off in the ingame settings and im trying to force it on in the control panel. So because fear 2 installs via steam i open steam and go create shortcut icon and it places fear 2 on the desktop i then add that to the NVCP and force vsync on and tripple buffering etc but its not working. And in the NVCP it says steam instead of fear 2 please helpp
Ok im trying to play fear 2 and i like to play with vsync on ive turned it off in the ingame settings and im trying to force it on in the control panel. So because fear 2 installs via steam i open steam and go create shortcut icon and it places fear 2 on the desktop i then add that to the NVCP and force vsync on and tripple buffering etc but its not working. And in the NVCP it says steam instead of fear 2 please helpp

Core i7 920@ 4.20ghz
Asus P6T Motherboard
6GB Corsair DDR3 Memory
Palit Gtx 295
500GB WD And 500GB Hitachi Hard Drive
500GB Iomega External Drive
Antec 1200 Case
1000W CoolerMaster Power Supply
Windows Vista Ultimate 64 Bit.

#1
Posted 05/31/2009 02:15 AM   
dont bother forcing it in the control panel, or using it through FEAR 2.

It causes stutter.

Secondly, the contol panel triple buffering is for OpenGL apps only. So it won't have any effect on FEAR 2.

For the best results (it eliminates stutter) use the D3D overrider tool bundled with Rivatuner. Force Vsync and Triple Buffering with that and you will get rid of the stutter, activate triple buffering and have Vsync all in one.

Use the triple buffering in D3D Overrider for ALL your games that use direct3d. And you will see a noticeable difference when compared to forcing it in CP. Simply because it doesnt work for anything but OpenGL.
dont bother forcing it in the control panel, or using it through FEAR 2.



It causes stutter.



Secondly, the contol panel triple buffering is for OpenGL apps only. So it won't have any effect on FEAR 2.



For the best results (it eliminates stutter) use the D3D overrider tool bundled with Rivatuner. Force Vsync and Triple Buffering with that and you will get rid of the stutter, activate triple buffering and have Vsync all in one.



Use the triple buffering in D3D Overrider for ALL your games that use direct3d. And you will see a noticeable difference when compared to forcing it in CP. Simply because it doesnt work for anything but OpenGL.

CPU: Core i7 930 @ 4.20ghz 1.3v cooled by Antec Kuhler 920

MOBO: Asus P6X58D Premium

GFX: 2x Asus GTX 560Ti Direct CUII @ 900mhz Core 2200mhz Memory

RAM: Corsair CMG6GX3M3A1600C7 6gb 1600mhz 7-7-7-20 2t

PSU: Thermaltake Toughpower 850 watt

CASE: Antec 1200

APU: X-fi Titanium Fatality SPEAKERS: Logitech X-530 5.1

HDD: 1x OCZ Agility 3 60gb SSD GAMES 2x Western Digital Caviar Black 500gb in RAID 0

DISPLAY: Acer H243HX 24" @ 1920x1080 Resolution

KEYBOARD: Logitech G19 MOUSE: Logitech G5 WHEEL Logitech G25 JOYSTICK Logitech G940

OPERATING SYSTEM: Windows 7 Ultimate x64 RTM

#2
Posted 05/31/2009 02:36 AM   
[quote name='0408SL' post='308266' date='May 31 2009, 01:06 PM']dont bother forcing it in the control panel, or using it through FEAR 2.

It causes stutter.

Secondly, the contol panel triple buffering is for OpenGL apps only. So it won't have any effect on FEAR 2.

For the best results (it eliminates stutter) use the D3D overrider tool bundled with Rivatuner. Force Vsync and Triple Buffering with that and you will get rid of the stutter, activate triple buffering and have Vsync all in one.

Use the triple buffering in D3D Overrider for ALL your games that use direct3d. And you will see a noticeable difference when compared to forcing it in CP. Simply because it doesnt work for anything but OpenGL.[/quote]

So how come vsync in and tripple buffering works with all my other games such as cod 4 and 5, rainbow six vegas, dead space etc in the control panel. But fear 2 doesnt
[quote name='0408SL' post='308266' date='May 31 2009, 01:06 PM']dont bother forcing it in the control panel, or using it through FEAR 2.



It causes stutter.



Secondly, the contol panel triple buffering is for OpenGL apps only. So it won't have any effect on FEAR 2.



For the best results (it eliminates stutter) use the D3D overrider tool bundled with Rivatuner. Force Vsync and Triple Buffering with that and you will get rid of the stutter, activate triple buffering and have Vsync all in one.



Use the triple buffering in D3D Overrider for ALL your games that use direct3d. And you will see a noticeable difference when compared to forcing it in CP. Simply because it doesnt work for anything but OpenGL.



So how come vsync in and tripple buffering works with all my other games such as cod 4 and 5, rainbow six vegas, dead space etc in the control panel. But fear 2 doesnt

Core i7 920@ 4.20ghz
Asus P6T Motherboard
6GB Corsair DDR3 Memory
Palit Gtx 295
500GB WD And 500GB Hitachi Hard Drive
500GB Iomega External Drive
Antec 1200 Case
1000W CoolerMaster Power Supply
Windows Vista Ultimate 64 Bit.

#3
Posted 05/31/2009 02:54 AM   
I play WOW with vsync and triple bufflering enabled through the control panel and it caps at 60 fps. If I disable it I get fps in the hundreds. Appears to work with more than opengl to me. Because I dont use the -opengl switch to play WOW. Am I missing something?
I play WOW with vsync and triple bufflering enabled through the control panel and it caps at 60 fps. If I disable it I get fps in the hundreds. Appears to work with more than opengl to me. Because I dont use the -opengl switch to play WOW. Am I missing something?

#4
Posted 05/31/2009 03:27 AM   
[quote name='sfeltch' post='308272' date='May 30 2009, 10:27 PM']I play WOW with vsync and triple bufflering enabled through the control panel and it caps at 60 fps. If I disable it I get fps in the hundreds. Appears to work with more than opengl to me. Because I dont use the -opengl switch to play WOW. Am I missing something?[/quote]

[url="http://en.wikipedia.org/wiki/Vertical_synchronization"]VSYNC explained[/url]

...but i even saved you the trouble of reading all that:

[quote]This can cause lowered [u][url="http://en.wikipedia.org/wiki/Frame_rate"]frame rates[/url][/u] due to latency (the period of the [url="http://en.wikipedia.org/wiki/Refresh_rate"]refresh rate[/url] at maximum), which might be undesirable in games that require fast response (e.g. [url="http://en.wikipedia.org/wiki/First_person_shooters"]first person shooters[/url]), although in practise it is impossible to achieve a visible [url="http://en.wikipedia.org/wiki/Frame_rate"]frame rate[/url] faster than the [url="http://en.wikipedia.org/wiki/Refresh_rate"]refresh rate[/url] of the monitor.[/quote]
[quote name='sfeltch' post='308272' date='May 30 2009, 10:27 PM']I play WOW with vsync and triple bufflering enabled through the control panel and it caps at 60 fps. If I disable it I get fps in the hundreds. Appears to work with more than opengl to me. Because I dont use the -opengl switch to play WOW. Am I missing something?



VSYNC explained



...but i even saved you the trouble of reading all that:



This can cause lowered frame rates due to latency (the period of the refresh rate at maximum), which might be undesirable in games that require fast response (e.g. first person shooters), although in practise it is impossible to achieve a visible frame rate faster than the refresh rate of the monitor.

#5
Posted 05/31/2009 03:20 PM   
Huh?

A2K, my response was to support that vsync and triple buffering does in fact seem to work in direct3d apps activated from the nvidia control panel. Due to the fact it works in WOW for me. Not to mention that it not only caps my fps but removes screen tearing that I can always reproduce by flying in the game. Doesnt exist with vsync and triple buffering enabled.
Huh?



A2K, my response was to support that vsync and triple buffering does in fact seem to work in direct3d apps activated from the nvidia control panel. Due to the fact it works in WOW for me. Not to mention that it not only caps my fps but removes screen tearing that I can always reproduce by flying in the game. Doesnt exist with vsync and triple buffering enabled.

#6
Posted 05/31/2009 04:50 PM   
[quote name='sfeltch' post='308272' date='May 31 2009, 03:27 AM']I play WOW with vsync and triple bufflering enabled through the control panel and it caps at 60 fps. If I disable it I get fps in the hundreds. Appears to work with more than opengl to me. Because I dont use the -opengl switch to play WOW. Am I missing something?[/quote]

Here is a link explaining triple buffering and its relavence to the NVCP settings.

[url="http://www.tweakguides.com/Graphics_10.html"]http://www.tweakguides.com/Graphics_10.html[/url]

This information can be confirmed by this information here on the nHancer website.

[url="http://www.nhancer.com/?dat=d_enhancements#VSync"]http://www.nhancer.com/?dat=d_enhancements#VSync[/url]

Also, it caps the FPS because Vsync controls both OpenGL & direct3d in the NVCPL. as confirmed by the nHancer website.

But you are not triple buffering, which means when you enable it correctly you will get a nice FPS boost and alot smoother mouse input.
[quote name='sfeltch' post='308272' date='May 31 2009, 03:27 AM']I play WOW with vsync and triple bufflering enabled through the control panel and it caps at 60 fps. If I disable it I get fps in the hundreds. Appears to work with more than opengl to me. Because I dont use the -opengl switch to play WOW. Am I missing something?



Here is a link explaining triple buffering and its relavence to the NVCP settings.



http://www.tweakguides.com/Graphics_10.html



This information can be confirmed by this information here on the nHancer website.



http://www.nhancer.com/?dat=d_enhancements#VSync



Also, it caps the FPS because Vsync controls both OpenGL & direct3d in the NVCPL. as confirmed by the nHancer website.



But you are not triple buffering, which means when you enable it correctly you will get a nice FPS boost and alot smoother mouse input.

CPU: Core i7 930 @ 4.20ghz 1.3v cooled by Antec Kuhler 920

MOBO: Asus P6X58D Premium

GFX: 2x Asus GTX 560Ti Direct CUII @ 900mhz Core 2200mhz Memory

RAM: Corsair CMG6GX3M3A1600C7 6gb 1600mhz 7-7-7-20 2t

PSU: Thermaltake Toughpower 850 watt

CASE: Antec 1200

APU: X-fi Titanium Fatality SPEAKERS: Logitech X-530 5.1

HDD: 1x OCZ Agility 3 60gb SSD GAMES 2x Western Digital Caviar Black 500gb in RAID 0

DISPLAY: Acer H243HX 24" @ 1920x1080 Resolution

KEYBOARD: Logitech G19 MOUSE: Logitech G5 WHEEL Logitech G25 JOYSTICK Logitech G940

OPERATING SYSTEM: Windows 7 Ultimate x64 RTM

#7
Posted 06/01/2009 08:58 AM   
[quote name='KFORM' post='308268' date='May 31 2009, 02:54 AM']So how come vsync in and tripple buffering works with all my other games such as cod 4 and 5, rainbow six vegas, dead space etc in the control panel. But fear 2 doesnt[/quote]

please read the links posted above.

They explain why.

You will find COD4 and 5 and rainbow six and dead space run much better both with Vsync on and triple buffering correctly enabled.

Also did you try it with FEAR 2 using d3doverrider? did it fix your issue?

Hope so!
[quote name='KFORM' post='308268' date='May 31 2009, 02:54 AM']So how come vsync in and tripple buffering works with all my other games such as cod 4 and 5, rainbow six vegas, dead space etc in the control panel. But fear 2 doesnt



please read the links posted above.



They explain why.



You will find COD4 and 5 and rainbow six and dead space run much better both with Vsync on and triple buffering correctly enabled.



Also did you try it with FEAR 2 using d3doverrider? did it fix your issue?



Hope so!

CPU: Core i7 930 @ 4.20ghz 1.3v cooled by Antec Kuhler 920

MOBO: Asus P6X58D Premium

GFX: 2x Asus GTX 560Ti Direct CUII @ 900mhz Core 2200mhz Memory

RAM: Corsair CMG6GX3M3A1600C7 6gb 1600mhz 7-7-7-20 2t

PSU: Thermaltake Toughpower 850 watt

CASE: Antec 1200

APU: X-fi Titanium Fatality SPEAKERS: Logitech X-530 5.1

HDD: 1x OCZ Agility 3 60gb SSD GAMES 2x Western Digital Caviar Black 500gb in RAID 0

DISPLAY: Acer H243HX 24" @ 1920x1080 Resolution

KEYBOARD: Logitech G19 MOUSE: Logitech G5 WHEEL Logitech G25 JOYSTICK Logitech G940

OPERATING SYSTEM: Windows 7 Ultimate x64 RTM

#8
Posted 06/01/2009 09:04 AM   
Yeah, some games just seem to be able to resist Vsync and triple buffereing applied via the nvcpl. As 0408SL says, the Rivatuner D3D overrider works in most cases.

Word of warning, though. If you play GTA4, the SecuROM launcher crashes if you have D3Doverrider running. This prevents the game from starting. You don't need D3Doverrider for GTA4, though, so it's not a problem. Just took me (and Sony) a while to work out what was causing it.
Yeah, some games just seem to be able to resist Vsync and triple buffereing applied via the nvcpl. As 0408SL says, the Rivatuner D3D overrider works in most cases.



Word of warning, though. If you play GTA4, the SecuROM launcher crashes if you have D3Doverrider running. This prevents the game from starting. You don't need D3Doverrider for GTA4, though, so it's not a problem. Just took me (and Sony) a while to work out what was causing it.

Core i5 4670K @ 4.3GHz with 4GHz uncore
Corsair H100 water cooler
8GB Patriot Viper DDR3 @ 2400MHz
Gigabyte Z87X-OC mobo
SLI eVGA GTX670 FTW (1227MHz boost 6800MHz VRAM)
Soundblaster Z with 5.1 speakers
112GB OCZ Vertex 3 SSD
240GB OCZ Vertex 4 SSD
Corsair Carbide 500R case (white)
Akasa PowerXtreme 1200W PSU
HP ZR2740W 2560 x 1440 27" IPS panel
Windows 7 Pro 64bit

#9
Posted 06/01/2009 11:44 AM   
[quote name='0408SL' post='308530' date='Jun 1 2009, 12:58 AM']Here is a link explaining triple buffering and its relavence to the NVCP settings.

[url="http://www.tweakguides.com/Graphics_10.html"]http://www.tweakguides.com/Graphics_10.html[/url][/quote]
Very nice guide you linked to. It's bound to solve a lot of tearing and fps drop issues many members of our forums complain of.
[quote name='0408SL' post='308530' date='Jun 1 2009, 12:58 AM']Here is a link explaining triple buffering and its relavence to the NVCP settings.



http://www.tweakguides.com/Graphics_10.html

Very nice guide you linked to. It's bound to solve a lot of tearing and fps drop issues many members of our forums complain of.

#10
Posted 06/05/2009 12:04 PM   
Scroll To Top