Switching To AHCI Nvidia nForce Drivers
Hi there.
I have currently got XP 32bit installed on my system with the 780a Chipset.
The sata controller is currently running in IDE mode, however i am aware of the benefits of AHCI mode.
I am aware that the standard way to use AHCI is to install the drivers at boot

With Windows 7 on the way I intend to shrink my XP partition and install Win 7 alongside.
I want to be using AHCI when I do this, so I want to enable AHCI on my current XP install

If I run the nvidia driver package, then it doesnt offer me the option to install the raid/ahci drivers
Is there anyway to force the drivers to install / can anyone walk me through manually installing them?
Thanks
Hi there.

I have currently got XP 32bit installed on my system with the 780a Chipset.

The sata controller is currently running in IDE mode, however i am aware of the benefits of AHCI mode.

I am aware that the standard way to use AHCI is to install the drivers at boot



With Windows 7 on the way I intend to shrink my XP partition and install Win 7 alongside.

I want to be using AHCI when I do this, so I want to enable AHCI on my current XP install



If I run the nvidia driver package, then it doesnt offer me the option to install the raid/ahci drivers

Is there anyway to force the drivers to install / can anyone walk me through manually installing them?

Thanks

AMD Phenom II X4 940 Black Edition 3.92ghz
XFX GTX 260 XXX Edition 896Mb PCI-E GFX Card
4096MB OCZ Reaper DDR2 1066 RAM
Samsung SyncMaster 226BW Display
Asus Crosshair II Formula Motherboard
Corsair Hydro H50-1 Watercooling
1000 GB Samsung F1 Hard Disk Drive
LG Blu-Ray & HD-DVD Drive
Corsair HX 850w Modular PSU
Custom Black Dual Cathode Windowed Case
Logitech Driving Force Pro
Wireless Xbox 360 controller
5.1 Channel Surround Sound Speakers
Bluetooth Wireless Enabled w Bluetooth Headphones
15 Enhanced USB ports (12 rear / 2 front/ 1 internal)
Windows 7 Home Premium 64bit
Windows XP Professional Edition
Razer Copperhead 2000dpi Gaming Mouse
Twin-touch 16e Wireless Keyboard

#1
Posted 10/18/2009 08:08 PM   
[quote name='madness_3d' post='602498' date='Oct 18 2009, 10:08 PM']If I run the nvidia driver package, then it doesnt offer me the option to install the raid/ahci drivers
Is there anyway to force the drivers to install / can anyone walk me through manually installing them?[/quote]
The problem is that NVIDIA chose to change the PCI device ID when you change the SATA controller mode. So while in IDE mode, the AHCI device is not "seen" and thus the AHCI driver cannot be installed.

The workaround is to "sneak" the AHCI driver into the registry (and the driver SYS into the Drivers directory), then reboot in AHCI mode and install the driver properly. The catch is that the registry entries may be very specific to your motherboard.

On my ASUS Crosshair II, the following registry file worked for me (created by installing Windows XP x64 clean in AHCI mode, exporting the registry entries and editing out the "64" from the driver binary name):

[code]REGEDIT4

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\CriticalDeviceDatabase\pci#ven_10de&dev_0ad4&cc_0106]
"ClassGUID"="{4D36E96A-E325-11CE-BFC1-08002BE10318}"
"Service"="nvgts"

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\nvgts]
"Type"=dword:00000001
"Start"=dword:00000000
"Group"="SCSI miniport"
"ErrorControl"=dword:00000003
"ImagePath"="System32\\Drivers\\nvgts.sys"
"Tag"=dword:00000021
"DisableFilterCache"=dword:00000001

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\nvgts\parameters]
"BusType"=dword:00000003

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\nvgts\parameters\PnpInterface]
"5"=dword:00000001

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\nvgts\Enum]
"Count"=dword:00000001
"NextInstance"=dword:00000001
"0"="PCI\\VEN_10DE&DEV_0AD4&SUBSYS_83321043&REV_A2\\3&2411e6fe&2&48"[/code]
Copy the above lines to Notepad and save them e.g. as "nForce_780a_AHCI_32bit.reg". Unpack the latest NVIDIA nForce chipset drivers, go to the IDE\WinXP\sata_ide subdirectory and copy the file "nvgts.sys" to your Windows\System32\Drivers directory. Then run the registry file you saved, restart the machine, enter BIOS setup and change the SATA mode to AHCI. Save and restart and see if Windows XP boots. If it does, you've made it! Just run the nForce chipset driver installer to "properly" install the AHCI driver you sneaked in.

If Windows XP does not boot after changing the SATA mode to AHCI, change it back to IDE and try booting again. If it boots now, it is probably the very last line from the registry file which needs to be adjusted to your machine...

Disclaimer: Do this at your own risk. If this wrecks your Windows XP installation, don't hold me responsible. All I'm saying is that the above procedure worked for me.
[quote name='madness_3d' post='602498' date='Oct 18 2009, 10:08 PM']If I run the nvidia driver package, then it doesnt offer me the option to install the raid/ahci drivers

Is there anyway to force the drivers to install / can anyone walk me through manually installing them?

The problem is that NVIDIA chose to change the PCI device ID when you change the SATA controller mode. So while in IDE mode, the AHCI device is not "seen" and thus the AHCI driver cannot be installed.



The workaround is to "sneak" the AHCI driver into the registry (and the driver SYS into the Drivers directory), then reboot in AHCI mode and install the driver properly. The catch is that the registry entries may be very specific to your motherboard.



On my ASUS Crosshair II, the following registry file worked for me (created by installing Windows XP x64 clean in AHCI mode, exporting the registry entries and editing out the "64" from the driver binary name):



REGEDIT4



[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\CriticalDeviceDatabase\pci#ven_10de&dev_0ad4&cc_0106]

"ClassGUID"="{4D36E96A-E325-11CE-BFC1-08002BE10318}"

"Service"="nvgts"



[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\nvgts]

"Type"=dword:00000001

"Start"=dword:00000000

"Group"="SCSI miniport"

"ErrorControl"=dword:00000003

"ImagePath"="System32\\Drivers\\nvgts.sys"

"Tag"=dword:00000021

"DisableFilterCache"=dword:00000001



[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\nvgts\parameters]

"BusType"=dword:00000003



[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\nvgts\parameters\PnpInterface]

"5"=dword:00000001



[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\nvgts\Enum]

"Count"=dword:00000001

"NextInstance"=dword:00000001

"0"="PCI\\VEN_10DE&DEV_0AD4&SUBSYS_83321043&REV_A2\\3&2411e6fe&2&48"


Copy the above lines to Notepad and save them e.g. as "nForce_780a_AHCI_32bit.reg". Unpack the latest NVIDIA nForce chipset drivers, go to the IDE\WinXP\sata_ide subdirectory and copy the file "nvgts.sys" to your Windows\System32\Drivers directory. Then run the registry file you saved, restart the machine, enter BIOS setup and change the SATA mode to AHCI. Save and restart and see if Windows XP boots. If it does, you've made it! Just run the nForce chipset driver installer to "properly" install the AHCI driver you sneaked in.



If Windows XP does not boot after changing the SATA mode to AHCI, change it back to IDE and try booting again. If it boots now, it is probably the very last line from the registry file which needs to be adjusted to your machine...



Disclaimer: Do this at your own risk. If this wrecks your Windows XP installation, don't hold me responsible. All I'm saying is that the above procedure worked for me.

#2
Posted 10/18/2009 08:46 PM   
[quote name='robert_s' post='602508' date='Oct 18 2009, 09:46 PM']The problem is that NVIDIA chose to change the PCI device ID when you change the SATA controller mode. So while in IDE mode, the AHCI device is not "seen" and thus the AHCI driver cannot be installed.

The workaround is to "sneak" the AHCI driver into the registry (and the driver SYS into the Drivers directory), then reboot in AHCI mode and install the driver properly. The catch is that the registry entries may be very specific to your motherboard.

On my ASUS Crosshair II, the following registry file worked for me (created by installing Windows XP x64 clean in AHCI mode, exporting the registry entries and editing out the "64" from the driver binary name):

[code]REGEDIT4

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\CriticalDeviceDatabase\pci#ven_10de&dev_0ad4&cc_0106]
"ClassGUID"="{4D36E96A-E325-11CE-BFC1-08002BE10318}"
"Service"="nvgts"

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\nvgts]
"Type"=dword:00000001
"Start"=dword:00000000
"Group"="SCSI miniport"
"ErrorControl"=dword:00000003
"ImagePath"="System32\\Drivers\\nvgts.sys"
"Tag"=dword:00000021
"DisableFilterCache"=dword:00000001

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\nvgts\parameters]
"BusType"=dword:00000003

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\nvgts\parameters\PnpInterface]
"5"=dword:00000001

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\nvgts\Enum]
"Count"=dword:00000001
"NextInstance"=dword:00000001
"0"="PCI\\VEN_10DE&DEV_0AD4&SUBSYS_83321043&REV_A2\\3&2411e6fe&2&48"[/code]
Copy the above lines to Notepad and save them e.g. as "nForce_780a_AHCI_32bit.reg". Unpack the latest NVIDIA nForce chipset drivers, go to the IDE\WinXP\sata_ide subdirectory and copy the file "nvgts.sys" to your Windows\System32\Drivers directory. Then run the registry file you saved, restart the machine, enter BIOS setup and change the SATA mode to AHCI. Save and restart and see if Windows XP boots. If it does, you've made it! Just run the nForce chipset driver installer to "properly" install the AHCI driver you sneaked in.

If Windows XP does not boot after changing the SATA mode to AHCI, change it back to IDE and try booting again. If it boots now, it is probably the very last line from the registry file which needs to be adjusted to your machine...

Disclaimer: Do this at your own risk. If this wrecks your Windows XP installation, don't hold me responsible. All I'm saying is that the above procedure worked for me.[/quote]
I did it and it worked perfectly!
the only snag is that its brought up windows genuine advantage and it says that my hardware has changed significantly :S
working on that now...

edit: fixed now so Thank You!
[quote name='robert_s' post='602508' date='Oct 18 2009, 09:46 PM']The problem is that NVIDIA chose to change the PCI device ID when you change the SATA controller mode. So while in IDE mode, the AHCI device is not "seen" and thus the AHCI driver cannot be installed.



The workaround is to "sneak" the AHCI driver into the registry (and the driver SYS into the Drivers directory), then reboot in AHCI mode and install the driver properly. The catch is that the registry entries may be very specific to your motherboard.



On my ASUS Crosshair II, the following registry file worked for me (created by installing Windows XP x64 clean in AHCI mode, exporting the registry entries and editing out the "64" from the driver binary name):



REGEDIT4



[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\CriticalDeviceDatabase\pci#ven_10de&dev_0ad4&cc_0106]

"ClassGUID"="{4D36E96A-E325-11CE-BFC1-08002BE10318}"

"Service"="nvgts"



[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\nvgts]

"Type"=dword:00000001

"Start"=dword:00000000

"Group"="SCSI miniport"

"ErrorControl"=dword:00000003

"ImagePath"="System32\\Drivers\\nvgts.sys"

"Tag"=dword:00000021

"DisableFilterCache"=dword:00000001



[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\nvgts\parameters]

"BusType"=dword:00000003



[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\nvgts\parameters\PnpInterface]

"5"=dword:00000001



[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\nvgts\Enum]

"Count"=dword:00000001

"NextInstance"=dword:00000001

"0"="PCI\\VEN_10DE&DEV_0AD4&SUBSYS_83321043&REV_A2\\3&2411e6fe&2&48"


Copy the above lines to Notepad and save them e.g. as "nForce_780a_AHCI_32bit.reg". Unpack the latest NVIDIA nForce chipset drivers, go to the IDE\WinXP\sata_ide subdirectory and copy the file "nvgts.sys" to your Windows\System32\Drivers directory. Then run the registry file you saved, restart the machine, enter BIOS setup and change the SATA mode to AHCI. Save and restart and see if Windows XP boots. If it does, you've made it! Just run the nForce chipset driver installer to "properly" install the AHCI driver you sneaked in.



If Windows XP does not boot after changing the SATA mode to AHCI, change it back to IDE and try booting again. If it boots now, it is probably the very last line from the registry file which needs to be adjusted to your machine...



Disclaimer: Do this at your own risk. If this wrecks your Windows XP installation, don't hold me responsible. All I'm saying is that the above procedure worked for me.

I did it and it worked perfectly!

the only snag is that its brought up windows genuine advantage and it says that my hardware has changed significantly :S

working on that now...



edit: fixed now so Thank You!

AMD Phenom II X4 940 Black Edition 3.92ghz
XFX GTX 260 XXX Edition 896Mb PCI-E GFX Card
4096MB OCZ Reaper DDR2 1066 RAM
Samsung SyncMaster 226BW Display
Asus Crosshair II Formula Motherboard
Corsair Hydro H50-1 Watercooling
1000 GB Samsung F1 Hard Disk Drive
LG Blu-Ray & HD-DVD Drive
Corsair HX 850w Modular PSU
Custom Black Dual Cathode Windowed Case
Logitech Driving Force Pro
Wireless Xbox 360 controller
5.1 Channel Surround Sound Speakers
Bluetooth Wireless Enabled w Bluetooth Headphones
15 Enhanced USB ports (12 rear / 2 front/ 1 internal)
Windows 7 Home Premium 64bit
Windows XP Professional Edition
Razer Copperhead 2000dpi Gaming Mouse
Twin-touch 16e Wireless Keyboard

#3
Posted 10/18/2009 10:43 PM   
[quote name='madness_3d' post='602547' date='Oct 19 2009, 12:43 AM']I did it and it worked perfectly!

edit: fixed now so Thank You![/quote]
You're welcome :)
[quote name='madness_3d' post='602547' date='Oct 19 2009, 12:43 AM']I did it and it worked perfectly!



edit: fixed now so Thank You!

You're welcome :)

#4
Posted 10/19/2009 12:28 AM   
@robert_s:

Works here too, out of the box, on a 720D mobo. Thanks and cheers, you saved me a re-installation!
@robert_s:



Works here too, out of the box, on a 720D mobo. Thanks and cheers, you saved me a re-installation!

#5
Posted 01/08/2010 08:33 PM   
This worked on a MSI NF980-G65 also. Thanks, you've also saved me a re-installation
This worked on a MSI NF980-G65 also. Thanks, you've also saved me a re-installation

#6
Posted 12/04/2012 10:46 PM   
Hi all ! I'm on xp 64 and wanted to know if i can use the 32 bits version of nvgts to sneak the ahci mode and then intall properly the 64 bits version, or directly put the x64 version and edit the .reg file ( i don't know if i have to add 64 after all the nvgts names ! ) ! Thanks guys !
Hi all ! I'm on xp 64 and wanted to know if i can use the 32 bits version of nvgts to sneak the ahci mode and then intall properly the 64 bits version, or directly put the x64 version and edit the .reg file ( i don't know if i have to add 64 after all the nvgts names ! ) !

Thanks guys !

#7
Posted 04/05/2013 06:45 AM   
Read [url=http://tweaks.com/windows/44119/improve-sata-hard-disk-performance-convert-from-ide-to-ahci/]this[/url]
Read this

My Opinion is no more important or right than yours. But if your using the LATEST drivers, go back to the prior set.

Piss Poor tech support blame all issues on drivers and assumes that your an idiot. Find a set that you know worked and see if the problem exists still.

""Don't f with it if it ain't broken!""

Constantly updating drivers is a good way to F'up the whole system.

#8
Posted 04/05/2013 12:54 PM   
Scroll To Top