Windows 7 Audio Driver for GeForce 7050 / NVIDIA nForce 610i Motherboard
Hi All,

I've installed Windows 7 RC in my Desktop PC. Everything except the audio works fine.
My motherboard is Galaxy GeForce 7050 / NVIDIA nForce 610i.
I've searched in the NVIDIA website for the driver and couldn't find the audio driver.
Could anyone of you help me out with this??? Greatly appreciate your response and support.
Thanks!
Hi All,



I've installed Windows 7 RC in my Desktop PC. Everything except the audio works fine.

My motherboard is Galaxy GeForce 7050 / NVIDIA nForce 610i.

I've searched in the NVIDIA website for the driver and couldn't find the audio driver.

Could anyone of you help me out with this??? Greatly appreciate your response and support.

Thanks!

#1
Posted 07/29/2009 04:46 PM   
[quote name='Sudeep P Nambiar' post='571507' date='Jul 30 2009, 12:46 AM']Hi All,

I've installed Windows 7 RC in my Desktop PC. Everything except the audio works fine.
My motherboard is Galaxy GeForce 7050 / NVIDIA nForce 610i.
I've searched in the NVIDIA website for the driver and couldn't find the audio driver.
Could anyone of you help me out with this??? Greatly appreciate your response and support.
Thanks![/quote]
If I'm not wrong, these series of motherboards are using Realtek HD chip? Why not try to download the latest Realtek HD audo drivers? They work for me.
[quote name='Sudeep P Nambiar' post='571507' date='Jul 30 2009, 12:46 AM']Hi All,



I've installed Windows 7 RC in my Desktop PC. Everything except the audio works fine.

My motherboard is Galaxy GeForce 7050 / NVIDIA nForce 610i.

I've searched in the NVIDIA website for the driver and couldn't find the audio driver.

Could anyone of you help me out with this??? Greatly appreciate your response and support.

Thanks!

If I'm not wrong, these series of motherboards are using Realtek HD chip? Why not try to download the latest Realtek HD audo drivers? They work for me.

#2
Posted 07/30/2009 07:27 AM   
[quote name='Kiwi8' post='571809' date='Jul 30 2009, 12:57 PM']If I'm not wrong, these series of motherboards are using Realtek HD chip? Why not try to download the latest Realtek HD audo drivers? They work for me.[/quote]
Yes, you are right. This series of Motherboards use Realtek HD chip. I've tried downloading and installing the drivers from Realtek as well. But nothing seems to work out. Just thought if i could get some inputs from here, it would be great and i can make my audio work.
[quote name='Kiwi8' post='571809' date='Jul 30 2009, 12:57 PM']If I'm not wrong, these series of motherboards are using Realtek HD chip? Why not try to download the latest Realtek HD audo drivers? They work for me.

Yes, you are right. This series of Motherboards use Realtek HD chip. I've tried downloading and installing the drivers from Realtek as well. But nothing seems to work out. Just thought if i could get some inputs from here, it would be great and i can make my audio work.

#3
Posted 07/30/2009 07:44 AM   
Try [url="http://downloads.guru3d.com/Realtek-HD-Audio-2.29-Driver-download-2337.html"]these drivers[/url]. If they don't work, you have some other issue than missing drivers.
Try these drivers. If they don't work, you have some other issue than missing drivers.

#4
Posted 07/30/2009 12:06 PM   
[quote name='Hexen525' post='571902' date='Jul 30 2009, 05:36 PM']Try [url="http://downloads.guru3d.com/Realtek-HD-Audio-2.29-Driver-download-2337.html"]these drivers[/url]. If they don't work, you have some other issue than missing drivers.[/quote]

Hi Hexen 525

I did exactly what you have said & my audio problem in the comp is resolved. Thanks a lot after a week of agony.
[quote name='Hexen525' post='571902' date='Jul 30 2009, 05:36 PM']Try these drivers. If they don't work, you have some other issue than missing drivers.



Hi Hexen 525



I did exactly what you have said & my audio problem in the comp is resolved. Thanks a lot after a week of agony.

#5
Posted 01/17/2010 01:55 PM   
Scroll To Top