Far Cry 2 stability
I've been having a few stability problems with the newer (from 185 (?) up to 190) drivers while playing Far Cry 2. Here's a list:

1. After a random time playing, everything 2-d looses sync, framerate halves, and the windows log is flooded with 'nv' errors. Using v-sync usually extends playable time...
2. Geting bluescreens when enabling AA. (fine, can do without)
3. Loading takes forever. (seems to bother both ATi and Nvidia, discussing is useless here)

I tried disabling my oc's. Didn't work. Tried increasing my fan speeds (CPU temp was a bit high), didn't work. Prime95 ran faultless for over 2 hours untill I decided to stop it, 3dmark06 gave me a score of 5000/5000/1500, no problems or weird stuff on screen at all. The only thing I haven't tried yet is installing older drivers...

System:
AMD Athlon 64 4000+ , ~2.5 GHz. Max allowed temp: 65C, reached 65C with lower aux-fan speed. Doesn't exceed 62C now.
Nvidia GeForce 9600GT, 766/1035. Temp perfectly fine, under 75C. Perfectly stable.
2GB MDT DDR1 RAM, MSI K8N MoBo.

Any ideas on point one? Or two?
I've been having a few stability problems with the newer (from 185 (?) up to 190) drivers while playing Far Cry 2. Here's a list:



1. After a random time playing, everything 2-d looses sync, framerate halves, and the windows log is flooded with 'nv' errors. Using v-sync usually extends playable time...

2. Geting bluescreens when enabling AA. (fine, can do without)

3. Loading takes forever. (seems to bother both ATi and Nvidia, discussing is useless here)



I tried disabling my oc's. Didn't work. Tried increasing my fan speeds (CPU temp was a bit high), didn't work. Prime95 ran faultless for over 2 hours untill I decided to stop it, 3dmark06 gave me a score of 5000/5000/1500, no problems or weird stuff on screen at all. The only thing I haven't tried yet is installing older drivers...



System:

AMD Athlon 64 4000+ , ~2.5 GHz. Max allowed temp: 65C, reached 65C with lower aux-fan speed. Doesn't exceed 62C now.

Nvidia GeForce 9600GT, 766/1035. Temp perfectly fine, under 75C. Perfectly stable.

2GB MDT DDR1 RAM, MSI K8N MoBo.



Any ideas on point one? Or two?

#1
Posted 07/27/2009 07:14 AM   
hai there,

I seem to have problems with far cry 2 too, I get bluescreens sometimes and other times the game just crashes to desktop with a warning that my display drivers have stopped working. if I boot far cry 2 again after that last warning I get a dramatically low fps from around 22-28, normaly I have 34-56 with everything maxed out including AA and 1920x1200, the reason for the fps drop is because my gtx 280 is throttling down to low power mode, somehow it doesn't want to get out of that mode unless I reboot my pc, this problem only occurs with far cry 2.

My system:

q6600 4x 2.4GHz.
gtx 280 oc'd ( stock makes the game quit too )
3.3 gb RAM.
650W PSU.
My temps are also fine.


I think that me and orwell are having a bit of the same problem apart from the fact that his card isn't having a low power mode probably.
hai there,



I seem to have problems with far cry 2 too, I get bluescreens sometimes and other times the game just crashes to desktop with a warning that my display drivers have stopped working. if I boot far cry 2 again after that last warning I get a dramatically low fps from around 22-28, normaly I have 34-56 with everything maxed out including AA and 1920x1200, the reason for the fps drop is because my gtx 280 is throttling down to low power mode, somehow it doesn't want to get out of that mode unless I reboot my pc, this problem only occurs with far cry 2.



My system:



q6600 4x 2.4GHz.

gtx 280 oc'd ( stock makes the game quit too )

3.3 gb RAM.

650W PSU.

My temps are also fine.





I think that me and orwell are having a bit of the same problem apart from the fact that his card isn't having a low power mode probably.

#2
Posted 08/06/2009 10:00 AM   
What Operating System do you have? [Update your OS to the latest Service Pack from Microsoft -> XP = SP3 | Vista = SP2]

It should work with a ORIGINAL XP/Vista/Win7

And did you patched your game to Version 1.03 ??
What Operating System do you have? [Update your OS to the latest Service Pack from Microsoft -> XP = SP3 | Vista = SP2]



It should work with a ORIGINAL XP/Vista/Win7



And did you patched your game to Version 1.03 ??

#3
Posted 08/09/2009 12:18 AM   
I spent the best part of 3 days trying to sort this problem. I tried 2 different OS's and every other possible thing you could imagine. It turns out any driver AFTER 182.50 causes major problems. So I rolled back too 182.50 and everything is fine. I only found this out after 4 hours of searching the web, and one guy had the exact same problems as me. So a big thanks to him because I wouldn't of guessed it was a driver issue, as I had already tried 5 different ones with no luck. I may add all my other games work fine with any of the drivers, it was just far cry 2 that had the issues. So thanks a lot nvidia /thumbsdown.gif' class='bbc_emoticon' alt=':thumbsdown:' />

So guys just roll back and everything should be fine! G'luck :)
I spent the best part of 3 days trying to sort this problem. I tried 2 different OS's and every other possible thing you could imagine. It turns out any driver AFTER 182.50 causes major problems. So I rolled back too 182.50 and everything is fine. I only found this out after 4 hours of searching the web, and one guy had the exact same problems as me. So a big thanks to him because I wouldn't of guessed it was a driver issue, as I had already tried 5 different ones with no luck. I may add all my other games work fine with any of the drivers, it was just far cry 2 that had the issues. So thanks a lot nvidia /thumbsdown.gif' class='bbc_emoticon' alt=':thumbsdown:' />



So guys just roll back and everything should be fine! G'luck :)

#4
Posted 08/10/2009 07:28 AM   
The 182.50 works great in XP for me with a 260-216.
The 182.50 works great in XP for me with a 260-216.

AMD quad core 955 BE @ 3.6GHz
Seagate 250GB SATA, Lite On DVD writer SATA
2x2GB DDR2 800Mhz RAM, Asus M4N82 mobo
Thermaltake 650 watt PSU, eVga GTX 260-216
Samsung 953 monitor, Windows 7
ATH AD700 headphones, Lian Li PC-7 YCF

#5
Posted 08/10/2009 10:55 AM   
Thanks for the info !!!!!!! a couple of weeks ago that FARCRY2 me to leave the blue screen appeared and restart (with the message to NV4_disp.dll stopped working) and if it does not crash when closing FARCRY2 hanging executed after changes abruptly when the resolution of any application, or go to the desktop from FARCRY2 and re-enter ... blue screen, also note that the menus flashing, try to reinstall the 190.38 driver, also try the 185 ... and still the problems, it is rare that only fails FARCRY2 because the Crysis Warhead and work without problems .. . I was going crazy, there are many error messages in windows event log (NV error ...) I'll be provided the oldest driver (182.50) excuse my bad english (I am using a translator) I'm from Argentina, and my english is very poor, as something more I can say that my OS is Windows XP SP3, DirectX9c March 2009 .. hopefully the next driver to correct these errors :unsure:


if someone found a solution for this please comment on this forum /thumbup.gif' class='bbc_emoticon' alt=':thumbup:' />
Thanks for the info !!!!!!! a couple of weeks ago that FARCRY2 me to leave the blue screen appeared and restart (with the message to NV4_disp.dll stopped working) and if it does not crash when closing FARCRY2 hanging executed after changes abruptly when the resolution of any application, or go to the desktop from FARCRY2 and re-enter ... blue screen, also note that the menus flashing, try to reinstall the 190.38 driver, also try the 185 ... and still the problems, it is rare that only fails FARCRY2 because the Crysis Warhead and work without problems .. . I was going crazy, there are many error messages in windows event log (NV error ...) I'll be provided the oldest driver (182.50) excuse my bad english (I am using a translator) I'm from Argentina, and my english is very poor, as something more I can say that my OS is Windows XP SP3, DirectX9c March 2009 .. hopefully the next driver to correct these errors :unsure:





if someone found a solution for this please comment on this forum /thumbup.gif' class='bbc_emoticon' alt=':thumbup:' />

#6
Posted 08/10/2009 12:24 PM   
Hola RoberD,
suena como que tiene los mismos problemas que tuve. He arreglado mis problemas mediante el uso de 182,50 conductores, cualquier conductor 182,50 causas después de los accidentes, y el parpadeo del menú. Cualquier conductor antes 182,50 parece bien. Espero que ayude!.
Hola RoberD,

suena como que tiene los mismos problemas que tuve. He arreglado mis problemas mediante el uso de 182,50 conductores, cualquier conductor 182,50 causas después de los accidentes, y el parpadeo del menú. Cualquier conductor antes 182,50 parece bien. Espero que ayude!.

#7
Posted 08/11/2009 07:35 AM   
[quote name='Sarlix' post='576799' date='Aug 11 2009, 04:35 AM']Hola RoberD,
suena como que tiene los mismos problemas que tuve. He arreglado mis problemas mediante el uso de 182,50 conductores, cualquier conductor 182,50 causas después de los accidentes, y el parpadeo del menú. Cualquier conductor antes 182,50 parece bien. Espero que ayude!.[/quote]


Thanks! I will do what I say, because a couple of weeks ago that no game FARCRY2 to avoid errors... :D

Gracias!!! voy a hacer lo que me dijiste, porque ya hace un par de semana que no juego FARCRY2 por evitar los errores... :D
[quote name='Sarlix' post='576799' date='Aug 11 2009, 04:35 AM']Hola RoberD,

suena como que tiene los mismos problemas que tuve. He arreglado mis problemas mediante el uso de 182,50 conductores, cualquier conductor 182,50 causas después de los accidentes, y el parpadeo del menú. Cualquier conductor antes 182,50 parece bien. Espero que ayude!.





Thanks! I will do what I say, because a couple of weeks ago that no game FARCRY2 to avoid errors... :D



Gracias!!! voy a hacer lo que me dijiste, porque ya hace un par de semana que no juego FARCRY2 por evitar los errores... :D

#8
Posted 08/11/2009 12:04 PM   
Exactly the Same problems with fasr cry 2. I'll try the older drivers, Thanks!!
Exactly the Same problems with fasr cry 2. I'll try the older drivers, Thanks!!

#9
Posted 10/04/2009 04:43 AM   
I got the same errors. I read on an earlier thread that says it could be caused by voltages for chipsets and processors. Enabling V-Sync did seem to work for me, but the menu's would start getting graphic artifacts or "flashing." I turned off V-sync and it started crashing mid-game. Before it would only crash when I tried to exit the game. My whole system would restart when I tried to exit the game.

Here are my system specs
CPU: AMD phenom II x4 940 (at default 3.0 GHz Peak temp 46c)
Motherboard: M3N78 Pro
Ram: Crucial ddr2 1066 in ganged mode
GPU: EVGA gtx 285 (no OC)

As a side note, my comp's only other problem is with asus pc-probe... Not sure if it might be related to similar driver problems with nvidia hardware.

Attached is my CPU-Z screen shot [attachment=13619:CPUZ.bmp]
I got the same errors. I read on an earlier thread that says it could be caused by voltages for chipsets and processors. Enabling V-Sync did seem to work for me, but the menu's would start getting graphic artifacts or "flashing." I turned off V-sync and it started crashing mid-game. Before it would only crash when I tried to exit the game. My whole system would restart when I tried to exit the game.



Here are my system specs

CPU: AMD phenom II x4 940 (at default 3.0 GHz Peak temp 46c)

Motherboard: M3N78 Pro

Ram: Crucial ddr2 1066 in ganged mode

GPU: EVGA gtx 285 (no OC)



As a side note, my comp's only other problem is with asus pc-probe... Not sure if it might be related to similar driver problems with nvidia hardware.



Attached is my CPU-Z screen shot [attachment=13619:CPUZ.bmp]

#10
Posted 10/05/2009 01:34 AM   
[quote name='Orwell' post='570401' date='Jul 27 2009, 12:14 AM']I've been having a few stability problems with the newer (from 185 (?) up to 190) drivers while playing Far Cry 2. Here's a list:

1. After a random time playing, everything 2-d looses sync, framerate halves, and the windows log is flooded with 'nv' errors. Using v-sync usually extends playable time...
2. Geting bluescreens when enabling AA. (fine, can do without)
3. Loading takes forever. (seems to bother both ATi and Nvidia, discussing is useless here)

I tried disabling my oc's. Didn't work. Tried increasing my fan speeds (CPU temp was a bit high), didn't work. Prime95 ran faultless for over 2 hours untill I decided to stop it, 3dmark06 gave me a score of 5000/5000/1500, no problems or weird stuff on screen at all. The only thing I haven't tried yet is installing older drivers...

System:
AMD Athlon 64 4000+ , ~2.5 GHz. Max allowed temp: 65C, reached 65C with lower aux-fan speed. Doesn't exceed 62C now.
Nvidia GeForce 9600GT, 766/1035. Temp perfectly fine, under 75C. Perfectly stable.
2GB MDT DDR1 RAM, MSI K8N MoBo.

Any ideas on point one? Or two?[/quote]


Thanks for sharing that info with us. I have just downloaded that game from Ubisoft and will monitor how it goes.
[quote name='Orwell' post='570401' date='Jul 27 2009, 12:14 AM']I've been having a few stability problems with the newer (from 185 (?) up to 190) drivers while playing Far Cry 2. Here's a list:



1. After a random time playing, everything 2-d looses sync, framerate halves, and the windows log is flooded with 'nv' errors. Using v-sync usually extends playable time...

2. Geting bluescreens when enabling AA. (fine, can do without)

3. Loading takes forever. (seems to bother both ATi and Nvidia, discussing is useless here)



I tried disabling my oc's. Didn't work. Tried increasing my fan speeds (CPU temp was a bit high), didn't work. Prime95 ran faultless for over 2 hours untill I decided to stop it, 3dmark06 gave me a score of 5000/5000/1500, no problems or weird stuff on screen at all. The only thing I haven't tried yet is installing older drivers...



System:

AMD Athlon 64 4000+ , ~2.5 GHz. Max allowed temp: 65C, reached 65C with lower aux-fan speed. Doesn't exceed 62C now.

Nvidia GeForce 9600GT, 766/1035. Temp perfectly fine, under 75C. Perfectly stable.

2GB MDT DDR1 RAM, MSI K8N MoBo.



Any ideas on point one? Or two?





Thanks for sharing that info with us. I have just downloaded that game from Ubisoft and will monitor how it goes.

Intel Core i5 3570k @ 4.2Ghz - MSi Z77 Mpower mobo - 16gb of Samsung Green DDR3 @ 1866mhz - EVGA GTX770 Classified 4gb - Seagate Hybrid drives - Seagate 480gb SSD - Windows 7 Ultimate 64bit

#11
Posted 10/20/2009 05:48 PM   
I had the same issues. I'm running Win7 x64 and downgraded my drivers to 181.xx. While the game runs now, sadly the performance is much much worse at times. Does NVIDIA know about this issue? Is there a way to notify them of the problems we've been having?
I had the same issues. I'm running Win7 x64 and downgraded my drivers to 181.xx. While the game runs now, sadly the performance is much much worse at times. Does NVIDIA know about this issue? Is there a way to notify them of the problems we've been having?

#12
Posted 10/20/2009 11:27 PM   
i would stay away from this game .. the error it causes is related to the 2d to 3d switchers in new cards
and it can fry ure hardware doing that as it cause it to switch on and off in an histercial way

look at the screen shot in my post in far cry 2 forums

[url="http://forums.ubi.com/eve/forums/a/tpc/f/5071014757/m/3341064697"]http://forums.ubi.com/eve/forums/a/tpc/f/5...57/m/3341064697[/url]


[url="http://www.tomshardware.co.uk/forum/page-100529_25_0.html"]http://www.tomshardware.co.uk/forum/page-100529_25_0.html[/url]


look at XPS M1710 post :

XPS M1710 10-29-2008 at 11:40:25 AM

@ Sarkamen

Ok i played far cry for about 25 mins before it crashed out and after a re-boot my pc giving me an error with my Nvidia Go 7900GS card. The Error was:

nv4_disp (The driver nv4_disp for the display device \Device\Video0 got stuck in an infinite loop.)

This has now completely fried my VGA card and is not covered under guarantee so ppl beware of this title.
i would stay away from this game .. the error it causes is related to the 2d to 3d switchers in new cards

and it can fry ure hardware doing that as it cause it to switch on and off in an histercial way



look at the screen shot in my post in far cry 2 forums



http://forums.ubi.com/eve/forums/a/tpc/f/5...57/m/3341064697





http://www.tomshardware.co.uk/forum/page-100529_25_0.html





look at XPS M1710 post :



XPS M1710 10-29-2008 at 11:40:25 AM



@ Sarkamen



Ok i played far cry for about 25 mins before it crashed out and after a re-boot my pc giving me an error with my Nvidia Go 7900GS card. The Error was:



nv4_disp (The driver nv4_disp for the display device \Device\Video0 got stuck in an infinite loop.)



This has now completely fried my VGA card and is not covered under guarantee so ppl beware of this title.

E8500/9800 GTX+/4 gb kingston ddr2 800/ P5Q Pro/WD caviar Black 750GB/Corsair tx 750W/ SUMO 5115/SAMSUNG 2333SW lcd/win7 64bit home premium. -We shall go on playing
Or find a new town -

#13
Posted 10/22/2009 01:26 PM   
I downloaded the latest Beta drivers (195.xx) over the weekend and it fixed all of my Far Cry 2 issues. Thanks Nvidia!
I downloaded the latest Beta drivers (195.xx) over the weekend and it fixed all of my Far Cry 2 issues. Thanks Nvidia!

#14
Posted 11/02/2009 11:04 PM   
Scroll To Top