Windows 7 & HDTV desktop resize problem Can't get my desktop to size right
I just installed Windows 7 to give it a try. My computer uses a 46" HDTV as a monitor, and I can't get the desktop to size properly. At first it was too big, so I went into the nvidia control pannel and selected the resize my deskop radio button. If I then click the resize my desktop button the window that fills the screen is off center and too big to the extent that the horizontal slider is off the screen and the verticle slider is way on the right side of the screen.


Here is where it gets tricky. I gave up on that and went to sleep. I came back today, went into the nvidia control pannel, selected the reisize my desktop radio button, but then I didn't click the resize button. I clicked apply. My screen shrnk and I could now see everything. This would have been great, but it shrunk too much. I lose about an inch of screen on all sides. So I clicked the resize button thinking I could easily just expand the screen now with the sliders. When I clicked the button it reverted back to its too large state, and the sliders were once again off the screen as before. I have no clue what is causing this...any thoughts? Here is my system info:

[Display]
Processor: Intel® Core(tm) i7 CPU 920 @ 2.67GHz (2699 MHz)
Operating System: Windows 7 Ultimate, 64-bit
DirectX version: 10.0
GPU processor: GeForce GTX 260
Driver version: 185.85
Stream processors: 192
Core clock: 602 MHz
Shader clock: 1296 MHz
Memory clock: 1026 MHz (2052 MHz data rate)
Memory interface: 448-bit
Total available graphics memory: 3710 MB
Dedicated video memory: 896 MB
System video memory: 0 MB
Shared system memory: 2814 MB
Video BIOS version: 62.00.1A.00.60
IRQ: 16
Bus: PCI Express x16 Gen2

[Components]

nvCpl.cpl 2.5.373.05 NVIDIA Control Panel Applet
nvCplUI.exe 2.5.373.05 NVIDIA Control Panel
nvViTvS.dll 8.15.11.8585 NVIDIA Video and TV Server
NVMCTRAY.DLL 8.15.11.8585 NVIDIA Media Center Library
nvDispS.dll 8.15.11.8585 NVIDIA Display Server
NVCPL.DLL 8.15.11.8585 NVIDIA Compatible Windows7 Display driver, Version 185.85
PhysX 909.02.03 NVIDIA PhysX
NVCUDA.DLL 8.15.11.8585 NVIDIA CUDA 2.2 driver
nvGameS.dll 8.15.11.8585 NVIDIA 3D Settings Server
I just installed Windows 7 to give it a try. My computer uses a 46" HDTV as a monitor, and I can't get the desktop to size properly. At first it was too big, so I went into the nvidia control pannel and selected the resize my deskop radio button. If I then click the resize my desktop button the window that fills the screen is off center and too big to the extent that the horizontal slider is off the screen and the verticle slider is way on the right side of the screen.





Here is where it gets tricky. I gave up on that and went to sleep. I came back today, went into the nvidia control pannel, selected the reisize my desktop radio button, but then I didn't click the resize button. I clicked apply. My screen shrnk and I could now see everything. This would have been great, but it shrunk too much. I lose about an inch of screen on all sides. So I clicked the resize button thinking I could easily just expand the screen now with the sliders. When I clicked the button it reverted back to its too large state, and the sliders were once again off the screen as before. I have no clue what is causing this...any thoughts? Here is my system info:



[Display]

Processor: Intel® Core(tm) i7 CPU 920 @ 2.67GHz (2699 MHz)

Operating System: Windows 7 Ultimate, 64-bit

DirectX version: 10.0

GPU processor: GeForce GTX 260

Driver version: 185.85

Stream processors: 192

Core clock: 602 MHz

Shader clock: 1296 MHz

Memory clock: 1026 MHz (2052 MHz data rate)

Memory interface: 448-bit

Total available graphics memory: 3710 MB

Dedicated video memory: 896 MB

System video memory: 0 MB

Shared system memory: 2814 MB

Video BIOS version: 62.00.1A.00.60

IRQ: 16

Bus: PCI Express x16 Gen2



[Components]



nvCpl.cpl 2.5.373.05 NVIDIA Control Panel Applet

nvCplUI.exe 2.5.373.05 NVIDIA Control Panel

nvViTvS.dll 8.15.11.8585 NVIDIA Video and TV Server

NVMCTRAY.DLL 8.15.11.8585 NVIDIA Media Center Library

nvDispS.dll 8.15.11.8585 NVIDIA Display Server

NVCPL.DLL 8.15.11.8585 NVIDIA Compatible Windows7 Display driver, Version 185.85

PhysX 909.02.03 NVIDIA PhysX

NVCUDA.DLL 8.15.11.8585 NVIDIA CUDA 2.2 driver

nvGameS.dll 8.15.11.8585 NVIDIA 3D Settings Server

#1
Posted 05/12/2009 10:49 PM   
Try adding the resolution you are using in the manage custom resolution instead on trying to resize the desktop, even if u already have the resolution. To me 1280x1024 was displaying has 4:3 with black bars on the sides, after i add it it displayed ok.

Hope it helped


[quote name='frostykev' post='540405' date='May 12 2009, 11:49 PM']I just installed Windows 7 to give it a try. My computer uses a 46" HDTV as a monitor, and I can't get the desktop to size properly. At first it was too big, so I went into the nvidia control pannel and selected the resize my deskop radio button. If I then click the resize my desktop button the window that fills the screen is off center and too big to the extent that the horizontal slider is off the screen and the verticle slider is way on the right side of the screen.


Here is where it gets tricky. I gave up on that and went to sleep. I came back today, went into the nvidia control pannel, selected the reisize my desktop radio button, but then I didn't click the resize button. I clicked apply. My screen shrnk and I could now see everything. This would have been great, but it shrunk too much. I lose about an inch of screen on all sides. So I clicked the resize button thinking I could easily just expand the screen now with the sliders. When I clicked the button it reverted back to its too large state, and the sliders were once again off the screen as before. I have no clue what is causing this...any thoughts? Here is my system info:

[Display]
Processor: Intel® Core(tm) i7 CPU 920 @ 2.67GHz (2699 MHz)
Operating System: Windows 7 Ultimate, 64-bit
DirectX version: 10.0
GPU processor: GeForce GTX 260
Driver version: 185.85
Stream processors: 192
Core clock: 602 MHz
Shader clock: 1296 MHz
Memory clock: 1026 MHz (2052 MHz data rate)
Memory interface: 448-bit
Total available graphics memory: 3710 MB
Dedicated video memory: 896 MB
System video memory: 0 MB
Shared system memory: 2814 MB
Video BIOS version: 62.00.1A.00.60
IRQ: 16
Bus: PCI Express x16 Gen2

[Components]

nvCpl.cpl 2.5.373.05 NVIDIA Control Panel Applet
nvCplUI.exe 2.5.373.05 NVIDIA Control Panel
nvViTvS.dll 8.15.11.8585 NVIDIA Video and TV Server
NVMCTRAY.DLL 8.15.11.8585 NVIDIA Media Center Library
nvDispS.dll 8.15.11.8585 NVIDIA Display Server
NVCPL.DLL 8.15.11.8585 NVIDIA Compatible Windows7 Display driver, Version 185.85
PhysX 909.02.03 NVIDIA PhysX
NVCUDA.DLL 8.15.11.8585 NVIDIA CUDA 2.2 driver
nvGameS.dll 8.15.11.8585 NVIDIA 3D Settings Server[/quote]
Try adding the resolution you are using in the manage custom resolution instead on trying to resize the desktop, even if u already have the resolution. To me 1280x1024 was displaying has 4:3 with black bars on the sides, after i add it it displayed ok.



Hope it helped





[quote name='frostykev' post='540405' date='May 12 2009, 11:49 PM']I just installed Windows 7 to give it a try. My computer uses a 46" HDTV as a monitor, and I can't get the desktop to size properly. At first it was too big, so I went into the nvidia control pannel and selected the resize my deskop radio button. If I then click the resize my desktop button the window that fills the screen is off center and too big to the extent that the horizontal slider is off the screen and the verticle slider is way on the right side of the screen.





Here is where it gets tricky. I gave up on that and went to sleep. I came back today, went into the nvidia control pannel, selected the reisize my desktop radio button, but then I didn't click the resize button. I clicked apply. My screen shrnk and I could now see everything. This would have been great, but it shrunk too much. I lose about an inch of screen on all sides. So I clicked the resize button thinking I could easily just expand the screen now with the sliders. When I clicked the button it reverted back to its too large state, and the sliders were once again off the screen as before. I have no clue what is causing this...any thoughts? Here is my system info:



[Display]

Processor: Intel® Core(tm) i7 CPU 920 @ 2.67GHz (2699 MHz)

Operating System: Windows 7 Ultimate, 64-bit

DirectX version: 10.0

GPU processor: GeForce GTX 260

Driver version: 185.85

Stream processors: 192

Core clock: 602 MHz

Shader clock: 1296 MHz

Memory clock: 1026 MHz (2052 MHz data rate)

Memory interface: 448-bit

Total available graphics memory: 3710 MB

Dedicated video memory: 896 MB

System video memory: 0 MB

Shared system memory: 2814 MB

Video BIOS version: 62.00.1A.00.60

IRQ: 16

Bus: PCI Express x16 Gen2



[Components]



nvCpl.cpl 2.5.373.05 NVIDIA Control Panel Applet

nvCplUI.exe 2.5.373.05 NVIDIA Control Panel

nvViTvS.dll 8.15.11.8585 NVIDIA Video and TV Server

NVMCTRAY.DLL 8.15.11.8585 NVIDIA Media Center Library

nvDispS.dll 8.15.11.8585 NVIDIA Display Server

NVCPL.DLL 8.15.11.8585 NVIDIA Compatible Windows7 Display driver, Version 185.85

PhysX 909.02.03 NVIDIA PhysX

NVCUDA.DLL 8.15.11.8585 NVIDIA CUDA 2.2 driver

nvGameS.dll 8.15.11.8585 NVIDIA 3D Settings Server

#2
Posted 05/13/2009 01:46 AM   
Which connecter do you use DVI,HDMI,DP or component?


[quote name='frostykev' post='540405' date='May 12 2009, 10:49 PM']I just installed Windows 7 to give it a try. My computer uses a 46" HDTV as a monitor, and I can't get the desktop to size properly. At first it was too big, so I went into the nvidia control pannel and selected the resize my deskop radio button. If I then click the resize my desktop button the window that fills the screen is off center and too big to the extent that the horizontal slider is off the screen and the verticle slider is way on the right side of the screen.


Here is where it gets tricky. I gave up on that and went to sleep. I came back today, went into the nvidia control pannel, selected the reisize my desktop radio button, but then I didn't click the resize button. I clicked apply. My screen shrnk and I could now see everything. This would have been great, but it shrunk too much. I lose about an inch of screen on all sides. So I clicked the resize button thinking I could easily just expand the screen now with the sliders. When I clicked the button it reverted back to its too large state, and the sliders were once again off the screen as before. I have no clue what is causing this...any thoughts? Here is my system info:

[Display]
Processor: Intel® Core(tm) i7 CPU 920 @ 2.67GHz (2699 MHz)
Operating System: Windows 7 Ultimate, 64-bit
DirectX version: 10.0
GPU processor: GeForce GTX 260
Driver version: 185.85
Stream processors: 192
Core clock: 602 MHz
Shader clock: 1296 MHz
Memory clock: 1026 MHz (2052 MHz data rate)
Memory interface: 448-bit
Total available graphics memory: 3710 MB
Dedicated video memory: 896 MB
System video memory: 0 MB
Shared system memory: 2814 MB
Video BIOS version: 62.00.1A.00.60
IRQ: 16
Bus: PCI Express x16 Gen2

[Components]

nvCpl.cpl 2.5.373.05 NVIDIA Control Panel Applet
nvCplUI.exe 2.5.373.05 NVIDIA Control Panel
nvViTvS.dll 8.15.11.8585 NVIDIA Video and TV Server
NVMCTRAY.DLL 8.15.11.8585 NVIDIA Media Center Library
nvDispS.dll 8.15.11.8585 NVIDIA Display Server
NVCPL.DLL 8.15.11.8585 NVIDIA Compatible Windows7 Display driver, Version 185.85
PhysX 909.02.03 NVIDIA PhysX
NVCUDA.DLL 8.15.11.8585 NVIDIA CUDA 2.2 driver
nvGameS.dll 8.15.11.8585 NVIDIA 3D Settings Server[/quote]
Which connecter do you use DVI,HDMI,DP or component?





[quote name='frostykev' post='540405' date='May 12 2009, 10:49 PM']I just installed Windows 7 to give it a try. My computer uses a 46" HDTV as a monitor, and I can't get the desktop to size properly. At first it was too big, so I went into the nvidia control pannel and selected the resize my deskop radio button. If I then click the resize my desktop button the window that fills the screen is off center and too big to the extent that the horizontal slider is off the screen and the verticle slider is way on the right side of the screen.





Here is where it gets tricky. I gave up on that and went to sleep. I came back today, went into the nvidia control pannel, selected the reisize my desktop radio button, but then I didn't click the resize button. I clicked apply. My screen shrnk and I could now see everything. This would have been great, but it shrunk too much. I lose about an inch of screen on all sides. So I clicked the resize button thinking I could easily just expand the screen now with the sliders. When I clicked the button it reverted back to its too large state, and the sliders were once again off the screen as before. I have no clue what is causing this...any thoughts? Here is my system info:



[Display]

Processor: Intel® Core(tm) i7 CPU 920 @ 2.67GHz (2699 MHz)

Operating System: Windows 7 Ultimate, 64-bit

DirectX version: 10.0

GPU processor: GeForce GTX 260

Driver version: 185.85

Stream processors: 192

Core clock: 602 MHz

Shader clock: 1296 MHz

Memory clock: 1026 MHz (2052 MHz data rate)

Memory interface: 448-bit

Total available graphics memory: 3710 MB

Dedicated video memory: 896 MB

System video memory: 0 MB

Shared system memory: 2814 MB

Video BIOS version: 62.00.1A.00.60

IRQ: 16

Bus: PCI Express x16 Gen2



[Components]



nvCpl.cpl 2.5.373.05 NVIDIA Control Panel Applet

nvCplUI.exe 2.5.373.05 NVIDIA Control Panel

nvViTvS.dll 8.15.11.8585 NVIDIA Video and TV Server

NVMCTRAY.DLL 8.15.11.8585 NVIDIA Media Center Library

nvDispS.dll 8.15.11.8585 NVIDIA Display Server

NVCPL.DLL 8.15.11.8585 NVIDIA Compatible Windows7 Display driver, Version 185.85

PhysX 909.02.03 NVIDIA PhysX

NVCUDA.DLL 8.15.11.8585 NVIDIA CUDA 2.2 driver

nvGameS.dll 8.15.11.8585 NVIDIA 3D Settings Server

#3
Posted 05/13/2009 11:06 AM   
Try downloading [url="http://forums.nvidia.com/index.php?act=attach&type=post&id=11109"]DLPfix.zip[/url]. Hopefully it should apply a HotFix that fixes this issue. I have Vista Ultimate 64-bit (mistake) and I'm having a similar problem. DLPfix.exe hasn't helped me as it just hangs as it nears completion, but maybe you will have better luck.






[quote name='frostykev' post='540405' date='May 12 2009, 11:49 PM']I just installed Windows 7 to give it a try. My computer uses a 46" HDTV as a monitor, and I can't get the desktop to size properly. At first it was too big, so I went into the nvidia control pannel and selected the resize my deskop radio button. If I then click the resize my desktop button the window that fills the screen is off center and too big to the extent that the horizontal slider is off the screen and the verticle slider is way on the right side of the screen.


Here is where it gets tricky. I gave up on that and went to sleep. I came back today, went into the nvidia control pannel, selected the reisize my desktop radio button, but then I didn't click the resize button. I clicked apply. My screen shrnk and I could now see everything. This would have been great, but it shrunk too much. I lose about an inch of screen on all sides. So I clicked the resize button thinking I could easily just expand the screen now with the sliders. When I clicked the button it reverted back to its too large state, and the sliders were once again off the screen as before. I have no clue what is causing this...any thoughts? Here is my system info:

[Display]
Processor: Intel® Core(tm) i7 CPU 920 @ 2.67GHz (2699 MHz)
Operating System: Windows 7 Ultimate, 64-bit
DirectX version: 10.0
GPU processor: GeForce GTX 260
Driver version: 185.85
Stream processors: 192
Core clock: 602 MHz
Shader clock: 1296 MHz
Memory clock: 1026 MHz (2052 MHz data rate)
Memory interface: 448-bit
Total available graphics memory: 3710 MB
Dedicated video memory: 896 MB
System video memory: 0 MB
Shared system memory: 2814 MB
Video BIOS version: 62.00.1A.00.60
IRQ: 16
Bus: PCI Express x16 Gen2

[Components]

nvCpl.cpl 2.5.373.05 NVIDIA Control Panel Applet
nvCplUI.exe 2.5.373.05 NVIDIA Control Panel
nvViTvS.dll 8.15.11.8585 NVIDIA Video and TV Server
NVMCTRAY.DLL 8.15.11.8585 NVIDIA Media Center Library
nvDispS.dll 8.15.11.8585 NVIDIA Display Server
NVCPL.DLL 8.15.11.8585 NVIDIA Compatible Windows7 Display driver, Version 185.85
PhysX 909.02.03 NVIDIA PhysX
NVCUDA.DLL 8.15.11.8585 NVIDIA CUDA 2.2 driver
nvGameS.dll 8.15.11.8585 NVIDIA 3D Settings Server[/quote]
Try downloading DLPfix.zip. Hopefully it should apply a HotFix that fixes this issue. I have Vista Ultimate 64-bit (mistake) and I'm having a similar problem. DLPfix.exe hasn't helped me as it just hangs as it nears completion, but maybe you will have better luck.













[quote name='frostykev' post='540405' date='May 12 2009, 11:49 PM']I just installed Windows 7 to give it a try. My computer uses a 46" HDTV as a monitor, and I can't get the desktop to size properly. At first it was too big, so I went into the nvidia control pannel and selected the resize my deskop radio button. If I then click the resize my desktop button the window that fills the screen is off center and too big to the extent that the horizontal slider is off the screen and the verticle slider is way on the right side of the screen.





Here is where it gets tricky. I gave up on that and went to sleep. I came back today, went into the nvidia control pannel, selected the reisize my desktop radio button, but then I didn't click the resize button. I clicked apply. My screen shrnk and I could now see everything. This would have been great, but it shrunk too much. I lose about an inch of screen on all sides. So I clicked the resize button thinking I could easily just expand the screen now with the sliders. When I clicked the button it reverted back to its too large state, and the sliders were once again off the screen as before. I have no clue what is causing this...any thoughts? Here is my system info:



[Display]

Processor: Intel® Core(tm) i7 CPU 920 @ 2.67GHz (2699 MHz)

Operating System: Windows 7 Ultimate, 64-bit

DirectX version: 10.0

GPU processor: GeForce GTX 260

Driver version: 185.85

Stream processors: 192

Core clock: 602 MHz

Shader clock: 1296 MHz

Memory clock: 1026 MHz (2052 MHz data rate)

Memory interface: 448-bit

Total available graphics memory: 3710 MB

Dedicated video memory: 896 MB

System video memory: 0 MB

Shared system memory: 2814 MB

Video BIOS version: 62.00.1A.00.60

IRQ: 16

Bus: PCI Express x16 Gen2



[Components]



nvCpl.cpl 2.5.373.05 NVIDIA Control Panel Applet

nvCplUI.exe 2.5.373.05 NVIDIA Control Panel

nvViTvS.dll 8.15.11.8585 NVIDIA Video and TV Server

NVMCTRAY.DLL 8.15.11.8585 NVIDIA Media Center Library

nvDispS.dll 8.15.11.8585 NVIDIA Display Server

NVCPL.DLL 8.15.11.8585 NVIDIA Compatible Windows7 Display driver, Version 185.85

PhysX 909.02.03 NVIDIA PhysX

NVCUDA.DLL 8.15.11.8585 NVIDIA CUDA 2.2 driver

nvGameS.dll 8.15.11.8585 NVIDIA 3D Settings Server

#4
Posted 05/28/2009 06:50 PM   
[quote name='Rustylicious' post='546214' date='May 28 2009, 01:50 PM']Try downloading [url="http://forums.nvidia.com/index.php?act=attach&type=post&id=11109"]DLPfix.zip[/url]. Hopefully it should apply a HotFix that fixes this issue. I have Vista Ultimate 64-bit (mistake) and I'm having a similar problem. DLPfix.exe hasn't helped me as it just hangs as it nears completion, but maybe you will have better luck.[/quote]

Could you link the 32 bit version of this, or show us where you found it, so that we can try it?
[quote name='Rustylicious' post='546214' date='May 28 2009, 01:50 PM']Try downloading DLPfix.zip. Hopefully it should apply a HotFix that fixes this issue. I have Vista Ultimate 64-bit (mistake) and I'm having a similar problem. DLPfix.exe hasn't helped me as it just hangs as it nears completion, but maybe you will have better luck.



Could you link the 32 bit version of this, or show us where you found it, so that we can try it?

#5
Posted 06/07/2009 04:47 PM   
Sorry to be so late on this, but I just solved the same issue. Adjust the text and icon size in Window's control panel. This needs to be set to one of the windows standard settings. In my case I needed it to be in the smallest setting in order to see the sliders. You'll need to log off then back in for that change to apply. You should now be able to see the sliders. Once you've adjusted the desktop size you can go back and resize the text and icons to your liking.
Sorry to be so late on this, but I just solved the same issue. Adjust the text and icon size in Window's control panel. This needs to be set to one of the windows standard settings. In my case I needed it to be in the smallest setting in order to see the sliders. You'll need to log off then back in for that change to apply. You should now be able to see the sliders. Once you've adjusted the desktop size you can go back and resize the text and icons to your liking.

#6
Posted 11/18/2009 07:31 PM   
[quote name='bmj2728' post='952660' date='Nov 18 2009, 02:31 PM']Sorry to be so late on this, but I just solved the same issue. Adjust the text and icon size in Window's control panel. This needs to be set to one of the windows standard settings. In my case I needed it to be in the smallest setting in order to see the sliders. You'll need to log off then back in for that change to apply. You should now be able to see the sliders. Once you've adjusted the desktop size you can go back and resize the text and icons to your liking.[/quote]

Thanks, that solved my identical issue. Happens every time I upgrade drivers. (Just put in 195.62 x64 for my 9800GT running in Win 7.) I'm now back to my oddball 1080i, 1790 X 1026 @ 29Hx on my 37" Toshiba connected with Component video.
[quote name='bmj2728' post='952660' date='Nov 18 2009, 02:31 PM']Sorry to be so late on this, but I just solved the same issue. Adjust the text and icon size in Window's control panel. This needs to be set to one of the windows standard settings. In my case I needed it to be in the smallest setting in order to see the sliders. You'll need to log off then back in for that change to apply. You should now be able to see the sliders. Once you've adjusted the desktop size you can go back and resize the text and icons to your liking.



Thanks, that solved my identical issue. Happens every time I upgrade drivers. (Just put in 195.62 x64 for my 9800GT running in Win 7.) I'm now back to my oddball 1080i, 1790 X 1026 @ 29Hx on my 37" Toshiba connected with Component video.

#7
Posted 11/28/2009 08:46 AM   
This is happening to my new HTPC i built. I'm running Win7 and have the newest nvidia drivers. I have a mGF9300 being used with a 42" 1080i Plasma Panasonic TV.

From what i've read elsewhere, this is an overscanning issue with nVidia. Similar to the underscanning phenomenon where black borders are put around the desktop screen.

You shouldn't have to resize the desktop but be able to apply a fix to actually render the pixels 1:1 with the physical pixels. It's simply an nVidia problem.

I haven't been able to find the exact fix, but i've only been looking for less than an hour.

Can any Senior Forum members comment on how to correct this issue? TIA.
This is happening to my new HTPC i built. I'm running Win7 and have the newest nvidia drivers. I have a mGF9300 being used with a 42" 1080i Plasma Panasonic TV.



From what i've read elsewhere, this is an overscanning issue with nVidia. Similar to the underscanning phenomenon where black borders are put around the desktop screen.



You shouldn't have to resize the desktop but be able to apply a fix to actually render the pixels 1:1 with the physical pixels. It's simply an nVidia problem.



I haven't been able to find the exact fix, but i've only been looking for less than an hour.



Can any Senior Forum members comment on how to correct this issue? TIA.

#8
Posted 11/28/2009 07:03 PM   
bump. can someone point me in the right direction? or give me a link to the old drivers before this was an issue.
bump. can someone point me in the right direction? or give me a link to the old drivers before this was an issue.

#9
Posted 12/15/2009 06:04 PM   
[quote name='naman919' post='965152' date='Dec 16 2009, 02:04 AM']bump. can someone point me in the right direction? or give me a link to the old drivers before this was an issue.[/quote]

You're looking for the 190.62 drivers. I've got a Viewsonic 28" running at 1920x1200. All the drivers after 190.62 give me a desktop too big for my display. Can't see the start button. I concur that it's an nVidia problem. Btw, for those folks who have an issue with aspect ratio you can check your display's settings to see if there's a manual toggle for 1:1, 4:3, 16:9 or full screen. This let's you play older games on a widescreen with the correct aspect ratio. The display's menu. Not the nVidia CP. nVidia used to have a control option for this on older displays but not for HDMI connections. I'm running a GTX295 with a primary Viewsonic 28" and a secondary Viewsonic 19". I use the secondary display to display my heat temps and stuff. I used to run a quad SLI 9800GX2 setup many moons ago. A single GTX295 is way faster. =)
[quote name='naman919' post='965152' date='Dec 16 2009, 02:04 AM']bump. can someone point me in the right direction? or give me a link to the old drivers before this was an issue.



You're looking for the 190.62 drivers. I've got a Viewsonic 28" running at 1920x1200. All the drivers after 190.62 give me a desktop too big for my display. Can't see the start button. I concur that it's an nVidia problem. Btw, for those folks who have an issue with aspect ratio you can check your display's settings to see if there's a manual toggle for 1:1, 4:3, 16:9 or full screen. This let's you play older games on a widescreen with the correct aspect ratio. The display's menu. Not the nVidia CP. nVidia used to have a control option for this on older displays but not for HDMI connections. I'm running a GTX295 with a primary Viewsonic 28" and a secondary Viewsonic 19". I use the secondary display to display my heat temps and stuff. I used to run a quad SLI 9800GX2 setup many moons ago. A single GTX295 is way faster. =)

#10
Posted 01/11/2010 06:07 AM   
The problem with the Viewsonic 28" monitor will be resolved through a future driver. This monitor was previously blacklisted back when there wasn't an easy method for disabling audio infoframe. When we introduced a method for disabling audio infoframe (HDMI audio), this monitor was removed from the blacklist however it appears that this monitor requires additional steps to fully HD mode and run in PC mode. This will be resolved in a future driver. This fix will also apply to other monitors with similar problems.
The problem with the Viewsonic 28" monitor will be resolved through a future driver. This monitor was previously blacklisted back when there wasn't an easy method for disabling audio infoframe. When we introduced a method for disabling audio infoframe (HDMI audio), this monitor was removed from the blacklist however it appears that this monitor requires additional steps to fully HD mode and run in PC mode. This will be resolved in a future driver. This fix will also apply to other monitors with similar problems.

Please send me a PM if I fail to keep up on replying in any specific thread or leave a driver feedback: Driver Feedback

I am also available on Twitter:
www.twitter.com/manuelguzman

#11
Posted 01/11/2010 11:28 AM   
I also have a Viewsonic 28", a 9800 GTX+ and was running into the same problem. I thought I was going crazy. I tried everything! I did find a workaround until the driver fix comes out though. This worked for me, YMMV. I found this completely by accident.

Go into the NVIDIA Control Panel to the "Change Resolution" page. Click the "Connector:" drop down menu and change it to "Audio Enabled", click Apply. A window will appear with some instructions and ask you if you really want to enable this. Choose "Yes". Nothing will change. Click the Ok button on the "Do you want to keep this..." box. Now go and click the the "Connector:" drop down again and set it back to "Audio Disabled". This time when you click the Apply button, the screen will blank and when it comes back, the desktop will resize and be correct.

Unfortunately, you have to do this every time you reboot, log off, or if the screen saver activates, but hey, at least you can use the latest drivers and the desktop fits properly. Not sure why this works, but maybe it might help NVIDIA fix the problem with our monitors in a new driver.

ManuelG, I know you guys are busy, but I'm sure all of us Viewsonic owners would really appreciate a speedy fix for this. We can't use our nice monitors with Win7 and the latest drivers. :-(

Thanks,

Dave
I also have a Viewsonic 28", a 9800 GTX+ and was running into the same problem. I thought I was going crazy. I tried everything! I did find a workaround until the driver fix comes out though. This worked for me, YMMV. I found this completely by accident.



Go into the NVIDIA Control Panel to the "Change Resolution" page. Click the "Connector:" drop down menu and change it to "Audio Enabled", click Apply. A window will appear with some instructions and ask you if you really want to enable this. Choose "Yes". Nothing will change. Click the Ok button on the "Do you want to keep this..." box. Now go and click the the "Connector:" drop down again and set it back to "Audio Disabled". This time when you click the Apply button, the screen will blank and when it comes back, the desktop will resize and be correct.



Unfortunately, you have to do this every time you reboot, log off, or if the screen saver activates, but hey, at least you can use the latest drivers and the desktop fits properly. Not sure why this works, but maybe it might help NVIDIA fix the problem with our monitors in a new driver.



ManuelG, I know you guys are busy, but I'm sure all of us Viewsonic owners would really appreciate a speedy fix for this. We can't use our nice monitors with Win7 and the latest drivers. :-(



Thanks,



Dave

#12
Posted 01/31/2010 11:20 PM   
[quote name='ManuelG' post='979291' date='Jan 11 2010, 12:28 PM']The problem with the Viewsonic 28" monitor will be resolved through a future driver. This monitor was previously blacklisted back when there wasn't an easy method for disabling audio infoframe. When we introduced a method for disabling audio infoframe (HDMI audio), this monitor was removed from the blacklist however it appears that this monitor requires additional steps to fully HD mode and run in PC mode. This will be resolved in a future driver. This fix will also apply to other monitors with similar problems.[/quote]
There were some earlier drivers like 191.07 that could be edited in the inf file as follows. Why isn't the edited inf working anymore? Thanks in advance...

Edit the NV4_DISP file as follows. (So unpack the files for install and open NV4_DISP.inf in notepad).

1. Locate the section labeled: [nv_clearRegistrySwitches_delreg]

2. Remove the following lines:

HKR,,OverrideEdidFlags0
HKR,,OverrideEdidFlags1
HKR,,OverrideEdidFlags2
HKR,,OverrideEdidFlags3
HKR,,OverrideEdidFlags4

3. Locate the section labeled: [nv_commonDisplayModes_addreg]

4. Add the customized line:

HKR,,OverrideEdidFlags0, %REG_BINARY%, 5A,63,1F,0F,00,00,FF,FF,04,00,00,00,7E,01,00

5. Locate the setup.exe file in the 'nVidia Drivers' folder and execute. Install as normal.

This is for the Viewsonic VX2835wm and the 191.07 windows 7 x64 drivers only.

You need to replace the first four sets of hex with the ones you for your monitor's/TV's EDID if it is another brand/model.
[quote name='ManuelG' post='979291' date='Jan 11 2010, 12:28 PM']The problem with the Viewsonic 28" monitor will be resolved through a future driver. This monitor was previously blacklisted back when there wasn't an easy method for disabling audio infoframe. When we introduced a method for disabling audio infoframe (HDMI audio), this monitor was removed from the blacklist however it appears that this monitor requires additional steps to fully HD mode and run in PC mode. This will be resolved in a future driver. This fix will also apply to other monitors with similar problems.

There were some earlier drivers like 191.07 that could be edited in the inf file as follows. Why isn't the edited inf working anymore? Thanks in advance...



Edit the NV4_DISP file as follows. (So unpack the files for install and open NV4_DISP.inf in notepad).



1. Locate the section labeled: [nv_clearRegistrySwitches_delreg]



2. Remove the following lines:



HKR,,OverrideEdidFlags0

HKR,,OverrideEdidFlags1

HKR,,OverrideEdidFlags2

HKR,,OverrideEdidFlags3

HKR,,OverrideEdidFlags4



3. Locate the section labeled: [nv_commonDisplayModes_addreg]



4. Add the customized line:



HKR,,OverrideEdidFlags0, %REG_BINARY%, 5A,63,1F,0F,00,00,FF,FF,04,00,00,00,7E,01,00



5. Locate the setup.exe file in the 'nVidia Drivers' folder and execute. Install as normal.



This is for the Viewsonic VX2835wm and the 191.07 windows 7 x64 drivers only.



You need to replace the first four sets of hex with the ones you for your monitor's/TV's EDID if it is another brand/model.

#13
Posted 02/04/2010 03:04 AM   
Scroll To Top