HOW to disable HDMI audio through the NVIDIA Control Panel?
  1 / 2    
PROBLEM:
8600GT connected via DVI->HDMI cable to SAMSUNG LCD HDReady TV = Good Image but NO SOUND using ANALOG OUTPUT.

While searching online I discovered a forceware registry hack ( [url="http://forums.afterdawn.com/thread_view.cfm/589259)"]http://forums.afterdawn.com/thread_view.cfm/589259)[/url] but it doesn't work.
I am not the first person with this issue.

NOTE: If I install a different Forceware driver (181.22) I get sound during the inicial instalation phase (the windows default "plug in found" sound).
That made me believe this is a software related problem - the ForceWare driver turns on the audio over HDMI cable overriding the analog input on the TV!

So I ask: How to to disable the HDMI audio?
There must be a way.

Do anyone have some Hacked forceware drivers with this "bug" fixed?
PROBLEM:

8600GT connected via DVI->HDMI cable to SAMSUNG LCD HDReady TV = Good Image but NO SOUND using ANALOG OUTPUT.



While searching online I discovered a forceware registry hack ( http://forums.afterdawn.com/thread_view.cfm/589259) but it doesn't work.

I am not the first person with this issue.



NOTE: If I install a different Forceware driver (181.22) I get sound during the inicial instalation phase (the windows default "plug in found" sound).

That made me believe this is a software related problem - the ForceWare driver turns on the audio over HDMI cable overriding the analog input on the TV!



So I ask: How to to disable the HDMI audio?

There must be a way.



Do anyone have some Hacked forceware drivers with this "bug" fixed?

#1
Posted 01/31/2009 01:10 PM   
Response from NVIDIA:
"The HDTV is basically telling the PC via its EDID firmware that it supports audio via HDMI only and not analog.
NVIDIA is investigating a workaround for this to ignore the HDTV/monitors EDID firmware to support this user configuration in the future."

If we look on similiar posts on the internet this problem has more than 1 yr old... and still no solution?!
Response from NVIDIA:

"The HDTV is basically telling the PC via its EDID firmware that it supports audio via HDMI only and not analog.

NVIDIA is investigating a workaround for this to ignore the HDTV/monitors EDID firmware to support this user configuration in the future."



If we look on similiar posts on the internet this problem has more than 1 yr old... and still no solution?!

#2
Posted 01/31/2009 01:26 PM   
[quote name='inoxllor' post='499402' date='Jan 31 2009, 01:26 PM']Response from NVIDIA:
"The HDTV is basically telling the PC via its EDID firmware that it supports audio via HDMI only and not analog.
NVIDIA is investigating a workaround for this to ignore the HDTV/monitors EDID firmware to support this user configuration in the future."

If we look on similiar posts on the internet this problem has more than 1 yr old... and still no solution?![/quote]

That makes sense, good to understand what the problem is. Its not an easy one to solve though, EDID's are important for graphics card and monitors to work together correctly. This is then, not NVidia's issue really. The computer is ouputting video correctly. The computer is being told by the TV its connected by HDMI, therefore is disabling its own analog audio. This is the problem with adapters... especially ones that support different features like HDMI to DVI. Its not really a bug, but an HDMI connection being handled like t should be... except its not REALLY an HDMI connection.

The only other work around that I can think of is if the EDID is transferred via a single pin on the connector. It would most likely be the DDC data pin, and pulling it might stop the problem. Then again, you might get nothing when its re-connected. I honestly don't know.
[quote name='inoxllor' post='499402' date='Jan 31 2009, 01:26 PM']Response from NVIDIA:

"The HDTV is basically telling the PC via its EDID firmware that it supports audio via HDMI only and not analog.

NVIDIA is investigating a workaround for this to ignore the HDTV/monitors EDID firmware to support this user configuration in the future."



If we look on similiar posts on the internet this problem has more than 1 yr old... and still no solution?!



That makes sense, good to understand what the problem is. Its not an easy one to solve though, EDID's are important for graphics card and monitors to work together correctly. This is then, not NVidia's issue really. The computer is ouputting video correctly. The computer is being told by the TV its connected by HDMI, therefore is disabling its own analog audio. This is the problem with adapters... especially ones that support different features like HDMI to DVI. Its not really a bug, but an HDMI connection being handled like t should be... except its not REALLY an HDMI connection.



The only other work around that I can think of is if the EDID is transferred via a single pin on the connector. It would most likely be the DDC data pin, and pulling it might stop the problem. Then again, you might get nothing when its re-connected. I honestly don't know.

Official GeForce Forums Benchmarking Leaderboards
NVIDIA SLI Technology: A Canine's Guide

Corsair Obsidian 350D mATX, Asus Maximus VI GENE Z87 mATX, Intel Core i7-4770k @ 4.40GHz, Corsair H110, Corsair Dominator Platinum 16GB (4x4GB) @ 2400MHz, 1x OCZ Vertex 4 256GB, 1x WD Scorpio Black 750GB, 2x WD Caviar Black 1TB, EVGA GeForce GTX 780Ti Superclock, Enermax 1250W Evolution, Windows 8 64bit.

Logitech G9x, Razer Black Widow Ultimate, Logitech G930, 2x Eizo EV2333W.

Twitter | Steam

#3
Posted 01/31/2009 04:13 PM   
Can you just use the sound cards control panel to configure audio out?

Try using the windows, sounds and audio devices control panel,Audio Tab to set the Defualt Device for sound output from NV HD back to you're sound card's name as default output from the list!
Can you just use the sound cards control panel to configure audio out?



Try using the windows, sounds and audio devices control panel,Audio Tab to set the Defualt Device for sound output from NV HD back to you're sound card's name as default output from the list!

#4
Posted 01/31/2009 04:14 PM   
I've been looking for information on this everywhere. I'm running Linux kernel 2.6.24 with Nvidia drivers 180.29 drivers with a 9500GT (G96). Nvidia is rightfully claiming that the TV is telling the driver via it's edid (Extension Block Details really) that the tv has audio capabilities via hdmi. With that information I downloaded my TVs edid and edited it to remove all references to having audio and redid the checksums etc. X thinks the edid is fine, so does monitor asset manager, but for some reasons it seems that the driver still enables audio. The only way I can disable audio for sure is to remove the entire Extension Block, but doing so removes several of the extended supported modes that I use. Seems that the driver is only looking for the presence of an extension block and is not really reading into it to discern whether or not the set supports audio. I've attached both edids the original and the patched versions, it would be great if someone at NVidia or some other technical guru could tell me what I'm doing wrong. I had to rename the files, so just remove the .txt.
I've been looking for information on this everywhere. I'm running Linux kernel 2.6.24 with Nvidia drivers 180.29 drivers with a 9500GT (G96). Nvidia is rightfully claiming that the TV is telling the driver via it's edid (Extension Block Details really) that the tv has audio capabilities via hdmi. With that information I downloaded my TVs edid and edited it to remove all references to having audio and redid the checksums etc. X thinks the edid is fine, so does monitor asset manager, but for some reasons it seems that the driver still enables audio. The only way I can disable audio for sure is to remove the entire Extension Block, but doing so removes several of the extended supported modes that I use. Seems that the driver is only looking for the presence of an extension block and is not really reading into it to discern whether or not the set supports audio. I've attached both edids the original and the patched versions, it would be great if someone at NVidia or some other technical guru could tell me what I'm doing wrong. I had to rename the files, so just remove the .txt.

#5
Posted 02/19/2009 07:58 PM   
[b]Solution for Windows[/b] :)
- Provided by Nvidia Support Center.
Solution for Windows :)

- Provided by Nvidia Support Center.

#6
Posted 02/19/2009 10:51 PM   
[quote name='inoxllor' post='508064' date='Feb 20 2009, 12:51 AM'][b]Solution for Windows[/b] :)
- Provided by Nvidia Support Center.[/quote]

It only support Windows Vista. What about Windows XP? :)
[quote name='inoxllor' post='508064' date='Feb 20 2009, 12:51 AM']Solution for Windows :)

- Provided by Nvidia Support Center.



It only support Windows Vista. What about Windows XP? :)

#7
Posted 02/20/2009 02:02 PM   
[quote name='bagzoidceo' post='508306' date='Feb 20 2009, 02:02 PM']It only support Windows Vista. What about Windows XP? :)[/quote]
I guess you have to ask nvidia support center.
But they told me they are going to implement this fix in the next driver release, so I think it will be available to windows XP also.
[quote name='bagzoidceo' post='508306' date='Feb 20 2009, 02:02 PM']It only support Windows Vista. What about Windows XP? :)

I guess you have to ask nvidia support center.

But they told me they are going to implement this fix in the next driver release, so I think it will be available to windows XP also.

#8
Posted 02/20/2009 02:35 PM   
bryanb's edid fix in this thread solved my analog audio problem
[url="http://forums.nvidia.com/index.php?showtopic=58483"]http://forums.nvidia.com/index.php?showtopic=58483[/url]
bryanb's edid fix in this thread solved my analog audio problem

http://forums.nvidia.com/index.php?showtopic=58483

#9
Posted 03/01/2009 05:03 PM   
For noobs and the like...

bak's illustrated edid fix might be of help.

[url="http://forums.nvidia.com/index.php?showtopic=99932"]http://forums.nvidia.com/index.php?showtopic=99932[/url]
For noobs and the like...



bak's illustrated edid fix might be of help.



http://forums.nvidia.com/index.php?showtopic=99932

#10
Posted 06/24/2009 01:40 AM   
This problem has resufaced in the new 191.07 drivers.

The hot fix here doesn't help either:
[url="http://nvidia.custhelp.com/cgi-bin/nvidia.cfg/php/enduser/std_adp.php?p_faqid=2371"]DLP Hotfix[/url]

I notice the HDMI audio handling has changed with this release (there's a new hdaudio_1.00.00.59_xp_vista_win7.exe file in the driver)

Any chance of a fix?
This problem has resufaced in the new 191.07 drivers.



The hot fix here doesn't help either:

DLP Hotfix



I notice the HDMI audio handling has changed with this release (there's a new hdaudio_1.00.00.59_xp_vista_win7.exe file in the driver)



Any chance of a fix?

#11
Posted 10/14/2009 01:58 PM   
I'm using 195.62 win 7 64 and still have the same problem.Any word on a fix or ill have to go back to 190.62.Hopefully this will fix but I'd rather be using the latsest drivers (of course)
I'm using 195.62 win 7 64 and still have the same problem.Any word on a fix or ill have to go back to 190.62.Hopefully this will fix but I'd rather be using the latsest drivers (of course)

#12
Posted 01/10/2010 02:52 AM   
I have the same problem. No S/PDIF-out connector on mainboard. When I select "HDMI - Disable Audio" it works, till I start a game or reboot.
Is there a way to disable the HDMI audio permanently?
The Phoenix EDID software won't find my TV so I can't modify the drivers either :<
I have the same problem. No S/PDIF-out connector on mainboard. When I select "HDMI - Disable Audio" it works, till I start a game or reboot.

Is there a way to disable the HDMI audio permanently?

The Phoenix EDID software won't find my TV so I can't modify the drivers either :<

#13
Posted 01/17/2010 09:30 AM   
I'm in the exact same boat...
Upgraded to windows 7, and now windows 7 seems to think my LCD TV is a generic plug and play monitor, and won't pull an EDID on it.
Meanwhile, samsung isn't releasing drivers to tie to the TV.

I know this is the error, and it is the single most infuriating bane of my existence.




[quote name='OroSaiwa' post='982799' date='Jan 17 2010, 09:30 AM']I have the same problem. No S/PDIF-out connector on mainboard. When I select "HDMI - Disable Audio" it works, till I start a game or reboot.
Is there a way to disable the HDMI audio permanently?
The Phoenix EDID software won't find my TV so I can't modify the drivers either :<[/quote]
I'm in the exact same boat...

Upgraded to windows 7, and now windows 7 seems to think my LCD TV is a generic plug and play monitor, and won't pull an EDID on it.

Meanwhile, samsung isn't releasing drivers to tie to the TV.



I know this is the error, and it is the single most infuriating bane of my existence.









[quote name='OroSaiwa' post='982799' date='Jan 17 2010, 09:30 AM']I have the same problem. No S/PDIF-out connector on mainboard. When I select "HDMI - Disable Audio" it works, till I start a game or reboot.

Is there a way to disable the HDMI audio permanently?

The Phoenix EDID software won't find my TV so I can't modify the drivers either :<

#14
Posted 01/25/2010 05:57 AM   
[quote name='madmanuel' post='988226' date='Jan 25 2010, 06:57 PM']I'm in the exact same boat...
Upgraded to windows 7, and now windows 7 seems to think my LCD TV is a generic plug and play monitor, and won't pull an EDID on it.
Meanwhile, samsung isn't releasing drivers to tie to the TV.

I know this is the error, and it is the single most infuriating bane of my existence.[/quote]

I'm having exactly the same problem. It's hard to believe Nvidia can't fix this after 18 months. Thankfully they added an "HDMI Audio Disable" option in the latest driver update; but they don't stick. Every time I turn the computer or monitor back on, I have to enable HDMI audio, then disable it again. Absolutely ridiculous.
[quote name='madmanuel' post='988226' date='Jan 25 2010, 06:57 PM']I'm in the exact same boat...

Upgraded to windows 7, and now windows 7 seems to think my LCD TV is a generic plug and play monitor, and won't pull an EDID on it.

Meanwhile, samsung isn't releasing drivers to tie to the TV.



I know this is the error, and it is the single most infuriating bane of my existence.



I'm having exactly the same problem. It's hard to believe Nvidia can't fix this after 18 months. Thankfully they added an "HDMI Audio Disable" option in the latest driver update; but they don't stick. Every time I turn the computer or monitor back on, I have to enable HDMI audio, then disable it again. Absolutely ridiculous.

#15
Posted 01/31/2010 10:58 PM   
  1 / 2    
Scroll To Top