BF2142 XP and VISTA 178.24 bug FIX! Fixes for XP artifact & VISTA Black bugs
  1 / 3    
Ok, So I have Vista and with the new drivers, the BF2142 black bug was upsetting me. An my firend with XP couldnt even play with the artifacts all over his screen.

I scoured all over and found out whats causing it, which is your AA. But just simply turning it off is annoying and not acceptable.

So, for both users, I have found a temporary fix that works great.

1) Turn off AA [u]IN GAME[/u]
2) Go to nVidia Control panel and go to [i]Adjust image setting with preview[/i]
3) Check the [i]Use the Advance 3d Settings[/i]
4) Then click [i]Take me there[/i]
5) Under [i]Global Settings[/i] switch [i]Antialaising -Mode[/i] to [u]Override any application settings[/u]
6) Switch [i]Antialaising - Setting[/i] to whatever you had in game (2x - 16x)
7) Apply, enter game, enjoy with AA and no more bugs. :)

Feedback from anyone if this worked for you or not! Pretty confident it should work for most setups.

I'm running a 9800 GX2 in multi-gpu mode.
Ok, So I have Vista and with the new drivers, the BF2142 black bug was upsetting me. An my firend with XP couldnt even play with the artifacts all over his screen.



I scoured all over and found out whats causing it, which is your AA. But just simply turning it off is annoying and not acceptable.



So, for both users, I have found a temporary fix that works great.



1) Turn off AA IN GAME

2) Go to nVidia Control panel and go to Adjust image setting with preview

3) Check the Use the Advance 3d Settings

4) Then click Take me there

5) Under Global Settings switch Antialaising -Mode to Override any application settings

6) Switch Antialaising - Setting to whatever you had in game (2x - 16x)

7) Apply, enter game, enjoy with AA and no more bugs. :)



Feedback from anyone if this worked for you or not! Pretty confident it should work for most setups.



I'm running a 9800 GX2 in multi-gpu mode.

#1
Posted 10/20/2008 02:37 AM   
[b]Cartire:[/b] It works - thank you! I have XP 32 bit running an 8800GTS 512 and had the exact same problems with the 178.24 drivers on 1680x1050 with AA 4x. I was pulling my hair out when I couldn't fix it and found folk that were uninstalling the driver (ack!).

Before your suggetion, I found that 1024x768 with AA 4x worked, but clearly that wasn't acceptable. The problem definately appears to be due to the drivers and the use of AA (if you don't have AA on, you won't have the problem).

I will note that I do not prefer your instruction in changing the 'Global,' setting, I went into 'Program Settings' specific to BF2142 with the same results.

Credit to you:

[url="http://www.zinclan.com/portal/forums/index.php?topic=1117.msg12413#msg12413"]http://www.zinclan.com/portal/forums/index...g12413#msg12413[/url]

[b]- Chance[/b]
Cartire: It works - thank you! I have XP 32 bit running an 8800GTS 512 and had the exact same problems with the 178.24 drivers on 1680x1050 with AA 4x. I was pulling my hair out when I couldn't fix it and found folk that were uninstalling the driver (ack!).



Before your suggetion, I found that 1024x768 with AA 4x worked, but clearly that wasn't acceptable. The problem definately appears to be due to the drivers and the use of AA (if you don't have AA on, you won't have the problem).



I will note that I do not prefer your instruction in changing the 'Global,' setting, I went into 'Program Settings' specific to BF2142 with the same results.



Credit to you:



http://www.zinclan.com/portal/forums/index...g12413#msg12413



- Chance

#2
Posted 10/20/2008 10:41 PM   
Just to let people know; the Nvidia recommended settings for BF2142 in the control panel for the Antialaising is or should be 2x. So if you keep it on 2x in the game you should not have to worry about that.

I am going to test this out and see what it does for me. I will post back if it works for me.

Note for the record.: I have 2 @ eVGA 8800GTS 640MB cards with driver (178.13 modded by side).

I tried this method and it works. /thumbup.gif' class='bbc_emoticon' alt=':thumbup:' />
Just to let people know; the Nvidia recommended settings for BF2142 in the control panel for the Antialaising is or should be 2x. So if you keep it on 2x in the game you should not have to worry about that.



I am going to test this out and see what it does for me. I will post back if it works for me.



Note for the record.: I have 2 @ eVGA 8800GTS 640MB cards with driver (178.13 modded by side).



I tried this method and it works. /thumbup.gif' class='bbc_emoticon' alt=':thumbup:' />

#3
Posted 10/21/2008 04:41 PM   
Since I overrided settings in the NVidia Panel, I get kicked by Punkbuster after about 10 minutes of game. Anyone else have this problem ?

For the time being, I'm going back to 175.19 drivers /blarg.gif' class='bbc_emoticon' alt=':/' />
Since I overrided settings in the NVidia Panel, I get kicked by Punkbuster after about 10 minutes of game. Anyone else have this problem ?



For the time being, I'm going back to 175.19 drivers /blarg.gif' class='bbc_emoticon' alt=':/' />

#4
Posted 11/10/2008 05:26 PM   
With the release of new drivers, do the new drivers fix this issue?
With the release of new drivers, do the new drivers fix this issue?

#5
Posted 11/20/2008 07:42 PM   
Im running 64bit vista having the same problem with Battlefield 2142 ( the screen turns black when being shot or if i get hit by an orbital strike). I'm now running 180.48 drivers still with the same problem if i leave the AA on in game. BUT even if i change it like suggested there appears to be no AA in game. I don't know if this has to do with it but in the manage 3D settings if i check the box that says "Show only programs found on this computer" there appears to be no programs at all (so usually i leave it unchecked). Maybe this is due to my multiple harddrives?

All in all i can't get the game to play with decent AA unless i either A) Deal with the black screens (Haha!) B ) roll back my drivers to 177.41 June 26, 2008 ( i think all the 177.xx work)

~I'm running a BFG GTX 280 OCX~
Im running 64bit vista having the same problem with Battlefield 2142 ( the screen turns black when being shot or if i get hit by an orbital strike). I'm now running 180.48 drivers still with the same problem if i leave the AA on in game. BUT even if i change it like suggested there appears to be no AA in game. I don't know if this has to do with it but in the manage 3D settings if i check the box that says "Show only programs found on this computer" there appears to be no programs at all (so usually i leave it unchecked). Maybe this is due to my multiple harddrives?



All in all i can't get the game to play with decent AA unless i either A) Deal with the black screens (Haha!) B ) roll back my drivers to 177.41 June 26, 2008 ( i think all the 177.xx work)



~I'm running a BFG GTX 280 OCX~

#6
Posted 11/20/2008 10:48 PM   
Didn't fix it for me either... Still have to run no AA. As Pawz said, even with AA on in the NVIDIA control panel, in game graphics clearly show that AA is not on at all.
Didn't fix it for me either... Still have to run no AA. As Pawz said, even with AA on in the NVIDIA control panel, in game graphics clearly show that AA is not on at all.

#7
Posted 11/21/2008 12:52 PM   
It worked for me ! Thx a lot !
It worked for me ! Thx a lot !

#8
Posted 11/21/2008 01:07 PM   
[quote name='Cartire' post='454089' date='Oct 19 2008, 09:37 PM']Ok, So I have Vista and with the new drivers, the BF2142 black bug was upsetting me. An my firend with XP couldnt even play with the artifacts all over his screen.

I scoured all over and found out whats causing it, which is your AA. But just simply turning it off is annoying and not acceptable.

So, for both users, I have found a temporary fix that works great.

1) Turn off AA [u]IN GAME[/u]
2) Go to nVidia Control panel and go to [i]Adjust image setting with preview[/i]
3) Check the [i]Use the Advance 3d Settings[/i]
4) Then click [i]Take me there[/i]
5) Under [i]Global Settings[/i] switch [i]Antialaising -Mode[/i] to [u]Override any application settings[/u]
6) Switch [i]Antialaising - Setting[/i] to whatever you had in game (2x - 16x)
7) Apply, enter game, enjoy with AA and no more bugs. :)

Feedback from anyone if this worked for you or not! Pretty confident it should work for most setups.

I'm running a 9800 GX2 in multi-gpu mode.[/quote]
this worked for me on the 180.48 drivers...but that driver has issues with my other games so i went back to 178.13...nvidia has put out like 5 or 6 drivers that are broken with bf2142 lately. i don't know if i should bother upgrading my driver anymore. 8800 gts 512
[quote name='Cartire' post='454089' date='Oct 19 2008, 09:37 PM']Ok, So I have Vista and with the new drivers, the BF2142 black bug was upsetting me. An my firend with XP couldnt even play with the artifacts all over his screen.



I scoured all over and found out whats causing it, which is your AA. But just simply turning it off is annoying and not acceptable.



So, for both users, I have found a temporary fix that works great.



1) Turn off AA IN GAME

2) Go to nVidia Control panel and go to Adjust image setting with preview

3) Check the Use the Advance 3d Settings

4) Then click Take me there

5) Under Global Settings switch Antialaising -Mode to Override any application settings

6) Switch Antialaising - Setting to whatever you had in game (2x - 16x)

7) Apply, enter game, enjoy with AA and no more bugs. :)



Feedback from anyone if this worked for you or not! Pretty confident it should work for most setups.



I'm running a 9800 GX2 in multi-gpu mode.

this worked for me on the 180.48 drivers...but that driver has issues with my other games so i went back to 178.13...nvidia has put out like 5 or 6 drivers that are broken with bf2142 lately. i don't know if i should bother upgrading my driver anymore. 8800 gts 512

#9
Posted 11/23/2008 01:24 PM   
Hi,
I found that this didn't work for me as Nvidia control panel doesn't affect AA in game (BF 2142), Maybe it depends which driver you are using. Was driving me crazy as i've got GT 8600 and good spec machine so want to run at least 2x.
Anyway disabled in game AA and installed Nhancer app and let that control the app. here's the link [url="http://www.nhancer.com/"]http://www.nhancer.com/[/url]
I used the Battlefield 2 Profile within nhancer and just pointed it at my 2142.exe as well. Make sure that AA is on in nhancer (may get a warning about NVidia not recommending this, well it's gotta be better than freaky patterns right?) and run the game.

Now AA is working, no patterns and the t/l seems to be improved (bonus.)

I'd probably try the fix that the first post above recommends first as it doesn't mean installing extra s/ware. Anyway hope this helps.

reeeespec!!
Hi,

I found that this didn't work for me as Nvidia control panel doesn't affect AA in game (BF 2142), Maybe it depends which driver you are using. Was driving me crazy as i've got GT 8600 and good spec machine so want to run at least 2x.

Anyway disabled in game AA and installed Nhancer app and let that control the app. here's the link http://www.nhancer.com/

I used the Battlefield 2 Profile within nhancer and just pointed it at my 2142.exe as well. Make sure that AA is on in nhancer (may get a warning about NVidia not recommending this, well it's gotta be better than freaky patterns right?) and run the game.



Now AA is working, no patterns and the t/l seems to be improved (bonus.)



I'd probably try the fix that the first post above recommends first as it doesn't mean installing extra s/ware. Anyway hope this helps.



reeeespec!!

#10
Posted 11/23/2008 03:06 PM   
gone back to 177 drivers now, better than having a 5 degree rise in temps, new drivers raised card temps, with minimal gain for me
gone back to 177 drivers now, better than having a 5 degree rise in temps, new drivers raised card temps, with minimal gain for me

#11
Posted 11/23/2008 08:27 PM   
Excuse me but this whole thread is nonsense. You CANNOT override AA settings in BF2142. If you don't believe me read:

[url="http://www.nzone.com/object/nzone_bf2142_techtips.html"]http://www.nzone.com/object/nzone_bf2142_techtips.html[/url]

"Don't try forcing AA (anti-aliasing) using the Driver Control Panel. Battlefield 2142 uses its own AA method. Use the in-game AA to squeeze all the juice from your GPU."

Now if anyone from nVidia is reading this: The black screen issue in BF2142 is still not fixed on latest 180.48 WHQL drivers. I'm forced to using a driver as old as 175.19 WHQL until that is fixed and not getting the performance I expect from newer games. Please don't leave us in the dilemma of choosing between new and old favorites.
Excuse me but this whole thread is nonsense. You CANNOT override AA settings in BF2142. If you don't believe me read:



http://www.nzone.com/object/nzone_bf2142_techtips.html



"Don't try forcing AA (anti-aliasing) using the Driver Control Panel. Battlefield 2142 uses its own AA method. Use the in-game AA to squeeze all the juice from your GPU."



Now if anyone from nVidia is reading this: The black screen issue in BF2142 is still not fixed on latest 180.48 WHQL drivers. I'm forced to using a driver as old as 175.19 WHQL until that is fixed and not getting the performance I expect from newer games. Please don't leave us in the dilemma of choosing between new and old favorites.

#12
Posted 11/24/2008 12:10 AM   
[quote name='Brut3Forc3' post='467598' date='Nov 24 2008, 11:10 AM']Excuse me but this whole thread is nonsense. You CANNOT override AA settings in BF2142. If you don't believe me read:

[url="http://www.nzone.com/object/nzone_bf2142_techtips.html"]http://www.nzone.com/object/nzone_bf2142_techtips.html[/url]

"Don't try forcing AA (anti-aliasing) using the Driver Control Panel. Battlefield 2142 uses its own AA method. Use the in-game AA to squeeze all the juice from your GPU."

Now if anyone from nVidia is reading this: The black screen issue in BF2142 is still not fixed on latest 180.48 WHQL drivers. I'm forced to using a driver as old as 175.19 WHQL until that is fixed and not getting the performance I expect from newer games. Please don't leave us in the dilemma of choosing between new and old favorites.[/quote]
Thanks for that reply... I was sure the forced AA wasn't working, now I know :(

Turning AA off in game fixes the black screen in Vista and the artifacts in XP but then you have to deal with poor quality graphics... The drivers NEED to be fixed, PLEASE!
[quote name='Brut3Forc3' post='467598' date='Nov 24 2008, 11:10 AM']Excuse me but this whole thread is nonsense. You CANNOT override AA settings in BF2142. If you don't believe me read:



http://www.nzone.com/object/nzone_bf2142_techtips.html



"Don't try forcing AA (anti-aliasing) using the Driver Control Panel. Battlefield 2142 uses its own AA method. Use the in-game AA to squeeze all the juice from your GPU."



Now if anyone from nVidia is reading this: The black screen issue in BF2142 is still not fixed on latest 180.48 WHQL drivers. I'm forced to using a driver as old as 175.19 WHQL until that is fixed and not getting the performance I expect from newer games. Please don't leave us in the dilemma of choosing between new and old favorites.

Thanks for that reply... I was sure the forced AA wasn't working, now I know :(



Turning AA off in game fixes the black screen in Vista and the artifacts in XP but then you have to deal with poor quality graphics... The drivers NEED to be fixed, PLEASE!

#13
Posted 11/24/2008 12:20 AM   
[quote name='Brut3Forc3' post='467598' date='Nov 24 2008, 01:10 PM']Excuse me but this whole thread is nonsense. You CANNOT override AA settings in BF2142. If you don't believe me read:

[url="http://www.nzone.com/object/nzone_bf2142_techtips.html"]http://www.nzone.com/object/nzone_bf2142_techtips.html[/url]

"Don't try forcing AA (anti-aliasing) using the Driver Control Panel. Battlefield 2142 uses its own AA method. Use the in-game AA to squeeze all the juice from your GPU."

Now if anyone from nVidia is reading this: The black screen issue in BF2142 is still not fixed on latest 180.48 WHQL drivers. I'm forced to using a driver as old as 175.19 WHQL until that is fixed and not getting the performance I expect from newer games. Please don't leave us in the dilemma of choosing between new and old favorites.[/quote]
couldnt agree more

although i doubt nvidia actually reads these forums/cares what we have to say tbh
[quote name='Brut3Forc3' post='467598' date='Nov 24 2008, 01:10 PM']Excuse me but this whole thread is nonsense. You CANNOT override AA settings in BF2142. If you don't believe me read:



http://www.nzone.com/object/nzone_bf2142_techtips.html



"Don't try forcing AA (anti-aliasing) using the Driver Control Panel. Battlefield 2142 uses its own AA method. Use the in-game AA to squeeze all the juice from your GPU."



Now if anyone from nVidia is reading this: The black screen issue in BF2142 is still not fixed on latest 180.48 WHQL drivers. I'm forced to using a driver as old as 175.19 WHQL until that is fixed and not getting the performance I expect from newer games. Please don't leave us in the dilemma of choosing between new and old favorites.

couldnt agree more



although i doubt nvidia actually reads these forums/cares what we have to say tbh

#14
Posted 11/24/2008 12:21 AM   
[quote name='Brut3Forc3' post='467598' date='Nov 23 2008, 06:10 PM']Excuse me but this whole thread is nonsense. You CANNOT override AA settings in BF2142.[/quote]


This thread isn't about overriding AA settings, it's about getting discoloration/artifacts in game with AA on. On a further note, if you do go back to old drivers games like Far Cry 2 among others complain/are unstable with the old drivers.

Ps: Nhancer did not work
[quote name='Brut3Forc3' post='467598' date='Nov 23 2008, 06:10 PM']Excuse me but this whole thread is nonsense. You CANNOT override AA settings in BF2142.





This thread isn't about overriding AA settings, it's about getting discoloration/artifacts in game with AA on. On a further note, if you do go back to old drivers games like Far Cry 2 among others complain/are unstable with the old drivers.



Ps: Nhancer did not work

#15
Posted 11/24/2008 12:48 AM   
  1 / 3    
Scroll To Top