Nvidia Driver/Resolution Issue in Ubuntu 8.04.1 EDID info incorrect/xorg.conf
Greetings,

I am struggling with getting native resolution on my ViewSonic VX2025WM monitor using the 173.14.05 driver for Linux. The installation goes perfectly but when the X-Server starts I have resolutions of 640x480. What is strange is I cannot force the Nvidia driver to ignore EDID in xorg.conf which has always worked in the past.

Here is a post of the problem as I have reported it to "Bugs in “xorg-server” source package in Ubuntu" under EDID Fail (https://bugs.launchpad.net/ubuntu/+source/xorg-server/+bug/194760).

Here is a post seeking for Answers in the same launchpad:
[url="https://answers.launchpad.net/ubuntu/+source/xorg-server/+question/39299"]https://answers.launchpad.net/ubuntu/+sourc...+question/39299[/url]

Nothing that I have tried so far has allowed an over-ride of EDID in xorg.conf and I cannot get resolutions above 640x480.

My hardware:
nForce 780i 3-Way SLI motherboard with GeForce 9800 GTX (G92) XXX 512MB 256-bit GDDR3 PCI-Express 2.0 x16 HDPC Ready SLI video card

Operating System is Kubuntu 8.04.1 installed from ISO downloaded on July 1st, 2008. Nvidia driver was downloaded today and is version 173.14.05. I had the same issues with the 173.14.09 beta driver so I opted for the "stable" driver instead thinking to have better luck with it.

Here is my xorg.conf as it applies to display/video:

Section "Device"
Identifier "Configured Video Device"
Boardname "GeForce 9800GTX"
Busid "PCI:3:0:0"
Driver "nvidia"
Option "ConnectedMonitor" "DFP-0"
Option "IgnoreEDID" "TRUE"
Option "UseEDID" "FALSE"
Option "UseEDIDFreqs" "FALSE"
Option "UseEDIDDpi" "FALSE"
Option "ModeValidation" "NoEdidModes"
Option "DPI" "96 x 96"
EndSection

Section "Monitor"
Identifier "Configured Monitor"
Vendorname "Generic LCD Display"
Modelname "LCD Panel 1680x1050"
Horizsync 30.0 - 82.0
Vertrefresh 50.0 - 75.0
Option "MetaModes" "1680x1050_60"
EndSection

Section "Screen"
Identifier "Default Screen"
Monitor "Configured Monitor"
Device "Configured Video Device"
Defaultdepth 24
SubSection "Display"
Depth 24
Virtual 1680 1050
Modes "1680x1050_60"
EndSubSection
EndSection

Section "Module"
Load "glx"
Load "v4l"
EndSection

Here is part of my Xorg.0.log after rebooting using the Nvidia driver:

(II) Setting vga for screen 0.
(**) NVIDIA(0): Depth 24, (--) framebuffer bpp 32
(==) NVIDIA(0): RGB weight 888
(==) NVIDIA(0): Default visual is TrueColor
(==) NVIDIA(0): Using gamma correction (1.0, 1.0, 1.0)
(**) NVIDIA(0): Option "IgnoreEDID" "TRUE"
(**) NVIDIA(0): Option "UseEDID" "FALSE"
(**) NVIDIA(0): Option "ConnectedMonitor" "DFP-0"
(**) NVIDIA(0): Option "UseEdidFreqs" "FALSE"
(**) NVIDIA(0): Option "MetaModes" "1680x1050_60"
(**) NVIDIA(0): Option "UseEdidDpi" "FALSE"
(**) NVIDIA(0): Option "DPI" "96 x 96"
(**) NVIDIA(0): Option "ModeValidation" "NoEdidModes"
(**) NVIDIA(0): Enabling RENDER acceleration
(**) NVIDIA(0): Using HorizSync/VertRefresh ranges from the EDID has been
(**) NVIDIA(0): disabled on all display devices.
(**) NVIDIA(0): ConnectedMonitor string: "DFP-0"
(WW) NVIDIA(0):
(WW) NVIDIA(0): The IgnoreEDID and NoDDC options have been deprecated. The
(WW) NVIDIA(0): NVIDIA X driver makes use of a display device's EDID
(WW) NVIDIA(0): during construction of its modePool. It is recommended
(WW) NVIDIA(0): that you allow the X driver to make use of any available
(WW) NVIDIA(0): EDID. If, however, you know what you are doing and have
(WW) NVIDIA(0): good reason to do so, you can disable the X driver's use
(WW) NVIDIA(0): of EDIDs by setting the "UseEDID" X configuration option
(WW) NVIDIA(0): to FALSE; e.g.,
(WW) NVIDIA(0):
(WW) NVIDIA(0): Option "UseEDID" "FALSE"
(WW) NVIDIA(0):
(WW) NVIDIA(0): Note that, rather than globally disable all uses of the EDID,
(WW) NVIDIA(0): you can individually disable each particular use of the
(WW) NVIDIA(0): EDID; e.g.,
(WW) NVIDIA(0):
(WW) NVIDIA(0): Option "UseEDIDFreqs" "FALSE"
(WW) NVIDIA(0): Option "UseEDIDDpi" "FALSE"
(WW) NVIDIA(0): Option "ModeValidation" "NoEdidModes"
(WW) NVIDIA(0):
(WW) NVIDIA(0): See Appendix B: X Config Options in the README for details on
(WW) NVIDIA(0): each of these options.
(WW) NVIDIA(0):
(**) NVIDIA(0): Ignoring EDIDs
(II) NVIDIA(0): Support for GLX with the Damage and Composite X extensions is
(II) NVIDIA(0): enabled.
(II) NVIDIA(GPU-0): Not probing EDID on DFP-0.
(II) NVIDIA(0): NVIDIA GPU GeForce 9800 GTX (G92) at PCI:3:0:0 (GPU-0)
(--) NVIDIA(0): Memory: 524288 kBytes
(--) NVIDIA(0): VideoBIOS: 62.92.3b.00.0b
(II) NVIDIA(0): Detected PCI Express Link width: 16X
(--) NVIDIA(0): Interlaced video modes are supported on this GPU
(--) NVIDIA(0): Connected display device(s) on GeForce 9800 GTX at PCI:3:0:0:
(--) NVIDIA(0): DFP-0
(--) NVIDIA(0): DFP-0: 330.0 MHz maximum pixel clock
(--) NVIDIA(0): DFP-0: Internal Dual Link TMDS
(II) NVIDIA(0): Mode Validation Overrides for DFP-0:
(II) NVIDIA(0): NoEdidModes
(II) NVIDIA(0): Assigned Display Device: DFP-0
(WW) NVIDIA(0): No valid modes for "1680x1050_60"; removing.
(WW) NVIDIA(0):
(WW) NVIDIA(0): Unable to validate any modes; falling back to the default mode
(WW) NVIDIA(0): "nvidia-auto-select".
(WW) NVIDIA(0):
(II) NVIDIA(0): Validated modes:
(II) NVIDIA(0): "nvidia-auto-select"
(II) NVIDIA(0): Virtual screen size determined to be 640 x 480
(**) NVIDIA(0): DPI set to (96, 96); computed from "DPI" X config option
(==) NVIDIA(0): Enabling 32-bit ARGB GLX visuals.
(--) Depth 24 pixmap format is 32 bpp

Apparently "nvidia-auto-select" has an extremely low resolution and I do not know how to increase it.

This is very frustrating, I have brand new hardware, the very best I could afford, and I cannot even use it to a fraction of its potential due to some driver issue I cannot over-ride as Nvidia and Xorg have suggested.

At this point any and all help is greatly appreciated!

Best Regards,
Gail
Greetings,



I am struggling with getting native resolution on my ViewSonic VX2025WM monitor using the 173.14.05 driver for Linux. The installation goes perfectly but when the X-Server starts I have resolutions of 640x480. What is strange is I cannot force the Nvidia driver to ignore EDID in xorg.conf which has always worked in the past.



Here is a post of the problem as I have reported it to "Bugs in “xorg-server” source package in Ubuntu" under EDID Fail (https://bugs.launchpad.net/ubuntu/+source/xorg-server/+bug/194760).



Here is a post seeking for Answers in the same launchpad:

https://answers.launchpad.net/ubuntu/+sourc...+question/39299



Nothing that I have tried so far has allowed an over-ride of EDID in xorg.conf and I cannot get resolutions above 640x480.



My hardware:

nForce 780i 3-Way SLI motherboard with GeForce 9800 GTX (G92) XXX 512MB 256-bit GDDR3 PCI-Express 2.0 x16 HDPC Ready SLI video card



Operating System is Kubuntu 8.04.1 installed from ISO downloaded on July 1st, 2008. Nvidia driver was downloaded today and is version 173.14.05. I had the same issues with the 173.14.09 beta driver so I opted for the "stable" driver instead thinking to have better luck with it.



Here is my xorg.conf as it applies to display/video:



Section "Device"

Identifier "Configured Video Device"

Boardname "GeForce 9800GTX"

Busid "PCI:3:0:0"

Driver "nvidia"

Option "ConnectedMonitor" "DFP-0"

Option "IgnoreEDID" "TRUE"

Option "UseEDID" "FALSE"

Option "UseEDIDFreqs" "FALSE"

Option "UseEDIDDpi" "FALSE"

Option "ModeValidation" "NoEdidModes"

Option "DPI" "96 x 96"

EndSection



Section "Monitor"

Identifier "Configured Monitor"

Vendorname "Generic LCD Display"

Modelname "LCD Panel 1680x1050"

Horizsync 30.0 - 82.0

Vertrefresh 50.0 - 75.0

Option "MetaModes" "1680x1050_60"

EndSection



Section "Screen"

Identifier "Default Screen"

Monitor "Configured Monitor"

Device "Configured Video Device"

Defaultdepth 24

SubSection "Display"

Depth 24

Virtual 1680 1050

Modes "1680x1050_60"

EndSubSection

EndSection



Section "Module"

Load "glx"

Load "v4l"

EndSection



Here is part of my Xorg.0.log after rebooting using the Nvidia driver:



(II) Setting vga for screen 0.

(**) NVIDIA(0): Depth 24, (--) framebuffer bpp 32

(==) NVIDIA(0): RGB weight 888

(==) NVIDIA(0): Default visual is TrueColor

(==) NVIDIA(0): Using gamma correction (1.0, 1.0, 1.0)

(**) NVIDIA(0): Option "IgnoreEDID" "TRUE"

(**) NVIDIA(0): Option "UseEDID" "FALSE"

(**) NVIDIA(0): Option "ConnectedMonitor" "DFP-0"

(**) NVIDIA(0): Option "UseEdidFreqs" "FALSE"

(**) NVIDIA(0): Option "MetaModes" "1680x1050_60"

(**) NVIDIA(0): Option "UseEdidDpi" "FALSE"

(**) NVIDIA(0): Option "DPI" "96 x 96"

(**) NVIDIA(0): Option "ModeValidation" "NoEdidModes"

(**) NVIDIA(0): Enabling RENDER acceleration

(**) NVIDIA(0): Using HorizSync/VertRefresh ranges from the EDID has been

(**) NVIDIA(0): disabled on all display devices.

(**) NVIDIA(0): ConnectedMonitor string: "DFP-0"

(WW) NVIDIA(0):

(WW) NVIDIA(0): The IgnoreEDID and NoDDC options have been deprecated. The

(WW) NVIDIA(0): NVIDIA X driver makes use of a display device's EDID

(WW) NVIDIA(0): during construction of its modePool. It is recommended

(WW) NVIDIA(0): that you allow the X driver to make use of any available

(WW) NVIDIA(0): EDID. If, however, you know what you are doing and have

(WW) NVIDIA(0): good reason to do so, you can disable the X driver's use

(WW) NVIDIA(0): of EDIDs by setting the "UseEDID" X configuration option

(WW) NVIDIA(0): to FALSE; e.g.,

(WW) NVIDIA(0):

(WW) NVIDIA(0): Option "UseEDID" "FALSE"

(WW) NVIDIA(0):

(WW) NVIDIA(0): Note that, rather than globally disable all uses of the EDID,

(WW) NVIDIA(0): you can individually disable each particular use of the

(WW) NVIDIA(0): EDID; e.g.,

(WW) NVIDIA(0):

(WW) NVIDIA(0): Option "UseEDIDFreqs" "FALSE"

(WW) NVIDIA(0): Option "UseEDIDDpi" "FALSE"

(WW) NVIDIA(0): Option "ModeValidation" "NoEdidModes"

(WW) NVIDIA(0):

(WW) NVIDIA(0): See Appendix B: X Config Options in the README for details on

(WW) NVIDIA(0): each of these options.

(WW) NVIDIA(0):

(**) NVIDIA(0): Ignoring EDIDs

(II) NVIDIA(0): Support for GLX with the Damage and Composite X extensions is

(II) NVIDIA(0): enabled.

(II) NVIDIA(GPU-0): Not probing EDID on DFP-0.

(II) NVIDIA(0): NVIDIA GPU GeForce 9800 GTX (G92) at PCI:3:0:0 (GPU-0)

(--) NVIDIA(0): Memory: 524288 kBytes

(--) NVIDIA(0): VideoBIOS: 62.92.3b.00.0b

(II) NVIDIA(0): Detected PCI Express Link width: 16X

(--) NVIDIA(0): Interlaced video modes are supported on this GPU

(--) NVIDIA(0): Connected display device(s) on GeForce 9800 GTX at PCI:3:0:0:

(--) NVIDIA(0): DFP-0

(--) NVIDIA(0): DFP-0: 330.0 MHz maximum pixel clock

(--) NVIDIA(0): DFP-0: Internal Dual Link TMDS

(II) NVIDIA(0): Mode Validation Overrides for DFP-0:

(II) NVIDIA(0): NoEdidModes

(II) NVIDIA(0): Assigned Display Device: DFP-0

(WW) NVIDIA(0): No valid modes for "1680x1050_60"; removing.

(WW) NVIDIA(0):

(WW) NVIDIA(0): Unable to validate any modes; falling back to the default mode

(WW) NVIDIA(0): "nvidia-auto-select".

(WW) NVIDIA(0):

(II) NVIDIA(0): Validated modes:

(II) NVIDIA(0): "nvidia-auto-select"

(II) NVIDIA(0): Virtual screen size determined to be 640 x 480

(**) NVIDIA(0): DPI set to (96, 96); computed from "DPI" X config option

(==) NVIDIA(0): Enabling 32-bit ARGB GLX visuals.

(--) Depth 24 pixmap format is 32 bpp



Apparently "nvidia-auto-select" has an extremely low resolution and I do not know how to increase it.



This is very frustrating, I have brand new hardware, the very best I could afford, and I cannot even use it to a fraction of its potential due to some driver issue I cannot over-ride as Nvidia and Xorg have suggested.



At this point any and all help is greatly appreciated!



Best Regards,

Gail

#1
Posted 07/22/2008 12:53 AM   
Update - I am able to get the Nvidia driver to work with my monitor plugged into the analog cable. Apparently the EDID information passed by the DVI connection is hosed. After spending the entire day trying to make this work via digital signal I am settling for analog and native resolution with Nvidia drivers.

If anything changes I will post again.

Another Update - Ok, this feels a lot like talking to myself but here goes.

I used the Nvidia Settings program to generate a valid EDID.bin profile, after I successfully logged into Kubuntu using the analog connection. It's under the setting for GPU-0 > DFP-0 > Acquire EDID. I saved it onto my hard drive.

Then I added the "Option "CustomEDID" "DFP-0:/path/to/edid.bin". I shut down the computer, unplugged the analog cable, plugged in the digital and booted into perfect resolution.

When I ran [code]sudo get-edid[/code] I still got EDID failure so that confirmed that the solution above is working. Now to turn on the bells and whistles. I am very happy to have found a solution and I hope that this helps others out as well.


[code]get-edid: get-edid version 1.4.1

       Performing real mode VBE call
       Interrupt 0x10 ax=0x4f00 bx=0x0 cx=0x0
       Function supported
       Call successful

       VBE version 300
       VBE string at 0x11110 "NVIDIA"

VBE/DDC service about to be called
       Report DDC capabilities

       Performing real mode VBE call
       Interrupt 0x10 ax=0x4f15 bx=0x0 cx=0x0
       Function supported
       Call successful

       Monitor and video card combination does not support DDC1 transfers
       Monitor and video card combination supports DDC2 transfers
       0 seconds per 128 byte EDID block transfer
       Screen is not blanked during DDC transfer

Reading next EDID block

VBE/DDC service about to be called
       Read EDID

       Performing real mode VBE call
       Interrupt 0x10 ax=0x4f15 bx=0x1 cx=0x0
       Function supported
       Call failed

The EDID data should not be trusted as the VBE call failed
������Zc����+.���ZI�$PT����@qO1
!9�0b▒'@h�6��Q6Y062507673
�2KR
     ï¿½VX2025wm[/code]
Update - I am able to get the Nvidia driver to work with my monitor plugged into the analog cable. Apparently the EDID information passed by the DVI connection is hosed. After spending the entire day trying to make this work via digital signal I am settling for analog and native resolution with Nvidia drivers.



If anything changes I will post again.



Another Update - Ok, this feels a lot like talking to myself but here goes.



I used the Nvidia Settings program to generate a valid EDID.bin profile, after I successfully logged into Kubuntu using the analog connection. It's under the setting for GPU-0 > DFP-0 > Acquire EDID. I saved it onto my hard drive.



Then I added the "Option "CustomEDID" "DFP-0:/path/to/edid.bin". I shut down the computer, unplugged the analog cable, plugged in the digital and booted into perfect resolution.



When I ran
sudo get-edid
I still got EDID failure so that confirmed that the solution above is working. Now to turn on the bells and whistles. I am very happy to have found a solution and I hope that this helps others out as well.





get-edid: get-edid version 1.4.1



       Performing real mode VBE call

       Interrupt 0x10 ax=0x4f00 bx=0x0 cx=0x0

       Function supported

       Call successful



       VBE version 300

       VBE string at 0x11110 "NVIDIA"



VBE/DDC service about to be called

       Report DDC capabilities



       Performing real mode VBE call

       Interrupt 0x10 ax=0x4f15 bx=0x0 cx=0x0

       Function supported

       Call successful



       Monitor and video card combination does not support DDC1 transfers

       Monitor and video card combination supports DDC2 transfers

       0 seconds per 128 byte EDID block transfer

       Screen is not blanked during DDC transfer



Reading next EDID block



VBE/DDC service about to be called

       Read EDID



       Performing real mode VBE call

       Interrupt 0x10 ax=0x4f15 bx=0x1 cx=0x0

       Function supported

       Call failed



The EDID data should not be trusted as the VBE call failed

������Zc����+.���ZI�$PT����@qO1

!9�0b▒'@h�6��Q6Y062507673

�2KR

     ï¿½VX2025wm

#2
Posted 07/22/2008 02:35 AM   
Thx for your solution,

Its working perfectly.

Great work mate,
Thx for your solution,



Its working perfectly.



Great work mate,

#3
Posted 08/25/2008 04:21 AM   
Hi Anlace,

just thanx for posting your solution,

worked perfectly!
Hi Anlace,



just thanx for posting your solution,



worked perfectly!

#4
Posted 11/14/2008 12:39 AM   
I am running Ubuntu 9.10 64 bit. I had been using a Nvidia Geforce 6500 DVI output connected to a Samsung 1920x1080 monitor but the DVI output broke so I bought a Nvidia Geforce 8400. This would work fine with the analog connector but the DVI connector did not seem to interrogate the monitor for its resolution and only worked at 640x480. Most frustrating.

With the analog connection I got the Nvidia X Server Settings program to get the EDID data and save it to a file. I then put the following line into xorg.conf

Option "CustomEDID" "DFP-0:/home/me/edid.bin"

I put it in both the Screen section and the Monitor section (I haven't tried by elimination the one that is effective). To my delight the system now works with DVI at the correct resolution. This was thanks to Anlace.

Why the 6500 worked, when the 8400 did not, using DVI (until it broke) I don't know. The difference in the connectors is that the 6500 had a DVI-D while the 8400 has a DVI-I but I don't think this can be the cause. Wonderful to have it working at pin sharp DVI 1920x1080.
I am running Ubuntu 9.10 64 bit. I had been using a Nvidia Geforce 6500 DVI output connected to a Samsung 1920x1080 monitor but the DVI output broke so I bought a Nvidia Geforce 8400. This would work fine with the analog connector but the DVI connector did not seem to interrogate the monitor for its resolution and only worked at 640x480. Most frustrating.



With the analog connection I got the Nvidia X Server Settings program to get the EDID data and save it to a file. I then put the following line into xorg.conf



Option "CustomEDID" "DFP-0:/home/me/edid.bin"



I put it in both the Screen section and the Monitor section (I haven't tried by elimination the one that is effective). To my delight the system now works with DVI at the correct resolution. This was thanks to Anlace.



Why the 6500 worked, when the 8400 did not, using DVI (until it broke) I don't know. The difference in the connectors is that the 6500 had a DVI-D while the 8400 has a DVI-I but I don't think this can be the cause. Wonderful to have it working at pin sharp DVI 1920x1080.

#5
Posted 02/04/2010 09:34 PM   
I Know this is a long dead thread but it shows up in google and I had the same problem after upgrading to 10.04 with a dual monitor setup (DFP-0 and CRT-0). Anlace solution does work, the only difference for me is the Acquire EDID button did not show up in the DFP-0 option but in the CRT-0 (even though it was the DFP-0 that was not showing proper resolution). Generating it through CRT-0 and then adding the line that Anlace indicates solved the problem for me.

Randy



[quote name='Anlace' date='21 July 2008 - 09:35 PM' timestamp='1216694134' post='414085']
Update - I am able to get the Nvidia driver to work with my monitor plugged into the analog cable. Apparently the EDID information passed by the DVI connection is hosed. After spending the entire day trying to make this work via digital signal I am settling for analog and native resolution with Nvidia drivers.

If anything changes I will post again.

Another Update - Ok, this feels a lot like talking to myself but here goes.

I used the Nvidia Settings program to generate a valid EDID.bin profile, after I successfully logged into Kubuntu using the analog connection. It's under the setting for GPU-0 > DFP-0 > Acquire EDID. I saved it onto my hard drive.

Then I added the "Option "CustomEDID" "DFP-0:/path/to/edid.bin". I shut down the computer, unplugged the analog cable, plugged in the digital and booted into perfect resolution.

When I ran [code]sudo get-edid[/code] I still got EDID failure so that confirmed that the solution above is working. Now to turn on the bells and whistles. I am very happy to have found a solution and I hope that this helps others out as well.


[code]get-edid: get-edid version 1.4.1

       Performing real mode VBE call
       Interrupt 0x10 ax=0x4f00 bx=0x0 cx=0x0
       Function supported
       Call successful

       VBE version 300
       VBE string at 0x11110 "NVIDIA"

VBE/DDC service about to be called
       Report DDC capabilities

       Performing real mode VBE call
       Interrupt 0x10 ax=0x4f15 bx=0x0 cx=0x0
       Function supported
       Call successful

       Monitor and video card combination does not support DDC1 transfers
       Monitor and video card combination supports DDC2 transfers
       0 seconds per 128 byte EDID block transfer
       Screen is not blanked during DDC transfer

Reading next EDID block

VBE/DDC service about to be called
       Read EDID

       Performing real mode VBE call
       Interrupt 0x10 ax=0x4f15 bx=0x1 cx=0x0
       Function supported
       Call failed

The EDID data should not be trusted as the VBE call failed
������Zc����+.���ZI�$PT����@qO1
!9�0b▒'@h�6��Q6Y062507673
�2KR
     �VX2025wm[/code]
[/quote]
I Know this is a long dead thread but it shows up in google and I had the same problem after upgrading to 10.04 with a dual monitor setup (DFP-0 and CRT-0). Anlace solution does work, the only difference for me is the Acquire EDID button did not show up in the DFP-0 option but in the CRT-0 (even though it was the DFP-0 that was not showing proper resolution). Generating it through CRT-0 and then adding the line that Anlace indicates solved the problem for me.



Randy







[quote name='Anlace' date='21 July 2008 - 09:35 PM' timestamp='1216694134' post='414085']

Update - I am able to get the Nvidia driver to work with my monitor plugged into the analog cable. Apparently the EDID information passed by the DVI connection is hosed. After spending the entire day trying to make this work via digital signal I am settling for analog and native resolution with Nvidia drivers.



If anything changes I will post again.



Another Update - Ok, this feels a lot like talking to myself but here goes.



I used the Nvidia Settings program to generate a valid EDID.bin profile, after I successfully logged into Kubuntu using the analog connection. It's under the setting for GPU-0 > DFP-0 > Acquire EDID. I saved it onto my hard drive.



Then I added the "Option "CustomEDID" "DFP-0:/path/to/edid.bin". I shut down the computer, unplugged the analog cable, plugged in the digital and booted into perfect resolution.



When I ran
sudo get-edid
I still got EDID failure so that confirmed that the solution above is working. Now to turn on the bells and whistles. I am very happy to have found a solution and I hope that this helps others out as well.





get-edid: get-edid version 1.4.1



       Performing real mode VBE call

       Interrupt 0x10 ax=0x4f00 bx=0x0 cx=0x0

       Function supported

       Call successful



       VBE version 300

       VBE string at 0x11110 "NVIDIA"



VBE/DDC service about to be called

       Report DDC capabilities



       Performing real mode VBE call

       Interrupt 0x10 ax=0x4f15 bx=0x0 cx=0x0

       Function supported

       Call successful



       Monitor and video card combination does not support DDC1 transfers

       Monitor and video card combination supports DDC2 transfers

       0 seconds per 128 byte EDID block transfer

       Screen is not blanked during DDC transfer



Reading next EDID block



VBE/DDC service about to be called

       Read EDID



       Performing real mode VBE call

       Interrupt 0x10 ax=0x4f15 bx=0x1 cx=0x0

       Function supported

       Call failed



The EDID data should not be trusted as the VBE call failed

������Zc����+.���ZI�$PT����@qO1

!9�0b▒'@h�6��Q6Y062507673

�2KR

     �VX2025wm


#6
Posted 12/29/2010 04:07 PM   
Using the above I was able to patch together a solution:

0. I set a virtual X viewport of 1024x1024, so even if my screen resolution was limited to 640x480 I could still open and scroll around to use reasonably sized windows.

1. I ran "[i]sudo get-edid[/i]" to verify I was getting bad info:
[code]The EDID data should not be trusted as the VBE call failed
EDID claims 255 more blocks left
EDID blocks left is wrong.
Your EDID is probably invalid.
[/code]

2. Then I downloaded [i]Phoenix EDID Designer[/i] from http://www.tucows.com/preview/329441 ,and ran it "[i]wine Phoenix.exe[/i]". This was the fun part: creating a new EDID from scratch, even getting to set the vendor ID and model number. I matched the specifications of my monitor and saved in in "raw" format.

3. I backed up "xorg.conf" and edited:
[code]
Section "Device"
VendorName "NVIDIA Corporation"
BoardName "GeForce GT 430"
...
Option "CustomEDID" "DFP-0:/home/bnesbitt/XP-17-EDID.raw"
EndSection
[/code]

4. Poof, native resolution.
Using the above I was able to patch together a solution:



0. I set a virtual X viewport of 1024x1024, so even if my screen resolution was limited to 640x480 I could still open and scroll around to use reasonably sized windows.



1. I ran "sudo get-edid" to verify I was getting bad info:

The EDID data should not be trusted as the VBE call failed

EDID claims 255 more blocks left

EDID blocks left is wrong.

Your EDID is probably invalid.




2. Then I downloaded Phoenix EDID Designer from http://www.tucows.com/preview/329441 ,and ran it "wine Phoenix.exe". This was the fun part: creating a new EDID from scratch, even getting to set the vendor ID and model number. I matched the specifications of my monitor and saved in in "raw" format.



3. I backed up "xorg.conf" and edited:



Section "Device"

VendorName "NVIDIA Corporation"

BoardName "GeForce GT 430"

...

Option "CustomEDID" "DFP-0:/home/bnesbitt/XP-17-EDID.raw"

EndSection




4. Poof, native resolution.

#7
Posted 02/16/2012 07:46 PM   
Scroll To Top