HDMI: How to disable?
  1 / 13    
I own a GeForce 8800GT with HDMI support as well as a HDMI capable Viewsonic VX2835wm display I use Windows XP and I despair due to overscan issues in quite any resolution modes I chose:

The borders of my desktop are out of the viewing range of my display (for example no Start bar visible) and the picture is blurred even when I am using native display resolution of 1920 x 1200.

Yes, I tried quite a number of suggestions like the NVIDIA provided overscan patch and I was near to hack the EDID info of my display.

Now when I use my display with my old 7950 GT or I use a non HDMI dispay with my graphics card I do not run into this problems so I expect the HDMI "feature" to be the problem.

My Viewsonic display is connected with a multi purpose DVI/HDMI connector to the multi purpose CVI/HDMI connector of my graphics board. Regretly there is no simple DVI connector attached to the display and the two devices allways seem to agree upon HDMI mode no matter what I do.

My question is: Is here any way to disable HDMI either by software or maybe at least by hardware (i. e. non HDMI compiland cable)?

I want to use my display in native resolution mode so much (gaming and working) and for watching TV I have my TV set! :(
I own a GeForce 8800GT with HDMI support as well as a HDMI capable Viewsonic VX2835wm display I use Windows XP and I despair due to overscan issues in quite any resolution modes I chose:



The borders of my desktop are out of the viewing range of my display (for example no Start bar visible) and the picture is blurred even when I am using native display resolution of 1920 x 1200.



Yes, I tried quite a number of suggestions like the NVIDIA provided overscan patch and I was near to hack the EDID info of my display.



Now when I use my display with my old 7950 GT or I use a non HDMI dispay with my graphics card I do not run into this problems so I expect the HDMI "feature" to be the problem.



My Viewsonic display is connected with a multi purpose DVI/HDMI connector to the multi purpose CVI/HDMI connector of my graphics board. Regretly there is no simple DVI connector attached to the display and the two devices allways seem to agree upon HDMI mode no matter what I do.



My question is: Is here any way to disable HDMI either by software or maybe at least by hardware (i. e. non HDMI compiland cable)?



I want to use my display in native resolution mode so much (gaming and working) and for watching TV I have my TV set! :(

#1
Posted 02/01/2008 06:49 AM   
Similar issue here.

I am using a 8600GT with a Westinghouse L2410 LCD monitor. The monitor does not have a DVI input, so I am using a DVI->HDMI adapter. However, the nVidia control panel assumes I have a HDTV plugged in, and proceeds to ruin the image. Text is blurry, everything appears oversharpened, and the colors are dull. I previously used this same monitor/cable combination with a Radeon x1650 and it looked excellent.

The default Vista driver looked excellent as well, but of course then I don't get very good video performance otherwise.

This is definitely a nVidia driver problem. If it would let me specify that I'm not using a HDTV, I think things would be OK. What resources do we have to remedy this?
Similar issue here.



I am using a 8600GT with a Westinghouse L2410 LCD monitor. The monitor does not have a DVI input, so I am using a DVI->HDMI adapter. However, the nVidia control panel assumes I have a HDTV plugged in, and proceeds to ruin the image. Text is blurry, everything appears oversharpened, and the colors are dull. I previously used this same monitor/cable combination with a Radeon x1650 and it looked excellent.



The default Vista driver looked excellent as well, but of course then I don't get very good video performance otherwise.



This is definitely a nVidia driver problem. If it would let me specify that I'm not using a HDTV, I think things would be OK. What resources do we have to remedy this?

#2
Posted 02/01/2008 02:40 PM   
I just want to chime in and say that I'd love to see this solution come to reality. It's either this, or some way to fiddle with custom timings (which is also impossible atm) while I use a VGA connection to my HDTV.
I just want to chime in and say that I'd love to see this solution come to reality. It's either this, or some way to fiddle with custom timings (which is also impossible atm) while I use a VGA connection to my HDTV.

#3
Posted 02/03/2008 12:00 AM   
[quote name='Mu0n' date='Feb 2 2008, 07:00 PM']I just want to chime in and say that I'd love to see this solution come to reality. It's either this, or some way to fiddle with custom timings (which is also impossible atm) while I use a VGA connection to my HDTV.
[right][snapback]319323[/snapback][/right]
[/quote]

Wow, I found posts on this dating back almost a year. So much for this card, I give up. I only have a 30-day window for a refund from newegg, and it looks like I can't wait around for a resolution. An ATI 2600 HD card will decode HD video better for the same price and no driver issues.

Nothing but trouble with nVidia cards in the past... I should have stuck with ATI with this one too.
[quote name='Mu0n' date='Feb 2 2008, 07:00 PM']I just want to chime in and say that I'd love to see this solution come to reality. It's either this, or some way to fiddle with custom timings (which is also impossible atm) while I use a VGA connection to my HDTV.

[snapback]319323[/snapback]






Wow, I found posts on this dating back almost a year. So much for this card, I give up. I only have a 30-day window for a refund from newegg, and it looks like I can't wait around for a resolution. An ATI 2600 HD card will decode HD video better for the same price and no driver issues.



Nothing but trouble with nVidia cards in the past... I should have stuck with ATI with this one too.

#4
Posted 02/03/2008 06:15 AM   
im replying to all the posts
im replying to all the posts

#5
Posted 02/03/2008 06:54 AM   
[quote name='mikemayo21' date='Feb 2 2008, 10:54 PM']im replying to all the posts
[right][snapback]319495[/snapback][/right]
[/quote]


did anyone found a solution for this problem
[quote name='mikemayo21' date='Feb 2 2008, 10:54 PM']im replying to all the posts

[snapback]319495[/snapback]








did anyone found a solution for this problem

#6
Posted 02/08/2008 02:24 PM   
Just want to add, that I have the same problem:

8800gt LG 24''
Vista64 and XP various driver versions.

It works in Linux btw.

(Just replying to all posts with this problem, maybe someone notices it -any idea how to report the issue to NVIDIA? )

Ceearem
Just want to add, that I have the same problem:



8800gt LG 24''

Vista64 and XP various driver versions.



It works in Linux btw.



(Just replying to all posts with this problem, maybe someone notices it -any idea how to report the issue to NVIDIA? )



Ceearem

#7
Posted 02/13/2008 12:30 AM   
Same problem here. ECS 8800GT and LG L246W. ATi has fixed this in their drivers from 7.10 forward. What is the holdup with Nvidia?

It's quite frustrating. All I can suggest is to fill out the bug report at [url="https://surveys.nvidia.com/index.jsp?pi=7498eac864dc1950c8f09e040b4a437a"]Nvidia bug report[/url].

Does anyone know what the "Treat as HDTV" option does in Windows XP? Presumably it sets some registry key value. Since that option is not available in Vista, I'm wondering if setting the registry key would still have some effect (IE. it's just hidden in the UI but still supported).
Same problem here. ECS 8800GT and LG L246W. ATi has fixed this in their drivers from 7.10 forward. What is the holdup with Nvidia?



It's quite frustrating. All I can suggest is to fill out the bug report at Nvidia bug report.



Does anyone know what the "Treat as HDTV" option does in Windows XP? Presumably it sets some registry key value. Since that option is not available in Vista, I'm wondering if setting the registry key would still have some effect (IE. it's just hidden in the UI but still supported).

#8
Posted 02/13/2008 02:01 AM   
As I have installed XP as well as Vista I can tell you that this checkbox has apparently no other function than activating or deactivating the function which allows to zoom your desktop to the right size. It does not deactivate the hdmi signal transfer and hence it does not sovle the problem.
As I have installed XP as well as Vista I can tell you that this checkbox has apparently no other function than activating or deactivating the function which allows to zoom your desktop to the right size. It does not deactivate the hdmi signal transfer and hence it does not sovle the problem.

#9
Posted 02/13/2008 02:42 PM   
I wonder if this would help - [url="http://forums.nvidia.com/index.php?showtopic=48946&mode=threaded"]Possible fix for Some Scaling Issues, I fixed my 8800 + Widescreen Scaling![/url]

My monitor's EDID also reports a max resolution of 1600x1200. The driver reports 1920x1200 though. My suspicion is that the NVidia card ignores the driver when hooked up over HDMI since it assumes it's talking to a TV. I haven't yet tried hacking EDID, since I'm a little nervous about the effects of doing that (IE. Does HDCP get messed up?)

I also found some interesting registry keys in some nv_disp.inf files found [url="http://www.laptopvideo2go.com/forum/lofiversion/index.php?t15828.html"]here[/url]:

nv_HDTVModes
nv_HDTVModesFRR

I tried adding 1920x1200 to those keys and importing them into the registry, but all that happened was I lost 1920x1200 as an option. It's possible I didn't modify them properly, so feel free to give it a shot.
I wonder if this would help - Possible fix for Some Scaling Issues, I fixed my 8800 + Widescreen Scaling!



My monitor's EDID also reports a max resolution of 1600x1200. The driver reports 1920x1200 though. My suspicion is that the NVidia card ignores the driver when hooked up over HDMI since it assumes it's talking to a TV. I haven't yet tried hacking EDID, since I'm a little nervous about the effects of doing that (IE. Does HDCP get messed up?)



I also found some interesting registry keys in some nv_disp.inf files found here:



nv_HDTVModes

nv_HDTVModesFRR



I tried adding 1920x1200 to those keys and importing them into the registry, but all that happened was I lost 1920x1200 as an option. It's possible I didn't modify them properly, so feel free to give it a shot.

#10
Posted 02/13/2008 05:54 PM   
I tried the OverrideEdidFlags0 method to force 1920x1200 support on my monitor but it didn't seem to have any effect. Seems like this flag may not be supported in Vista.
I tried the OverrideEdidFlags0 method to force 1920x1200 support on my monitor but it didn't seem to have any effect. Seems like this flag may not be supported in Vista.

#11
Posted 02/14/2008 11:01 PM   
Hey guys,

I've discovered a workaround for this problem. Basically you can use a registry key to override the monitor advertising itself as an HDTV (by setting the number of EDID extensions to 0). Using the following steps, I am now getting proper 1920x1200 resolution on my LG monitor:

1. Start the installation of the latest Nvidia drivers and cancel out once the files are extracted
2. Open nv_disp.inf. By default for the current drivers this is in C:\NVIDIA\WinVista\169.25
3. In the [nv_SoftwareDeviceSettings] section add the following:
[code]
HKR,, OverrideEdidFlags0, %REG_BINARY%, 1E,6D,3F,56,00,00,FF,FF,04,00,00,00,7E,01,00[/code]

[b]NOTE[/b]
The first 4 bytes (1E,6D,3F,56) in my OverrideEdidFlags0 are specific to the LG monitor I'm using. For other monitors, you will need to replace them. Using [url="http://www.tucows.com/preview/329441"]Phoenix EDID Designer[/url], extract the current EDID and open up the byte viewer. The bytes are in byte 8 through 11.

4. Uninstall your current drivers and reboot
5. Install the modified drivers by running the previously extracted setup.exe. By default for the current drivers this is in C:\NVIDIA\WinVista\169.25. You'll get a warning about the driver not being signed because of the modified inf. Just press OK.
Hey guys,



I've discovered a workaround for this problem. Basically you can use a registry key to override the monitor advertising itself as an HDTV (by setting the number of EDID extensions to 0). Using the following steps, I am now getting proper 1920x1200 resolution on my LG monitor:



1. Start the installation of the latest Nvidia drivers and cancel out once the files are extracted

2. Open nv_disp.inf. By default for the current drivers this is in C:\NVIDIA\WinVista\169.25

3. In the [nv_SoftwareDeviceSettings] section add the following:



HKR,, OverrideEdidFlags0, %REG_BINARY%, 1E,6D,3F,56,00,00,FF,FF,04,00,00,00,7E,01,00




NOTE

The first 4 bytes (1E,6D,3F,56) in my OverrideEdidFlags0 are specific to the LG monitor I'm using. For other monitors, you will need to replace them. Using Phoenix EDID Designer, extract the current EDID and open up the byte viewer. The bytes are in byte 8 through 11.



4. Uninstall your current drivers and reboot

5. Install the modified drivers by running the previously extracted setup.exe. By default for the current drivers this is in C:\NVIDIA\WinVista\169.25. You'll get a warning about the driver not being signed because of the modified inf. Just press OK.

#12
Posted 02/20/2008 11:02 PM   
/w00t.gif' class='bbc_emoticon' alt=':w00t:' /> YYYYYesssss!!!

How did you find out bryanb?

Works absolutely like charm!

For my Viewsonic VX2835wm it was

HKR,, OverrideEdidFlags0, %REG_BINARY%, 5A,63,1F,0F,00,00,FF,FF,04,00,00,00,7E,01,00

It worked exactly as you described:

I took the bytes 8 to 11 of the Phoenix EDID Designer byte viewer (5A,63,1F,0F) and replaced the first four bytes of your example (1E,6D,3F,56).

Now every resolution is working as you'd usually expect: The picture is always stretched to the exact size of my display. In native display resolution (1920x1200) I get a totally brilliant picture. NVIDIA: He's the man who prevented to make me throw my graphics board out of the window ^_^

Thanks a lot!
/w00t.gif' class='bbc_emoticon' alt=':w00t:' /> YYYYYesssss!!!



How did you find out bryanb?



Works absolutely like charm!



For my Viewsonic VX2835wm it was



HKR,, OverrideEdidFlags0, %REG_BINARY%, 5A,63,1F,0F,00,00,FF,FF,04,00,00,00,7E,01,00



It worked exactly as you described:



I took the bytes 8 to 11 of the Phoenix EDID Designer byte viewer (5A,63,1F,0F) and replaced the first four bytes of your example (1E,6D,3F,56).



Now every resolution is working as you'd usually expect: The picture is always stretched to the exact size of my display. In native display resolution (1920x1200) I get a totally brilliant picture. NVIDIA: He's the man who prevented to make me throw my graphics board out of the window ^_^



Thanks a lot!

#13
Posted 02/21/2008 07:40 PM   
I registered here today just to thank bryanb, your solution fixed my overscan, and had the welcome side effect of fixing a sound issue i've been having using a 8500gt with a samsung hdtv.

There was no sound at all using the dvi to hdmi adapter and analogue audio cables, and nvidia control panel reported it as a hdmi connection. now it reports as "dvi- high definition television over dvi" and i have full sound.

even samsung technical support were mystified by this problem, they thought the tv firmware might be bugged :D
I registered here today just to thank bryanb, your solution fixed my overscan, and had the welcome side effect of fixing a sound issue i've been having using a 8500gt with a samsung hdtv.



There was no sound at all using the dvi to hdmi adapter and analogue audio cables, and nvidia control panel reported it as a hdmi connection. now it reports as "dvi- high definition television over dvi" and i have full sound.



even samsung technical support were mystified by this problem, they thought the tv firmware might be bugged :D

#14
Posted 02/22/2008 07:33 AM   
8 through 11? so 08, 09, 0A, 0B?
8 through 11? so 08, 09, 0A, 0B?

#15
Posted 02/22/2008 07:21 PM   
  1 / 13    
Scroll To Top