Call of Duty 4 ( Vsync ) How to run smooth with Vsync enable
Hi all,

Since I bought this game, I notice that the Vsync enable on game, I get an perfect 60fps on my Geforce 8800GTS 320MB XXX edition by XFX @ 1680x1050 but i notice one problem, ( on every Patch of the game, actually the 1.3 ).

When I look around, on game, just give the effect like "frame-by-frame" but i look at the frames and are 60fps ( with "cg_drawfps 1" command ). On game if I turn the Vsync off, I get 90 fps average, its good but no for an LCD with 60hz. So, I tryed to turn off the Vsync on game, and force him on "Nvidia Control Panel" and... voila... get the same 60fps ( offcourse ) but now my game is much more smooth, when I look around on game, the "360º view" is now much more smoth, without that "frame-by-frame" effect.

So for all users, who have this problem in other games, or COD4, just enable the Vsync on Nvidia Control panel, instead the vsync of the game on options...

PS: Only tested on Windows Xp Sp2 32-Bit with 169.21 beta drivers ; on Windows Vista i didn't tested because the game run smooth with Vsync enable on game, not perfect but better then XP, so I think the CoD4, the Vsync on game is optimized for Vista...I think ;)


Core 2 Duo E6600 @ 2.80Ghz
Windows Xp Sp2 32bit & Windows Vista x64
4GB DDR2 800 - nForce680i - Geforce8800 GTS 320MB XXX edition
1680x1050 Samsung SyncMaster 205W ( DVI )
Hi all,



Since I bought this game, I notice that the Vsync enable on game, I get an perfect 60fps on my Geforce 8800GTS 320MB XXX edition by XFX @ 1680x1050 but i notice one problem, ( on every Patch of the game, actually the 1.3 ).



When I look around, on game, just give the effect like "frame-by-frame" but i look at the frames and are 60fps ( with "cg_drawfps 1" command ). On game if I turn the Vsync off, I get 90 fps average, its good but no for an LCD with 60hz. So, I tryed to turn off the Vsync on game, and force him on "Nvidia Control Panel" and... voila... get the same 60fps ( offcourse ) but now my game is much more smooth, when I look around on game, the "360º view" is now much more smoth, without that "frame-by-frame" effect.



So for all users, who have this problem in other games, or COD4, just enable the Vsync on Nvidia Control panel, instead the vsync of the game on options...



PS: Only tested on Windows Xp Sp2 32-Bit with 169.21 beta drivers ; on Windows Vista i didn't tested because the game run smooth with Vsync enable on game, not perfect but better then XP, so I think the CoD4, the Vsync on game is optimized for Vista...I think ;)





Core 2 Duo E6600 @ 2.80Ghz

Windows Xp Sp2 32bit & Windows Vista x64

4GB DDR2 800 - nForce680i - Geforce8800 GTS 320MB XXX edition

1680x1050 Samsung SyncMaster 205W ( DVI )

#1
Posted 12/17/2007 03:27 PM   
good to know, i will give this a try if i ever need to. thanks.
good to know, i will give this a try if i ever need to. thanks.

ASUS P5N-D 750i SLI Motherboard.
Intel Core 2 Duo E6750, 2.66GHz OCed To 3.8GHz On Air Cooling.
4 GB Corsair XMS2 SLI Ready DDR2 800 OCed.
Two WD Caviar SE 16 250 GB SATA-II 7200 RPM HDD's In RAID 0.
One Seagate 320 GB SATA-II 7200 RPM HDD For Media.
Zotac GTS 250 512MB, Stock clocks for now.
Logitech THX Z-5300.
Samsung SyncMaster 2232GW 22'' Widescreen LCD.
Acer X191W 19'' Widescreen LCD (For Dualview)
Windows Vista Home Premium 32bit / Windows XP 32bit.

#2
Posted 12/17/2007 03:55 PM   
Scroll To Top