PIXEL SHADER VERSION ERROR
My system specs are :

Intel Core 2 Duo E6700
Transcend 2GB DDR2 Ram
Intel Original D975XBX2 Motherboard
Seagate 400 GB HDD
Creative 7.1 Sound Card
nVidia 8800 GTX 786 MB

OS : Windows XP SP2

If u need any more specs, please do request.

The problem is, i installed lost planet extreme condition demo. When i start the game, i get a FATAL ERROR saying "Unsupported Pixel Shader Version 1.4"
When i ran a system requirements lab games test, used to verify whether my pc can play a specific game, all the high end games also showed it needed version 3.0 or something and i have only 1.4 .
My gpu is able to play lost planet, and i know it. Iam not using any beta drivers, but the latest stable driver version 162.18, dated July 26, 2007. Please, someone help me.
My system specs are :



Intel Core 2 Duo E6700

Transcend 2GB DDR2 Ram

Intel Original D975XBX2 Motherboard

Seagate 400 GB HDD

Creative 7.1 Sound Card

nVidia 8800 GTX 786 MB



OS : Windows XP SP2



If u need any more specs, please do request.



The problem is, i installed lost planet extreme condition demo. When i start the game, i get a FATAL ERROR saying "Unsupported Pixel Shader Version 1.4"

When i ran a system requirements lab games test, used to verify whether my pc can play a specific game, all the high end games also showed it needed version 3.0 or something and i have only 1.4 .

My gpu is able to play lost planet, and i know it. Iam not using any beta drivers, but the latest stable driver version 162.18, dated July 26, 2007. Please, someone help me.

#1
Posted 09/14/2007 11:20 AM   
Your card supports Pixel Shader 4.0, DX 9.0c comes with 3.0. I'd say update your DX files from microsoft.com
Your card supports Pixel Shader 4.0, DX 9.0c comes with 3.0. I'd say update your DX files from microsoft.com

#2
Posted 09/14/2007 11:31 AM   
Just now, when i checked with system requirements lab again, it says i have 3.0 ! again error,, instead of 4.0, as u said. I have DirectX August Redistributable Package innstalled. Please help.

PS. The system requirements lab also shows this ?
Your driver version number is: 6.14.11.6218
Just now, when i checked with system requirements lab again, it says i have 3.0 ! again error,, instead of 4.0, as u said. I have DirectX August Redistributable Package innstalled. Please help.



PS. The system requirements lab also shows this ?

Your driver version number is: 6.14.11.6218

#3
Posted 09/14/2007 11:52 AM   
Well, 3.0 is as high as you are going to get, 4.0 is DX10 which is Vista only. Grab the 163.44 drivers or higher.
Well, 3.0 is as high as you are going to get, 4.0 is DX10 which is Vista only. Grab the 163.44 drivers or higher.

#4
Posted 09/14/2007 12:06 PM   
can u please help me with the lost planet error ?
And, aren't beta releases troublesome, stable is good, right ? or, do u suggest to t ake the latest beta drivers ?
can u please help me with the lost planet error ?

And, aren't beta releases troublesome, stable is good, right ? or, do u suggest to t ake the latest beta drivers ?

#5
Posted 09/14/2007 12:14 PM   
as i already told, the game, when launched, says Fatal Errror, Unsupported pixel shader version 1.4.
as i already told, the game, when launched, says Fatal Errror, Unsupported pixel shader version 1.4.

#6
Posted 09/14/2007 12:16 PM   
Try newer drivers, update your DX from the MS website.
Try newer drivers, update your DX from the MS website.

#7
Posted 09/14/2007 12:49 PM   
i just installed the beta drivers (latest) and i already have all the ms updates and latest directx (august 2007). September is not out yet. So........ What next , buddy ?
i just installed the beta drivers (latest) and i already have all the ms updates and latest directx (august 2007). September is not out yet. So........ What next , buddy ?

#8
Posted 09/14/2007 01:07 PM   
are you sure you didn't install the DX10 version by mistake? the demo comes in two flavours; those using XP directx9, and those using vista DX10.
are you sure you didn't install the DX10 version by mistake? the demo comes in two flavours; those using XP directx9, and those using vista DX10.

#9
Posted 09/14/2007 04:16 PM   
DX 9 for sure
DX 9 for sure

#10
Posted 09/14/2007 04:28 PM   
have you tried completely uninstalling the graphics card drivers from your system? if you haven't, try that, and reinstall the current stable drivers.
have you tried completely uninstalling the graphics card drivers from your system? if you haven't, try that, and reinstall the current stable drivers.

#11
Posted 09/15/2007 04:32 PM   
Basically, it seems as though your game thinks that you have a GeForce4 card in there(DX8.1). Other than DX and drivers, I am not sure. Do you have both 6-pins plugged into your video card? Maybe your video card is lowering it's self because of a lack of power(not that I think it can drop several shaders because of it).
Basically, it seems as though your game thinks that you have a GeForce4 card in there(DX8.1). Other than DX and drivers, I am not sure. Do you have both 6-pins plugged into your video card? Maybe your video card is lowering it's self because of a lack of power(not that I think it can drop several shaders because of it).

#12
Posted 09/15/2007 11:43 PM   
Scroll To Top