LCD panel scaling
I have a HP LP3065 30" LCD attached to a PNY GeForce 8800GTX, with ForceWare v97.92.

The HP docs say the panel only works at 2560x1600@60Hz.

Lower resolutions still show up (e.g. BIOS POST and setup), but are scaled up.

I don't know if the docs are lying, and that the monitor automatically scales lower resolutions up, or if the graphics card does the scaling automatically, based on the capabilities reported by the panel.

In any case, stretch scaling works all by itself. However, I'd like to keep aspect ratios.

In the nVidia control panel, there are four options under "Change Flat Panel Scaling":

1) Use NVIDIA scaling
2) Use NVIDIA scaling with fixed-aspect ratio
3) Use my display's built-in scaling
4) Do not scale

#1 is selected whenever I open the control panel, and both #2 and #4 are active. #3 is not, which lends support to the notion that the panel has nothing to do with any of the scaling that's going on.

So I select option #2, hit Apply, etc. Now I launch WolfET in fullscreen (I had it set to a 1600x1200 or 2048x1536 window up to now), and it's doing option #1 scaling. Go back into the control panel, and option #1 is selected.

So I change it back to #2, close the control panel, then immediately open it again. It's back to #1.

I get the same thing if I try option #4 as well.

Clearly it's some kind of bug. Is it a bug in setting the scale mode, that I can work around by setting a registry value directly? Or is it a bug to even offer other scaling modes (i.e. the others aren't implemented), and there's nothing I can do except wait for the next version?
I have a HP LP3065 30" LCD attached to a PNY GeForce 8800GTX, with ForceWare v97.92.



The HP docs say the panel only works at 2560x1600@60Hz.



Lower resolutions still show up (e.g. BIOS POST and setup), but are scaled up.



I don't know if the docs are lying, and that the monitor automatically scales lower resolutions up, or if the graphics card does the scaling automatically, based on the capabilities reported by the panel.



In any case, stretch scaling works all by itself. However, I'd like to keep aspect ratios.



In the nVidia control panel, there are four options under "Change Flat Panel Scaling":



1) Use NVIDIA scaling

2) Use NVIDIA scaling with fixed-aspect ratio

3) Use my display's built-in scaling

4) Do not scale



#1 is selected whenever I open the control panel, and both #2 and #4 are active. #3 is not, which lends support to the notion that the panel has nothing to do with any of the scaling that's going on.



So I select option #2, hit Apply, etc. Now I launch WolfET in fullscreen (I had it set to a 1600x1200 or 2048x1536 window up to now), and it's doing option #1 scaling. Go back into the control panel, and option #1 is selected.



So I change it back to #2, close the control panel, then immediately open it again. It's back to #1.



I get the same thing if I try option #4 as well.



Clearly it's some kind of bug. Is it a bug in setting the scale mode, that I can work around by setting a registry value directly? Or is it a bug to even offer other scaling modes (i.e. the others aren't implemented), and there's nothing I can do except wait for the next version?

#1
Posted 01/16/2007 02:53 AM   
Hmm... (Ok). So you had a problem and now your sharing your knowledge ?

Anyway cool. LoL /wave.gif' class='bbc_emoticon' alt=':wave:' /> /shifty.gif' class='bbc_emoticon' alt=':shifty:' /> :rolleyes: B) ^_^ :D
Hmm... (Ok). So you had a problem and now your sharing your knowledge ?



Anyway cool. LoL /wave.gif' class='bbc_emoticon' alt=':wave:' /> /shifty.gif' class='bbc_emoticon' alt=':shifty:' /> :rolleyes: B) ^_^ :D

MSI Z77A-GD65
Intel Xeon E3-1230 v2
4x4GB Samsung DDR3-1600
Samsung 840 Pro 128GB
PNY GeForce GTX 680
----------------------------
"Human's aren't the only species on Earth, We just act like it..."

#2
Posted 01/16/2007 05:48 AM   
You can get around this problem by setting your own custom timings:

In the control panel select Advanced View then Manage Custom Timings

Create new - enter the native resolution, refresh rate, colour depth and select the Timing standard as Auto or DMT.

It sometimes takes several attempts of the Test and oking the new setting for my monitor to actually go to the unscaled resolution.

I found it easier to set the refresh rate to 60 then change it as normal from the desktop afterwards.
You can get around this problem by setting your own custom timings:



In the control panel select Advanced View then Manage Custom Timings



Create new - enter the native resolution, refresh rate, colour depth and select the Timing standard as Auto or DMT.



It sometimes takes several attempts of the Test and oking the new setting for my monitor to actually go to the unscaled resolution.



I found it easier to set the refresh rate to 60 then change it as normal from the desktop afterwards.

#3
Posted 01/16/2007 11:33 AM   
Same problem here Thanny. For some reason the control panel is not applying changes to scaling. It always jumps back to the default setting (#1). It is frustrating. Hopefully Nvidia corrects this on the next driver release.
Same problem here Thanny. For some reason the control panel is not applying changes to scaling. It always jumps back to the default setting (#1). It is frustrating. Hopefully Nvidia corrects this on the next driver release.

#4
Posted 01/17/2007 03:02 AM   
8800GTS
Same problem - very frustrating.
This was not a problem with my 7900GT (with the driver from 4 months ago).

The custom timings thing didn't work - and anyway, I wanted to disable scaling for games, so I don't know that custom timings would help even if it worked.
8800GTS

Same problem - very frustrating.

This was not a problem with my 7900GT (with the driver from 4 months ago).



The custom timings thing didn't work - and anyway, I wanted to disable scaling for games, so I don't know that custom timings would help even if it worked.

#5
Posted 01/17/2007 06:48 AM   
yo, same issue here ... :(

... this is since 97.44

8800GTX
Dell 3007WFP 30"

pls fix this nvidia
yo, same issue here ... :(



... this is since 97.44



8800GTX

Dell 3007WFP 30"



pls fix this nvidia

#6
Posted 01/22/2007 11:46 AM   
I don't even have an option for Flat Panel Scaling in Control Panel (97.92 drivers). I can't bring myself to play any non WS games stretched... I tried submitting a thing through Nvidia a week ago with no response.
I don't even have an option for Flat Panel Scaling in Control Panel (97.92 drivers). I can't bring myself to play any non WS games stretched... I tried submitting a thing through Nvidia a week ago with no response.

#7
Posted 02/08/2007 05:20 AM   
The custom timing work around seems to have actually worked for me. I can't believe it. I'll reserve judgement until a few reboots of course, but right now I have a crisp image on my secondary display for the first time in forever.
The control panel is still clunky, however, and needs a serious fix in any area where multiple monitors can be selected by clicking the image of the monitor. Also, anyone else get garbled rubbish in the overlay area when looking at the video settings?
The custom timing work around seems to have actually worked for me. I can't believe it. I'll reserve judgement until a few reboots of course, but right now I have a crisp image on my secondary display for the first time in forever.

The control panel is still clunky, however, and needs a serious fix in any area where multiple monitors can be selected by clicking the image of the monitor. Also, anyone else get garbled rubbish in the overlay area when looking at the video settings?

#8
Posted 02/24/2007 09:59 AM   
Check out page 28 of the latest Release notes;

[url="http://us.download.nvidia.com/Windows/100.65/100.65_ForceWare_Release_Notes.pdf"]http://us.download.nvidia.com/Windows/100....lease_Notes.pdf[/url]

Seems to suggest that although 2560x1600 was available in the 7 series, it is not available in the 8 series.

Gutted really as my new rig arriving next week has 8800's and probably won't work on my lovely 30" Dell !!!

Brian.
Check out page 28 of the latest Release notes;



http://us.download.nvidia.com/Windows/100....lease_Notes.pdf



Seems to suggest that although 2560x1600 was available in the 7 series, it is not available in the 8 series.



Gutted really as my new rig arriving next week has 8800's and probably won't work on my lovely 30" Dell !!!



Brian.

----------------------------------------------------------------------------------------
Lian-Li PC-343B Black CASE
LiquoCool Antarctic TXD Extreme (CPU+2Chipset+2VGA)
Enermax Galaxy Modular 1000W PSU
Asus Striker Extreme 680i SLI (1333 FSB Conroe)
Intel Core 2 Quad QX6700 Extreme Retail (4x2.66GHz 1066FSB 8Mb)
(2 x) OCZ DDR2-1150 2x1024MB FlexXLC Edition Dual Channel Kit
(2 x) Nvidia 8800GTX 768Mb PCIe HDCP
(2 x) 150Gb Raptor 10000 16mb E-SATA
(2 x) 500GB WD Caviar RE2 7200 16mb Cache SATA II NCQ
NEC AD-7173A 18x dual layer DVDRW black
Pioneer 111DBK DVDRW Black
Creative 7.1 X-FI ExtremeGamer Fatal1ty
Windows Vista Ultimate 64 bit
Dell 3007WFP

#9
Posted 02/24/2007 11:39 PM   
Holy s--t! Brian you must have taken out a second mortgage to pay for that list of equipment. I too have a Dell 3007WFP. It's hands down the best moniter I've ever owned. CRT or LCD. And I've been gaming a long time (i.e. Commodore 64). Driver ver. 100.65 does support 2560x1600, thats what I use as my native resolution. My only complaint is the lack of scaling options support. I'm starting to get used to playing games stretched, thats scary. Hopefully Nvidia will get this fixed SOON!
Holy s--t! Brian you must have taken out a second mortgage to pay for that list of equipment. I too have a Dell 3007WFP. It's hands down the best moniter I've ever owned. CRT or LCD. And I've been gaming a long time (i.e. Commodore 64). Driver ver. 100.65 does support 2560x1600, thats what I use as my native resolution. My only complaint is the lack of scaling options support. I'm starting to get used to playing games stretched, thats scary. Hopefully Nvidia will get this fixed SOON!

#10
Posted 02/25/2007 12:49 AM   
Somewhere in the release notes for the Nvidia drivers it says that flat panel scaling hasn't been implemented yet. You can try to change it all you want, but it won't do anything. See top of page 6 of the release notes.

I've been using my monitor's "wide / 4:3" setting to adjust for non-widescreen games until they get their drivers in working order.
Somewhere in the release notes for the Nvidia drivers it says that flat panel scaling hasn't been implemented yet. You can try to change it all you want, but it won't do anything. See top of page 6 of the release notes.



I've been using my monitor's "wide / 4:3" setting to adjust for non-widescreen games until they get their drivers in working order.

Raven RV03 / Gigabyte G1.Sniper / 990x / 12GB RAM / 3 x EVGA 580 GTX / 2 x 250GB 510 & 3 x 160GB X-25M Intel SSDs / Antec HCP 1200W

#11
Posted 02/25/2007 05:28 AM   
Scroll To Top