Warcraft 3 and DirectX 9.0c (June) ?!
  1 / 2    
OK this is weird, I installed the latest version of directx 9.0c from 9 June (if I remember correctly) and anyway, now Warcraft III won't even start ?! It says 'Warcraft III was unable to initialize DirectX. Please ensure you have DirectX 8.1 or newer... etc. etc. etc.'

Does this happen to anyone else ?
Also I don't know how to revert back to the earlier DirectX I got. Is there a DirectX removal tool or sth like that ?

P.S. I'm running a P43.0GHz, Gigabyte 6600GT, 2x512mb DDR400.

EDIT: Actually it didn't fix nothing! DirectX 9.0c from June is a piece of junk!

Anyone got any suggestions ? I reinstalled just a week ago, I don't want to reinstall again !
OK this is weird, I installed the latest version of directx 9.0c from 9 June (if I remember correctly) and anyway, now Warcraft III won't even start ?! It says 'Warcraft III was unable to initialize DirectX. Please ensure you have DirectX 8.1 or newer... etc. etc. etc.'



Does this happen to anyone else ?

Also I don't know how to revert back to the earlier DirectX I got. Is there a DirectX removal tool or sth like that ?



P.S. I'm running a P43.0GHz, Gigabyte 6600GT, 2x512mb DDR400.



EDIT: Actually it didn't fix nothing! DirectX 9.0c from June is a piece of junk!



Anyone got any suggestions ? I reinstalled just a week ago, I don't want to reinstall again !

#1
Posted 06/15/2006 06:50 PM   
[quote name='AssassiNBG' date='Jun 15 2006, 01:50 PM']OK this is weird, I installed the latest version of directx 9.0c from 9 June (if I remember correctly) and anyway, now Warcraft III won't even start ?! It says 'Warcraft III was unable to initialize DirectX. Please ensure you have DirectX 8.1 or newer... etc. etc. etc.'

Does this happen to anyone else ?
Also I don't know how to revert back to the earlier DirectX I got. Is there a DirectX removal tool or sth like that ?

P.S. I'm running a P43.0GHz, Gigabyte 6600GT, 2x512mb DDR400.

EDIT: Actually it didn't fix nothing! DirectX 9.0c from June is a piece of junk!

Anyone got any suggestions ? I reinstalled just a week ago, I don't want to reinstall again !
[right][post="95656"]<{POST_SNAPBACK}>[/post][/right][/quote]

Have never had a directX issue, no clue. Well not since Win95 anyways.
[quote name='AssassiNBG' date='Jun 15 2006, 01:50 PM']OK this is weird, I installed the latest version of directx 9.0c from 9 June (if I remember correctly) and anyway, now Warcraft III won't even start ?! It says 'Warcraft III was unable to initialize DirectX. Please ensure you have DirectX 8.1 or newer... etc. etc. etc.'



Does this happen to anyone else ?

Also I don't know how to revert back to the earlier DirectX I got. Is there a DirectX removal tool or sth like that ?



P.S. I'm running a P43.0GHz, Gigabyte 6600GT, 2x512mb DDR400.



EDIT: Actually it didn't fix nothing! DirectX 9.0c from June is a piece of junk!



Anyone got any suggestions ? I reinstalled just a week ago, I don't want to reinstall again !

[post="95656"]<{POST_SNAPBACK}>[/post]




Have never had a directX issue, no clue. Well not since Win95 anyways.

Intel Core 2 Duo 6600 @ 3.3ghz, Asus P5W Deluxe Mobo, 8192mb Mushkin DDR2, EVGA GF8800GTX, Xi-Fi Extreme Gamer Soundcard, Diamondmax 10 300gb HD, 2x Diamondmax Maxline III 250gb, OCZ GameXStream 700W PS

#2
Posted 06/19/2006 09:52 PM   
[quote name='evil' date='Jun 19 2006, 05:52 PM']Have never had a directX issue, no clue. Well not since Win95 anyways.
[right][post="96411"]<{POST_SNAPBACK}>[/post][/right][/quote]
Change to a different month of directX 9.0c ^_^
[quote name='evil' date='Jun 19 2006, 05:52 PM']Have never had a directX issue, no clue. Well not since Win95 anyways.

[post="96411"]<{POST_SNAPBACK}>[/post]


Change to a different month of directX 9.0c ^_^

#3
Posted 06/19/2006 10:15 PM   
I have the same problem. I've tried uninstalling war craft3 and removing all directX file I could find on my drive and in the registry.

I reinstalled warcraft 3 and still get the error.

It started after I reinstalled win 98SE to try and correct a exploror problem.
This has happend to me before.
The only way I found to fix it was fdisk and reinstall windows,

Gord




[quote name='AssassiNBG' date='Jun 15 2006, 11:50 AM']OK this is weird, I installed the latest version of directx 9.0c from 9 June (if I remember correctly) and anyway, now Warcraft III won't even start ?! It says 'Warcraft III was unable to initialize DirectX. Please ensure you have DirectX 8.1 or newer... etc. etc. etc.'

Does this happen to anyone else ?
Also I don't know how to revert back to the earlier DirectX I got. Is there a DirectX removal tool or sth like that ?

P.S. I'm running a P43.0GHz, Gigabyte 6600GT, 2x512mb DDR400.

EDIT: Actually it didn't fix nothing! DirectX 9.0c from June is a piece of junk!

Anyone got any suggestions ? I reinstalled just a week ago, I don't want to reinstall again !
[right][post="95656"]<{POST_SNAPBACK}>[/post][/right][/quote]
I have the same problem. I've tried uninstalling war craft3 and removing all directX file I could find on my drive and in the registry.



I reinstalled warcraft 3 and still get the error.



It started after I reinstalled win 98SE to try and correct a exploror problem.

This has happend to me before.

The only way I found to fix it was fdisk and reinstall windows,



Gord









[quote name='AssassiNBG' date='Jun 15 2006, 11:50 AM']OK this is weird, I installed the latest version of directx 9.0c from 9 June (if I remember correctly) and anyway, now Warcraft III won't even start ?! It says 'Warcraft III was unable to initialize DirectX. Please ensure you have DirectX 8.1 or newer... etc. etc. etc.'



Does this happen to anyone else ?

Also I don't know how to revert back to the earlier DirectX I got. Is there a DirectX removal tool or sth like that ?



P.S. I'm running a P43.0GHz, Gigabyte 6600GT, 2x512mb DDR400.



EDIT: Actually it didn't fix nothing! DirectX 9.0c from June is a piece of junk!



Anyone got any suggestions ? I reinstalled just a week ago, I don't want to reinstall again !

[post="95656"]<{POST_SNAPBACK}>[/post]

#4
Posted 09/04/2006 06:05 PM   
Did you ever fix your issue? I'm curious as to what caused it?
Did you ever fix your issue? I'm curious as to what caused it?

Intel Core 2 Duo 6600 @ 3.3ghz, Asus P5W Deluxe Mobo, 8192mb Mushkin DDR2, EVGA GF8800GTX, Xi-Fi Extreme Gamer Soundcard, Diamondmax 10 300gb HD, 2x Diamondmax Maxline III 250gb, OCZ GameXStream 700W PS

#5
Posted 09/04/2006 09:35 PM   
[quote name='evil' date='Sep 4 2006, 02:35 PM']Did you ever fix your issue? I'm curious as to what caused it?
[right][snapback]111515[/snapback][/right]
[/quote]
First post! :)

Just registered here because, after upgrading to an 8800GTS, I'm getting that same error msg (albeit a different game ... don't laugh ... Pirates! lol). I'm using the latest driver set from nVidia as well as the latest DX from MS. Please tell me I don't have to reinstall Windows. Not a big deal but seriously not in the mood. :(
[quote name='evil' date='Sep 4 2006, 02:35 PM']Did you ever fix your issue? I'm curious as to what caused it?

[snapback]111515[/snapback]




First post! :)



Just registered here because, after upgrading to an 8800GTS, I'm getting that same error msg (albeit a different game ... don't laugh ... Pirates! lol). I'm using the latest driver set from nVidia as well as the latest DX from MS. Please tell me I don't have to reinstall Windows. Not a big deal but seriously not in the mood. :(

#6
Posted 12/12/2006 12:40 AM   
@ gord.

if you are dumb enough to delete all the dx files.. you deserve to have issues.

@ lupine.
open the Pirate properties and set it to run in Win2k compatibility mode.
@ gord.



if you are dumb enough to delete all the dx files.. you deserve to have issues.



@ lupine.

open the Pirate properties and set it to run in Win2k compatibility mode.

#7
Posted 12/12/2006 05:47 AM   
First of all,
DO NOT ATTEMPT TO ROLLBACK OR UNINSTALL YOUR DIRECTX.
IT JUST DOESN'T WORK THAT WAY.
Reverting back to previous versions of DirectX, I assure you,
will not solve the problem
but will just mess up your Operating System.

Secondly,
BEFORE RESORTING TO GIVING UP YOUR CURRENT GRAPHIC CARDS
AND BUYING NEW ONES,
try this possible solution first.

THE ONLY REASON WHY THE ERROR MESSAGE
"..Unable to intialize DirectX..."
APPEARS IN WARCRAFT IS THAT
DIRECT3D ACCELERATION IS DISABLED
(even if your graphics card is direct3d-capable)
or IS JUST SIMPLY NOT SUPPORTED BY YOUR GRAPHICS CARD.

To know if it's disabled,
type dxdiag in the run command.
Go to Display tab.
Check DirectDraw and Direct3d acceleration.
Status of these two must be "Enabled" and is clickable.
If it's not, then your Direct3d is indeed disabled,
which prohibits warcraft from running.

SO THE QUESTION NOW IS, HOW DO YOU ENABLE DIRECT3D? Simple.
Just go to Display Properties (from the Control Panel),
then click Settings tab,
and then click Advanced button.
Look for the tab where "Hardware acceleration" is present
(in most cases, it's in the Troubleshoot tab).
Drag the indicator to Full.
Click Apply and OK.

Just to be safe, restart your PC again.
Run Warcraft.

/yes.gif' class='bbc_emoticon' alt=':yes:' />
First of all,

DO NOT ATTEMPT TO ROLLBACK OR UNINSTALL YOUR DIRECTX.

IT JUST DOESN'T WORK THAT WAY.

Reverting back to previous versions of DirectX, I assure you,

will not solve the problem

but will just mess up your Operating System.



Secondly,

BEFORE RESORTING TO GIVING UP YOUR CURRENT GRAPHIC CARDS

AND BUYING NEW ONES,

try this possible solution first.



THE ONLY REASON WHY THE ERROR MESSAGE

"..Unable to intialize DirectX..."

APPEARS IN WARCRAFT IS THAT

DIRECT3D ACCELERATION IS DISABLED

(even if your graphics card is direct3d-capable)

or IS JUST SIMPLY NOT SUPPORTED BY YOUR GRAPHICS CARD.



To know if it's disabled,

type dxdiag in the run command.

Go to Display tab.

Check DirectDraw and Direct3d acceleration.

Status of these two must be "Enabled" and is clickable.

If it's not, then your Direct3d is indeed disabled,

which prohibits warcraft from running.



SO THE QUESTION NOW IS, HOW DO YOU ENABLE DIRECT3D? Simple.

Just go to Display Properties (from the Control Panel),

then click Settings tab,

and then click Advanced button.

Look for the tab where "Hardware acceleration" is present

(in most cases, it's in the Troubleshoot tab).

Drag the indicator to Full.

Click Apply and OK.



Just to be safe, restart your PC again.

Run Warcraft.



/yes.gif' class='bbc_emoticon' alt=':yes:' />

#8
Posted 12/17/2007 06:50 PM   
Yeah, except that the hardware acceleration is already to the max and I doubt my 6600GT is not Direct3D enabled.

It was funny though I slided HA to the left a bit and then returned it to the right and hit apply and after a while my computer restarted.

Then Warcraft ran fine again...
Yeah, except that the hardware acceleration is already to the max and I doubt my 6600GT is not Direct3D enabled.



It was funny though I slided HA to the left a bit and then returned it to the right and hit apply and after a while my computer restarted.



Then Warcraft ran fine again...

#9
Posted 12/31/2007 08:46 PM   
[quote]To know if it's disabled,
type dxdiag in the run command.
Go to Display tab.
Check DirectDraw and Direct3d acceleration.
Status of these two must be "Enabled" and is clickable.
If it's not, then your Direct3d is indeed disabled,
which prohibits warcraft from running.[/quote]

ok what if it says Enabled but is not clickable? ie there is no button to click? cause i have the very same problem under vista32 , gf8600GT , 167.45 drivers on an asus g1s laptop.

thanks!
To know if it's disabled,

type dxdiag in the run command.

Go to Display tab.

Check DirectDraw and Direct3d acceleration.

Status of these two must be "Enabled" and is clickable.

If it's not, then your Direct3d is indeed disabled,

which prohibits warcraft from running.




ok what if it says Enabled but is not clickable? ie there is no button to click? cause i have the very same problem under vista32 , gf8600GT , 167.45 drivers on an asus g1s laptop.



thanks!

#10
Posted 01/28/2008 09:23 PM   
[quote name='emzic' date='Jan 28 2008, 04:23 PM']ok what if it says Enabled but is not clickable? ie there is no button to click? cause i have the very same problem under vista32 , gf8600GT , 167.45 drivers on an asus g1s laptop.

thanks!
[right][snapback]316359[/snapback][/right]
[/quote]

Thats what I was wondering, there is no button next to DirectDraw and Direct3D in dxdiag and the option to adjust the graphics acceleration is greyed out with the following text:

"Your current display driver does not allow changes to be made to hardware acceleration settings."

Im running vista 32bit with directx 10 obviously. Warcraft III wont run, it installs fine, but gives a directx error about not having directx 8.1, as I said earlier I have DirectX 10when starting, then immediatly says no disc in drive, although it is.

I have installed it under compatability modes Win 98/me and WinXP SP2, I have run them with that as well and run as admin checked. And I still get the same problem, I have tried omega video drivers, same problem.

My computer specs are:
Windows Vista 32bit, 4GB RAM, Intel C2D 3.0Ghz, Asus Maximus Formula MB, Seagate 250GB 7200RPM HD, Corsair 520W PSU, MSI 8800GTS 512MB OC.

I appreciate any help, I feel I have exhausted the obvious ideas and need some help.

Thanks
[quote name='emzic' date='Jan 28 2008, 04:23 PM']ok what if it says Enabled but is not clickable? ie there is no button to click? cause i have the very same problem under vista32 , gf8600GT , 167.45 drivers on an asus g1s laptop.



thanks!

[snapback]316359[/snapback]






Thats what I was wondering, there is no button next to DirectDraw and Direct3D in dxdiag and the option to adjust the graphics acceleration is greyed out with the following text:



"Your current display driver does not allow changes to be made to hardware acceleration settings."



Im running vista 32bit with directx 10 obviously. Warcraft III wont run, it installs fine, but gives a directx error about not having directx 8.1, as I said earlier I have DirectX 10when starting, then immediatly says no disc in drive, although it is.



I have installed it under compatability modes Win 98/me and WinXP SP2, I have run them with that as well and run as admin checked. And I still get the same problem, I have tried omega video drivers, same problem.



My computer specs are:

Windows Vista 32bit, 4GB RAM, Intel C2D 3.0Ghz, Asus Maximus Formula MB, Seagate 250GB 7200RPM HD, Corsair 520W PSU, MSI 8800GTS 512MB OC.



I appreciate any help, I feel I have exhausted the obvious ideas and need some help.



Thanks

#11
Posted 05/12/2008 03:15 AM   
Vista users (afaik) should install the latest direct x 9 then reinstall direct x 10. (I repeat, reinstall direct x 10 after installing direct x 9)

Windows XP users, the latest is Direct X March 2008 Redistributable.



If the above does not help then either A) you need to install video card drivers from the MANUFACTURERS SITE and not Microsoft site. B ) your hardware/drivers simply lack support for direct x 8.1... i know intels integrated graphics lack some direct draw support under vista.
Vista users (afaik) should install the latest direct x 9 then reinstall direct x 10. (I repeat, reinstall direct x 10 after installing direct x 9)



Windows XP users, the latest is Direct X March 2008 Redistributable.







If the above does not help then either A) you need to install video card drivers from the MANUFACTURERS SITE and not Microsoft site. B ) your hardware/drivers simply lack support for direct x 8.1... i know intels integrated graphics lack some direct draw support under vista.

Custom built PC | Intel Core i7 920 @ 2.66GHZ | ASUS P6T Motherboard | 6GB DDR3 1600 RAM | 2x 500GB SATA2 HDD's | Auzentech Forte S/C | Gainward Geforce GTX 560Ti "Phantom 2" 2048MB | Windows 7 Home Premium: Service Pack 1 - x64 | Thermaltake 750watt Toughpower Power Supply | Thermaltake Armor+ MX case.

#12
Posted 05/18/2008 10:55 AM   
[quote]Windows XP users, the latest is Direct X March 2008 Redistributable.[/quote]

the latest is DirectX April 2008 Redist
Windows XP users, the latest is Direct X March 2008 Redistributable.




the latest is DirectX April 2008 Redist

#13
Posted 05/23/2008 10:08 AM   
[quote name='bigirb2006' date='May 23 2008, 08:08 PM']the latest is DirectX April 2008 Redist
[right][snapback]381698[/snapback][/right]
[/quote]
:o (/me goes and updates)
[quote name='bigirb2006' date='May 23 2008, 08:08 PM']the latest is DirectX April 2008 Redist

[snapback]381698[/snapback]




:o (/me goes and updates)

Custom built PC | Intel Core i7 920 @ 2.66GHZ | ASUS P6T Motherboard | 6GB DDR3 1600 RAM | 2x 500GB SATA2 HDD's | Auzentech Forte S/C | Gainward Geforce GTX 560Ti "Phantom 2" 2048MB | Windows 7 Home Premium: Service Pack 1 - x64 | Thermaltake 750watt Toughpower Power Supply | Thermaltake Armor+ MX case.

#14
Posted 05/25/2008 08:47 AM   
oh my bad, i meant May. LOL
oh my bad, i meant May. LOL

#15
Posted 05/25/2008 03:57 PM   
  1 / 2    
Scroll To Top