Blocky shadows and jagged edges
Hello, I recently bought a 6800 GS and I'm having some problems, shadows are not displaying smootly and they are blocky and also I have jagged edges in some games.

I get this when I already have set the image quality on highest and AA8xS and AF16x.

Here is a cropped image from farcry:
[img]http://atitool.imagine-x.com/screenshots/otherscreenies/FarCry0000.jpg[/img]
Also when Jack stands on the beach his shadow is NOT smooth.


With the game GTA San Andreas (everything on highest settings) the colors on the cars and the sky look low quality as 16 bit colors(but it should be 32 bit). In buildings, the floor reflections and shadows are NOT smooth and have jagged edges.
And I already have all settings at highest possible.

NFSMW, this game stutters(hangs) every 10-15 seconds, i can play it, but it does not run smooth, low or high graphic settings was the same stuttering effect.


With all situations I've tried many things, low to high quality settings, different drivers, but nothing of that solved my problems.


I would like to run NFSMW smoothly and I would like to see smooth shadows as it should be.

Thanks for help and solutions.
Hello, I recently bought a 6800 GS and I'm having some problems, shadows are not displaying smootly and they are blocky and also I have jagged edges in some games.



I get this when I already have set the image quality on highest and AA8xS and AF16x.



Here is a cropped image from farcry:

Image

Also when Jack stands on the beach his shadow is NOT smooth.





With the game GTA San Andreas (everything on highest settings) the colors on the cars and the sky look low quality as 16 bit colors(but it should be 32 bit). In buildings, the floor reflections and shadows are NOT smooth and have jagged edges.

And I already have all settings at highest possible.



NFSMW, this game stutters(hangs) every 10-15 seconds, i can play it, but it does not run smooth, low or high graphic settings was the same stuttering effect.





With all situations I've tried many things, low to high quality settings, different drivers, but nothing of that solved my problems.





I would like to run NFSMW smoothly and I would like to see smooth shadows as it should be.



Thanks for help and solutions.

#1
Posted 04/03/2006 11:04 AM   
Does anyone else have those problems?
Does anyone know a way to get smooth images and smooth shadows, I want to get rid of those jagged edges and blocky shadows, or is this just the image quality of Nvidia?

Do I have to buy an ATI card again if I want quality images?
I assume that Nvidia also can display smooth images and smooth shadows right?
Does anyone else have those problems?

Does anyone know a way to get smooth images and smooth shadows, I want to get rid of those jagged edges and blocky shadows, or is this just the image quality of Nvidia?



Do I have to buy an ATI card again if I want quality images?

I assume that Nvidia also can display smooth images and smooth shadows right?

#2
Posted 04/04/2006 03:01 AM   
Hmm... well, I have experienced some of your problems before on games like NFSMW. Just some theory and advice. I may be wrong but well, I'm just trying to help.

I assume that your card is AGP. Just some theory for most AGP card problems.

Well, AGP slots tends to have problem with next generation cards especially, the 6600 series and above. AGP, as most know is running on parallel mode. Parallel mode had this bad advantage which is there are 8 wires transfering data and in high speed transport, like the case of your graphics card, data will be corrupted since the signals on one of the wire will interfere with the nearby wires and thus generate data corruption. What is happening is that, corrupted data get sent to card, the card process corrupted data and thus output what you see. This will always happen when data are transfer quickly on parrallel mode.

AGP cards in particular, they access your main memory, bypassing the processor. This high speed access can only be done if you enable Write Combine. This same advice, I have given to the rest. Disable Write Combine.

To disable it, go to display properties, click on settings, then click advanced button and go to troubleshoot. There's this write combine checkbox. Uncheck it and apply. Restart you pc and see how did it goes.

And I hope this particular post can serve as also a help for those who are experiencing game stutters, graphics corruption even though they didn't have overheating problem, or did overclocking or low power when they are using AGP cards.

And I know, many like to have the settings on the extreme. I am like that too. Good graphics feels good. But well, don't push your card too far otherwise, you will also have problems. So, you might want to reduce your AF and AA a little bit.

Hope you have a nice day. :D
Hmm... well, I have experienced some of your problems before on games like NFSMW. Just some theory and advice. I may be wrong but well, I'm just trying to help.



I assume that your card is AGP. Just some theory for most AGP card problems.



Well, AGP slots tends to have problem with next generation cards especially, the 6600 series and above. AGP, as most know is running on parallel mode. Parallel mode had this bad advantage which is there are 8 wires transfering data and in high speed transport, like the case of your graphics card, data will be corrupted since the signals on one of the wire will interfere with the nearby wires and thus generate data corruption. What is happening is that, corrupted data get sent to card, the card process corrupted data and thus output what you see. This will always happen when data are transfer quickly on parrallel mode.



AGP cards in particular, they access your main memory, bypassing the processor. This high speed access can only be done if you enable Write Combine. This same advice, I have given to the rest. Disable Write Combine.



To disable it, go to display properties, click on settings, then click advanced button and go to troubleshoot. There's this write combine checkbox. Uncheck it and apply. Restart you pc and see how did it goes.



And I hope this particular post can serve as also a help for those who are experiencing game stutters, graphics corruption even though they didn't have overheating problem, or did overclocking or low power when they are using AGP cards.



And I know, many like to have the settings on the extreme. I am like that too. Good graphics feels good. But well, don't push your card too far otherwise, you will also have problems. So, you might want to reduce your AF and AA a little bit.



Hope you have a nice day. :D

My New Rig/Current Rig



<span style='color:blue'>

Core i7 2600 with Antec H620 Liquid Cooler

Asus P8P87 (Normal) B2 stepping.

4x4GB G.Skill Ripjawz 1600Mhz

Gigabyte GTX 580 1.5GB

2x Western Digital Black 640 (RAID 0)

1x Western Digital Black 500GB (backup)

Pioneer DVD-Writer Drive.

Windows 7 64bit Home Premium

Antec 850W Quattro TruePower

CoolerMaster HAF 932



</span>



I don't run over clocked system. I play by stock clock and I'm proud of it.

#3
Posted 04/04/2006 08:30 AM   
[quote name='brandon' date='Apr 4 2006, 03:30 PM']Hmm... well, I have experienced some of your problems before on games like NFSMW. Just some theory and advice. I may be wrong but well, I'm just trying to help.

I assume that your card is AGP. Just some theory for most AGP card problems.[/quote]


Hi Brandon, I have an XFX 6800 GS XXX PCI-E , today I just installed a new beta driver
84.25, and the stuttering is reduced in NFSMW (but still there).

Until sofar I run every game on highest settings, including NFSMW, since that runs even smoother than on lower quality, I'm playing NFSMW at AA8xS and AF16x.
And with rivatuner I set the mipmap LOD on -3 for sharper textures.

But the shadows of farCry are still the same with the new driver, blocky.



My 3D Mark06 basic edition benchmark results:

XFX 6800GS XXX(not overclocked) scores 2765 3d marks.
SM 2.0 score 1261
HDR/SM3.0 score 1084
CPU score 1026

(@ 1280x1024 resolution)

[url="http://www.download.com/3DMark06-bas...-10492453.html"]http://www.download.com/3DMark06-bas...-10492453.html[/url]
__________________
Pentium 4 630 - 1GB corsair DDR2 667 - Seagate Barracuda 7200.7 SATA 160 - LG GSA-4165B 16x dual layer dvd RW-
XFX 6800GS XXX - Zalman Fatal 1TY FS-V7 - 17" Acer 8MS ultrafast LCD display- Logitech MX Laser mouse - Marvell Yukon PCI Gigabit Ethernet Controller - Realtek/Creative HD audio 8.1
[quote name='brandon' date='Apr 4 2006, 03:30 PM']Hmm... well, I have experienced some of your problems before on games like NFSMW. Just some theory and advice. I may be wrong but well, I'm just trying to help.



I assume that your card is AGP. Just some theory for most AGP card problems.





Hi Brandon, I have an XFX 6800 GS XXX PCI-E , today I just installed a new beta driver

84.25, and the stuttering is reduced in NFSMW (but still there).



Until sofar I run every game on highest settings, including NFSMW, since that runs even smoother than on lower quality, I'm playing NFSMW at AA8xS and AF16x.

And with rivatuner I set the mipmap LOD on -3 for sharper textures.



But the shadows of farCry are still the same with the new driver, blocky.







My 3D Mark06 basic edition benchmark results:



XFX 6800GS XXX(not overclocked) scores 2765 3d marks.

SM 2.0 score 1261

HDR/SM3.0 score 1084

CPU score 1026



(@ 1280x1024 resolution)



http://www.download.com/3DMark06-bas...-10492453.html

__________________

Pentium 4 630 - 1GB corsair DDR2 667 - Seagate Barracuda 7200.7 SATA 160 - LG GSA-4165B 16x dual layer dvd RW-

XFX 6800GS XXX - Zalman Fatal 1TY FS-V7 - 17" Acer 8MS ultrafast LCD display- Logitech MX Laser mouse - Marvell Yukon PCI Gigabit Ethernet Controller - Realtek/Creative HD audio 8.1

#4
Posted 04/04/2006 05:52 PM   
Hmm...well, maybe you can try disabling the write combine and see how it works?
Hmm...well, maybe you can try disabling the write combine and see how it works?

My New Rig/Current Rig



<span style='color:blue'>

Core i7 2600 with Antec H620 Liquid Cooler

Asus P8P87 (Normal) B2 stepping.

4x4GB G.Skill Ripjawz 1600Mhz

Gigabyte GTX 580 1.5GB

2x Western Digital Black 640 (RAID 0)

1x Western Digital Black 500GB (backup)

Pioneer DVD-Writer Drive.

Windows 7 64bit Home Premium

Antec 850W Quattro TruePower

CoolerMaster HAF 932



</span>



I don't run over clocked system. I play by stock clock and I'm proud of it.

#5
Posted 04/05/2006 03:49 AM   
I've tried with write combine disabled and I tell you that there was still not a 100% smooth gameplay. Also it seemed if the framerate went down when write combined disabled..

I probably have to wait for a better driver .

Thanks for your help.
I've tried with write combine disabled and I tell you that there was still not a 100% smooth gameplay. Also it seemed if the framerate went down when write combined disabled..



I probably have to wait for a better driver .



Thanks for your help.

#6
Posted 04/05/2006 09:32 AM   
I had exactly the same problems, with nfsmw skipping all the time, I cant say about far cry blocky shadows, as its fine to me. I only have a 6600gt on agp, and both games are playable on my low res monitor 17inch, at medium to max settings.

About nfsmw skipping, I had this problem so much, so I upgraded to 1 Gig ram, instead of the 512 I had. since then nfsmw plays a heck of alot smoother. BF2 plays like a dream with more ram too, but these two games are the only two ever, that ive seen more improvement in system ram than gpu.
I had exactly the same problems, with nfsmw skipping all the time, I cant say about far cry blocky shadows, as its fine to me. I only have a 6600gt on agp, and both games are playable on my low res monitor 17inch, at medium to max settings.



About nfsmw skipping, I had this problem so much, so I upgraded to 1 Gig ram, instead of the 512 I had. since then nfsmw plays a heck of alot smoother. BF2 plays like a dream with more ram too, but these two games are the only two ever, that ive seen more improvement in system ram than gpu.

#7
Posted 04/18/2006 01:17 AM   
Here's a similar problem with oblivion.
no AA (needed to disable for taking screenshots),
no AF (option not enabled in oblivion),

[attachment=1683:attachment]
[attachment=1684:attachment]

i got geforce 7800GT, with latest drivers.
anyone have any idea how to solve it?
Here's a similar problem with oblivion.

no AA (needed to disable for taking screenshots),

no AF (option not enabled in oblivion),



[attachment=1683:attachment]

[attachment=1684:attachment]



i got geforce 7800GT, with latest drivers.

anyone have any idea how to solve it?

#8
Posted 05/13/2006 10:31 AM   
Hi,

Have the same problem here and with lot of games, I was search on internet to find a solution and is probably a problem with the Shadow Map resolution that for some reason is on the low seting (256 x 256 pixels instead 1024 x 1024) unfortunately most of the games dont have the option to choose the shadow map size and I belive that this is a driver problem that for some reason fixed all the res at low, some games dont apear it (crysis, fallout 3, ..) cause they use other shadow system.

I look at ATI foruns too and found that ATI cards also have other problems with shadows so probably this new drivers for both cards are a crap.

One interest thing I noticed is when playing Dead Space depending on the place and camera angle your shadow is perfect with no jagged edges but other situations it apears a 8 bits shadow.

Unfortunately tha AA dont affect shadows, is anoying but probalby the next games will stop using Shadow Map and start using Shadow Volume then our problems are solved.

I tested with lots of old driver and no one fix it =(

Spec: Asus P5N-SLI, C2D E4500 2.2 Ghz, DDR2 667 Mhz 2x 1 Gb, GTX 260 192SP OC, SoundBlaster Audgy 7.1, XP 32bits SP3, Forceware 181.22 nvida driver.
Hi,



Have the same problem here and with lot of games, I was search on internet to find a solution and is probably a problem with the Shadow Map resolution that for some reason is on the low seting (256 x 256 pixels instead 1024 x 1024) unfortunately most of the games dont have the option to choose the shadow map size and I belive that this is a driver problem that for some reason fixed all the res at low, some games dont apear it (crysis, fallout 3, ..) cause they use other shadow system.



I look at ATI foruns too and found that ATI cards also have other problems with shadows so probably this new drivers for both cards are a crap.



One interest thing I noticed is when playing Dead Space depending on the place and camera angle your shadow is perfect with no jagged edges but other situations it apears a 8 bits shadow.



Unfortunately tha AA dont affect shadows, is anoying but probalby the next games will stop using Shadow Map and start using Shadow Volume then our problems are solved.



I tested with lots of old driver and no one fix it =(



Spec: Asus P5N-SLI, C2D E4500 2.2 Ghz, DDR2 667 Mhz 2x 1 Gb, GTX 260 192SP OC, SoundBlaster Audgy 7.1, XP 32bits SP3, Forceware 181.22 nvida driver.

MB: Intel DH55HC

CPU: Intel i7 860, 3.2 GHz + Akasa Nero 2 + Viper Fan

RAM: Kingstone 2x 2 Gb, DDR 3, 1333 MHz

PSU: Seventeam V-Force Series 850W

GPU: Evga GTX 580 772/1544/2004(4008)

SPU: Creative Sound Blaster X-Fi XtremeGamer

HD: Samsung 1 Tb, 32 Mb, SaTA II

DVD: LG Blue Ray

CASE: Aerocool BX-500, 7 fans

GPAD: Xbox 360 Controller for Windows

MOUSE: CM Sentinel Advance

KEY: Logitech G15

MON: LG Flatron E2350, 1920 x 1080 res

SO: Windows 7 Home Premium 64 bits

DRIV: Forceware 285.62

#9
Posted 02/06/2009 04:32 PM   
Did anyone ever figure this out at all? This problem has plagued my 8800GT from the day I got it. From windows XP, to vista 64bit, to 7 64 bit. I recently tried Tomb Raider Underworld, Tomb Raider Legend (1.2 and 1.0), and Crysis and they all showed issues with shadows like this. I would really like to get this fixed, because as it stands, I can't take any usable screenshots - they all have jagged shadows under the eyes and hair, and by the nose, and blocky shadows on the ground. And I can't take a video, because these shadows are always jumping around and look horrible on film. It makes the game much less cinematic.

Please help if you can, I can test a few more games if need be. I seem to remember Knights of the Old Republic having this problem as well, updates didn't help.

I would also like to know if this problem is fixed on newer cards. I need to upgrade soon, and I don't want to run in to the same problem again.

Any advice?
Thanks.
Did anyone ever figure this out at all? This problem has plagued my 8800GT from the day I got it. From windows XP, to vista 64bit, to 7 64 bit. I recently tried Tomb Raider Underworld, Tomb Raider Legend (1.2 and 1.0), and Crysis and they all showed issues with shadows like this. I would really like to get this fixed, because as it stands, I can't take any usable screenshots - they all have jagged shadows under the eyes and hair, and by the nose, and blocky shadows on the ground. And I can't take a video, because these shadows are always jumping around and look horrible on film. It makes the game much less cinematic.



Please help if you can, I can test a few more games if need be. I seem to remember Knights of the Old Republic having this problem as well, updates didn't help.



I would also like to know if this problem is fixed on newer cards. I need to upgrade soon, and I don't want to run in to the same problem again.



Any advice?

Thanks.

#10
Posted 05/31/2009 04:39 AM   
I just tried Tomb Raider Underworld, and the jagged shadows really made me want to get this finally fixed. I have a GTX 280 Gainward. Some people say that reducing shader clocks with RivaTuner or EVGA Precision may help. I tried that, but even when I reduced them as low as they could go, it didn't help. I'll try playing around with NVIDIA Control Panel settings too.

Has anyone had any success by reducing shader clocks?
I just tried Tomb Raider Underworld, and the jagged shadows really made me want to get this finally fixed. I have a GTX 280 Gainward. Some people say that reducing shader clocks with RivaTuner or EVGA Precision may help. I tried that, but even when I reduced them as low as they could go, it didn't help. I'll try playing around with NVIDIA Control Panel settings too.



Has anyone had any success by reducing shader clocks?

#11
Posted 01/27/2010 06:59 PM   
I have the same problem with my Gainward 9600GT. Anti-Aliasing is working fine, but the shadow map size seems to be stuck at 256x256 (or even lower), and there's no option in the driver to change it. It seems to be a problem in all games, including "Assassins Creed", "Heroes Of Might And Magic 5", "Battle for Middle Earth" and several others, in fact it seems like a problem in all games (all games are set to highest details, so this might be hardware enforced). It's a little annoying if you have a High-Res-World and the shadows are all blocky. :(

System:
Intel Core2Duo
Gainward 9600GT (1024MB) with 196.21
Windows XP 32-Bit with DirectX 9.0C
I have the same problem with my Gainward 9600GT. Anti-Aliasing is working fine, but the shadow map size seems to be stuck at 256x256 (or even lower), and there's no option in the driver to change it. It seems to be a problem in all games, including "Assassins Creed", "Heroes Of Might And Magic 5", "Battle for Middle Earth" and several others, in fact it seems like a problem in all games (all games are set to highest details, so this might be hardware enforced). It's a little annoying if you have a High-Res-World and the shadows are all blocky. :(



System:

Intel Core2Duo

Gainward 9600GT (1024MB) with 196.21

Windows XP 32-Bit with DirectX 9.0C

#12
Posted 01/31/2010 11:20 PM   
Scroll To Top