Windows Spring Creators Update (RS4) - No windowed G-Sync
  1 / 3    
Hello there, Upgraded my Windows 10 installation using the Windows Insiders slow ring. Everything seems to work fine, but even after clean re-installing the latest drivers (397.31), I cannot get windowed G-Sync to work. It works fine in fullscreen mode. (And yes, the option is enabled in Nvidia Control Panel - I've done this dance before! :) ) Interesting: Windowed G-Sync works [b]just after[/b] a clean driver installation. Rebooting after the driver install, and it's broken again. [b]My System:[/b] Win10 17134.1 (aka Redstone 4, aka Spring Creators Update), GTX1070 ti, 16 Gb RAM, single monitor setup. Applications to test this bug with are basicly any game with a windowed mode ([i]Overwatch, Rocket League[/i], ...) or any game without true exclusive fullscreen ([i]The Evil Within 2, Rust[/i], ...) [b]Tried, but did not solve the issue:[/b] [list] [.]Disable full screen optimizations on a per-exe basis[/.] [.]Disable fast boot (which was re-enabled by the Windows upgrade. Oh, Microsoft, you fox!)[/.] [.]Disable game bar / game mode[/.] [.]Installing older driver versions (every time with a DDU wipe in between, of course)[/.] [.]Disabling and re-enabling G-Sync in NVCP[/.] [.]Unplugging and replugging monitor[/.] [/list] [b]Ugly fix (found on 03/04/2018):[/b] [list] [.]Close all GPU applications (and pretty much any other app you don't want crashing)[/.] [.]Open task manager and kill "Windows Desktop Manager". Yep, acknowledge the warning.[/.] [.]WDM will restart itself immediately. Your screen might go black for a second while it recovers.[/.] [.] Windowed G-Sync working again, until next reboot.[/.] [/list] You can automate that process by saving [code]taskkill.exe /F /IM dwm.exe[/code] as a .bat file and running that as an administrator.
Hello there,

Upgraded my Windows 10 installation using the Windows Insiders slow ring. Everything seems to work fine, but even after clean re-installing the latest drivers (397.31), I cannot get windowed G-Sync to work. It works fine in fullscreen mode. (And yes, the option is enabled in Nvidia Control Panel - I've done this dance before! :) )

Interesting: Windowed G-Sync works just after a clean driver installation. Rebooting after the driver install, and it's broken again.

My System: Win10 17134.1 (aka Redstone 4, aka Spring Creators Update), GTX1070 ti, 16 Gb RAM, single monitor setup. Applications to test this bug with are basicly any game with a windowed mode (Overwatch, Rocket League, ...) or any game without true exclusive fullscreen (The Evil Within 2, Rust, ...)

Tried, but did not solve the issue:
  • Disable full screen optimizations on a per-exe basis
  • Disable fast boot (which was re-enabled by the Windows upgrade. Oh, Microsoft, you fox!)
  • Disable game bar / game mode
  • Installing older driver versions (every time with a DDU wipe in between, of course)
  • Disabling and re-enabling G-Sync in NVCP
  • Unplugging and replugging monitor

Ugly fix (found on 03/04/2018):
  • Close all GPU applications (and pretty much any other app you don't want crashing)
  • Open task manager and kill "Windows Desktop Manager". Yep, acknowledge the warning.
  • WDM will restart itself immediately. Your screen might go black for a second while it recovers.
  • Windowed G-Sync working again, until next reboot.

You can automate that process by saving
taskkill.exe /F /IM dwm.exe
as a .bat file and running that as an administrator.

#1
Posted 04/02/2018 10:21 PM   
disable fullscreen optimisation?
disable fullscreen optimisation?



In Memory of Chris "ChrisRay" Arthington, 1982-2010

Specs:
CPU:Intel Xeon x5690 @ 4.2Ghz, Mainboard:Asus Rampage III Extreme, Memory:48GB Corsair Vengeance LP 1600
Video:EVGA Geforce GTX 1080 Founders Edition, NVidia Geforce GTX 1060 Founders Edition
Monitor:ROG PG279Q, BenQ BL2211, Sound:Creative XFI Titanium Fatal1ty Pro
SDD:Crucial MX300 275, Crucial MX300 525, Crucial MX300 1000
HDD:500GB Spinpoint F3, 1TB WD Black, 2TB WD Red, 1TB WD Black
Case:NZXT Phantom 820, PSU:Seasonic X-850, OS:Windows 7 SP1
Cooler: ThermalRight Silver Arrow IB-E Extreme

CPU:Intel Xeon x5670 @ 3.8Gz, Mainboard:Asus Rampage II Gene, Memory:24GB Corsair Vengeance LP 1600
Video:EVGA Geforce GTX 680+ 4GB
Monitor:55" Thorn TV, Sound:Sony Muteki 7.1
SDD:Crucial MX200 250, HDD: 1TB Samsung Spinpoint F3
Case:NZXT Phantom 410, PSU:Corsair 620HX, OS:Windows 10
Cooler: ThermalRight TRUE Spirit 120M BW Rev.A

#2
Posted 04/03/2018 02:48 AM   
[quote="Sora"]disable fullscreen optimisation?[/quote] Makes no difference, unfortunately. Also tried: disabling fast startup, enabling/disabling Game Bar, enabling/disabling Game Mode.
Sora said:disable fullscreen optimisation?

Makes no difference, unfortunately. Also tried: disabling fast startup, enabling/disabling Game Bar, enabling/disabling Game Mode.

#3
Posted 04/03/2018 02:52 AM   
This has been an issue off and on in nvidia drivers for a long time now. One will work the next will have gsync and sync issues in boarderless windows, fullscreen and windowed modes. Also we have the long standing windows/nvidia issues with stuttering and sync issues. I can't even play any game without vsync on as they have heavy hitching due to these bugs. Vsync is the only thing that makes things somewhat smooth aprt from the random hitches on any monitor above 60hz.
This has been an issue off and on in nvidia drivers for a long time now. One will work the next will have gsync and sync issues in boarderless windows, fullscreen and windowed modes. Also we have the long standing windows/nvidia issues with stuttering and sync issues. I can't even play any game without vsync on as they have heavy hitching due to these bugs. Vsync is the only thing that makes things somewhat smooth aprt from the random hitches on any monitor above 60hz.

#4
Posted 04/03/2018 11:42 AM   
Update: I found out that borderless gsync works just after installing the driver. It breaks after the first reboot. :s
Update: I found out that borderless gsync works just after installing the driver. It breaks after the first reboot. :s

#5
Posted 04/03/2018 01:30 PM   
This is not surprising, unfortunately. Microsoft has broken Windowed Gsync with every iteration of the Creators Update and they seem not to care as they keep doing it. It takes many months to fix it each time it happens too.
This is not surprising, unfortunately. Microsoft has broken Windowed Gsync with every iteration of the Creators Update and they seem not to care as they keep doing it. It takes many months to fix it each time it happens too.

System specs:
i7 5820K@4.1GHz
Noctua NH-D15S CPU Cooler
Gigabyte X99 SOC Champion Bios F22
32GB Kingston HyperX DDR4 2133MHz(4x8GB)
Palit Geforce GTX 1080 Gamerock Premium
Corsair RMi 1000W
Dell S2716DG Gsync 2560x1440 144Hz
Windows 10 Home 64Bit
Phanteks Enthoo Evolv ATX Case

#6
Posted 04/03/2018 03:28 PM   
I found a (kind of ugly) way to fix the gsync windowed not working issue: [b]restart DWM[/b]. [list] [.]Close all GPU applications (and pretty much any other app you don't want crashing)[/.] [.] Open task manager and kill "Windows Desktop Manager". Yep, acknowledge the warning.[/.] [.] Windowed gsync working again, until next reboot.[/.] [/list] My suspicion is that this somehow reloads all the driver stuff necessary to make it work. I got this idea from observing what happens during a driver install.
I found a (kind of ugly) way to fix the gsync windowed not working issue: restart DWM.

  • Close all GPU applications (and pretty much any other app you don't want crashing)
  • Open task manager and kill "Windows Desktop Manager". Yep, acknowledge the warning.
  • Windowed gsync working again, until next reboot.

My suspicion is that this somehow reloads all the driver stuff necessary to make it work. I got this idea from observing what happens during a driver install.

#7
Posted 04/03/2018 06:47 PM   
Gsync has to hook into dwm to make bordeless windowed gsync works, so when it cant do that just does't work i guess killing it forcing dwm to restart making it function again till reboot.
Gsync has to hook into dwm to make bordeless windowed gsync works, so when it cant do that just does't work i guess killing it forcing dwm to restart making it function again till reboot.

#8
Posted 04/03/2018 10:42 PM   
this another issue resolved by disabling fast startup?
this another issue resolved by disabling fast startup?



In Memory of Chris "ChrisRay" Arthington, 1982-2010

Specs:
CPU:Intel Xeon x5690 @ 4.2Ghz, Mainboard:Asus Rampage III Extreme, Memory:48GB Corsair Vengeance LP 1600
Video:EVGA Geforce GTX 1080 Founders Edition, NVidia Geforce GTX 1060 Founders Edition
Monitor:ROG PG279Q, BenQ BL2211, Sound:Creative XFI Titanium Fatal1ty Pro
SDD:Crucial MX300 275, Crucial MX300 525, Crucial MX300 1000
HDD:500GB Spinpoint F3, 1TB WD Black, 2TB WD Red, 1TB WD Black
Case:NZXT Phantom 820, PSU:Seasonic X-850, OS:Windows 7 SP1
Cooler: ThermalRight Silver Arrow IB-E Extreme

CPU:Intel Xeon x5670 @ 3.8Gz, Mainboard:Asus Rampage II Gene, Memory:24GB Corsair Vengeance LP 1600
Video:EVGA Geforce GTX 680+ 4GB
Monitor:55" Thorn TV, Sound:Sony Muteki 7.1
SDD:Crucial MX200 250, HDD: 1TB Samsung Spinpoint F3
Case:NZXT Phantom 410, PSU:Corsair 620HX, OS:Windows 10
Cooler: ThermalRight TRUE Spirit 120M BW Rev.A

#9
Posted 04/03/2018 11:52 PM   
[quote="Sora"]this another issue resolved by disabling fast startup?[/quote] Nope, disabling fast startup (which indeed was re-enabled after the SCU update) did not make any difference.
Sora said:this another issue resolved by disabling fast startup?

Nope, disabling fast startup (which indeed was re-enabled after the SCU update) did not make any difference.

#10
Posted 04/03/2018 11:55 PM   
There, I updated the first post with all my findings and the possible fix, for other people stumbling upon this.
There, I updated the first post with all my findings and the possible fix, for other people stumbling upon this.

#11
Posted 04/04/2018 07:16 AM   
Thanks for sharing and making your results easy to discover.
Thanks for sharing and making your results easy to discover.

Custom built PC | Intel Core i7 920 @ 3.60GHZ | ASUS P6T Motherboard (1408 BIOS) | 24GB DDR3 1066MHZ RAM | Gigabyte 760 4GB OC1 Windforce x3 | Windows 10 Pro x64 v1803 | Corsair 760AX Platinum PSU | Fractal Design Define R5 computer case | Samsung P2350

#12
Posted 04/04/2018 09:29 AM   
Be nice if Nvidia could fix this before redstone 4 updates hits windows update oficially since it will be out soon.
Be nice if Nvidia could fix this before redstone 4 updates hits windows update oficially since it will be out soon.

#13
Posted 04/04/2018 12:21 PM   
I removed the note about restart64.exe, which was suggested [url=https://forums.blurbusters.com/viewtopic.php?f=5&t=4010]here[/url], but seems to do more bad then good for me.
I removed the note about restart64.exe, which was suggested here, but seems to do more bad then good for me.

#14
Posted 04/04/2018 10:16 PM   
Added a solution which you can save as a .bat file on your desktop to automate the process.
Added a solution which you can save as a .bat file on your desktop to automate the process.

#15
Posted 04/05/2018 04:40 AM   
  1 / 3    
Scroll To Top