G-Sync issue strikes again
Hello. I have searched far and wide and done many things to try and fix this issue I have been having., I have a Gsync monitor, the Acer Predator XB241h. Its currently being ran with display port. I have a built in refresh rate counter that comes with the screen. Usually when Gsync is on you can see it fluctuating often with my fps as it should be doing. When I shut down and start up my comp it seems to just be hit or miss (usually miss) when it comes to the monitor being active. Ill fire up a game and the refresh rate isn't doing anything. This tells my g-sync isn't working. I've compared it to a few other games with built in FPS counters and I'm def not getting a solid 144 fps. Anyone have any tips? I've booted safe mode and DDU/reinstall fresh drivers, I've done all the windows 10 superstitions, I've even reinstalled my monitor driver and reverted back to an earlier windows 10 date, and done it all again, but still I have this problem. The NVidia control panel G-Sync setup only says to make sure my primary display is setup. That's the only option. The 3D settings acknowledge my monitor is G-Sync compatible. I'm at a complete loss here guys. GPU 980ti CPU FX-8370 liquid cooled with some corsair thing I forgot 16 GB ram 2tb Toshiba HD
Hello. I have searched far and wide and done many things to try and fix this issue I have been having., I have a Gsync monitor, the Acer Predator XB241h. Its currently being ran with display port. I have a built in refresh rate counter that comes with the screen. Usually when Gsync is on you can see it fluctuating often with my fps as it should be doing.

When I shut down and start up my comp it seems to just be hit or miss (usually miss) when it comes to the monitor being active. Ill fire up a game and the refresh rate isn't doing anything. This tells my g-sync isn't working. I've compared it to a few other games with built in FPS counters and I'm def not getting a solid 144 fps. Anyone have any tips?

I've booted safe mode and DDU/reinstall fresh drivers, I've done all the windows 10 superstitions, I've even reinstalled my monitor driver and reverted back to an earlier windows 10 date, and done it all again, but still I have this problem.

The NVidia control panel G-Sync setup only says to make sure my primary display is setup. That's the only option. The 3D settings acknowledge my monitor is G-Sync compatible. I'm at a complete loss here guys.

GPU 980ti
CPU FX-8370 liquid cooled with some corsair thing I forgot
16 GB ram
2tb Toshiba HD

#1
Posted 01/13/2018 12:59 AM   
. Try this: Download this [url=http://us.download.nvidia.com/Windows/387.92/387.92-desktop-win10-64bit-international-rs3-whql.exe]387.92[/url] driver Download [url=http://www.wagnardsoft.com/content/display-driver-uninstaller-ddu-v17075-released]DDU[/url] (get the 17.0.7.5 or NEWER) Disable the Windows 10 [url=https://www.tenforums.com/tutorials/48277-enable-disable-driver-updates-windows-update-windows-10-a.html]Driver updating[/url]. Need to apply the .REG file found in Option 2 and REBOOT. Search(runbox) > Msconfig > Boot(tab) > Boot Option> check the SAFE BOOT ... Apply and Reboot. Run DDU [.]Select: NVIDIA Software and drivers[/.] [.]Select: Clean, do not restart[/.] Search(runbox) > Msconfig > Boot(tab) > Boot Option> [color="orange"]Un[/color]check the SAFE BOOT ... Apply and Reboot. Back in normal Windows: Install the NVIDIA 387.92 driver [.]Select: Custom[/.] [.]Uncheck Everything except the GPU driver[/.] [.]Check the CLEAN INSTALL BOX[/.] [.]Finish the Install[/.] Reboot ====================== [quote]I've compared it to a few other games with built in FPS counters and I'm def not getting a solid 144 fps[/quote] But I am pretty sure your FPS will not stay at 144FPS SOLID. .
.

Try this:

Download this 387.92 driver

Download DDU (get the 17.0.7.5 or NEWER)

Disable the Windows 10 Driver updating. Need to apply the .REG file found in Option 2 and REBOOT.

Search(runbox) > Msconfig > Boot(tab) > Boot Option> check the SAFE BOOT ... Apply and Reboot.

Run DDU
  • Select: NVIDIA Software and drivers
  • Select: Clean, do not restart

  • Search(runbox) > Msconfig > Boot(tab) > Boot Option> Uncheck the SAFE BOOT ... Apply and Reboot.


    Back in normal Windows:

    Install the NVIDIA 387.92 driver
  • Select: Custom
  • Uncheck Everything except the GPU driver
  • Check the CLEAN INSTALL BOX
  • Finish the Install
  • Reboot

    ======================

    I've compared it to a few other games with built in FPS counters and I'm def not getting a solid 144 fps


    But I am pretty sure your FPS will not stay at 144FPS SOLID.

    .

    My Opinion is no more important or right than yours. But if your using the LATEST drivers, go back to the prior set.

    Piss Poor tech support blame all issues on drivers and assumes that your an idiot. Find a set that you know worked and see if the problem exists still.

    ""Don't f with it if it ain't broken!""
    Constantly updating drivers is a good way to F'up the whole system.

    If the driver has an issue, don't be a fool, remove it.

    Just because you can, does not mean you should.

    #2
    Posted 01/13/2018 01:52 AM   
    probably using the cheap ass low quality displayport cable acer boxes.
    probably using the cheap ass low quality displayport cable acer boxes.



    In Memory of Chris "ChrisRay" Arthington, 1982-2010

    Specs:
    CPU:Intel Xeon x5690 @ 4.2Ghz, Mainboard:Asus Rampage III Extreme, Memory:48GB Corsair Vengeance LP 1600
    Video:EVGA Geforce GTX 1080 Founders Edition, NVidia Geforce GTX 1060 Founders Edition
    Monitor:ROG PG279Q, BenQ BL2211, Sound:Creative XFI Titanium Fatal1ty Pro
    SDD:Crucial MX300 275, Crucial MX300 525, Crucial MX300 1000
    HDD:500GB Spinpoint F3, 1TB WD Black, 2TB WD Red, 1TB WD Black
    Case:NZXT Phantom 820, PSU:Seasonic X-850, OS:Windows 7 SP1
    Cooler: ThermalRight Silver Arrow IB-E Extreme

    CPU:Intel Xeon x5670 @ 3.8Gz, Mainboard:Asus Rampage II Gene, Memory:24GB Corsair Vengeance LP 1600
    Video:EVGA Geforce GTX 680+ 4GB
    Monitor:55" Thorn TV, Sound:Sony Muteki 7.1
    SDD:Crucial MX200 250, HDD: 1TB Samsung Spinpoint F3
    Case:NZXT Phantom 410, PSU:Corsair 620HX, OS:Windows 10
    Cooler: ThermalRight TRUE Spirit 120M BW Rev.A

    #3
    Posted 01/13/2018 02:48 AM   
    You see Ive done all that already. I don't know what doing it again will do. And that's the point I'm making. I cant put out a constant 144fps so when my monitor is displaying 144hz that means to me the G-Sync isn't working. I'm not using the standard cable but I'm pretty sure that wouldn't prevent my G-sync from working. Also just earlier, in BF1 I took a pause break and was just sitting in the menu and when I came back it stopped.
    You see Ive done all that already. I don't know what doing it again will do.

    And that's the point I'm making. I cant put out a constant 144fps so when my monitor is displaying 144hz that means to me the G-Sync isn't working.

    I'm not using the standard cable but I'm pretty sure that wouldn't prevent my G-sync from working.

    Also just earlier, in BF1 I took a pause break and was just sitting in the menu and when I came back it stopped.

    #4
    Posted 01/13/2018 06:26 AM   
    . [quote="thorgeirn"]You see Ive done all that already. I don't know what doing it again will do.[/quote] Let me make sure this is exactly what you are saying.... You ran DDU. You Installed the DRIVERS I said to - previously. Not some other drivers randomly picked. You followed the STEPS of removing them in SAFE MODE, installing the 387.92 in NORMAL mode. Installing just the GPU driver? If so, make one more change, follow the same steps, only differences leave all driver | parts checked and still click the Clean install box. And you are using the CABLE provided by ACER? If thats a yes to Everything, then Im out of ideas. But I do not give RANDOM drivers. ACER should be providing a High Quality Cable with the Monitor. (not sure why Sora says its Cheap :) ) To my knowledge, Gsync does not prevent the monitor from hitting 144, it is supposed to try and smooth out the FPS when needed. Sweet spot is like 70-120FPS. .
    .

    thorgeirn said:You see Ive done all that already. I don't know what doing it again will do.
    Let me make sure this is exactly what you are saying....

    You ran DDU.

    You Installed the DRIVERS I said to - previously. Not some other drivers randomly picked.

    You followed the STEPS of removing them in SAFE MODE, installing the 387.92 in NORMAL mode. Installing just the GPU driver? If so, make one more change, follow the same steps, only differences leave all driver | parts checked and still click the Clean install box.


    And you are using the CABLE provided by ACER?


    If thats a yes to Everything, then Im out of ideas.


    But I do not give RANDOM drivers.
    ACER should be providing a High Quality Cable with the Monitor. (not sure why Sora says its Cheap :) )


    To my knowledge, Gsync does not prevent the monitor from hitting 144, it is supposed to try and smooth out the FPS when needed.

    Sweet spot is like 70-120FPS.

    .

    My Opinion is no more important or right than yours. But if your using the LATEST drivers, go back to the prior set.

    Piss Poor tech support blame all issues on drivers and assumes that your an idiot. Find a set that you know worked and see if the problem exists still.

    ""Don't f with it if it ain't broken!""
    Constantly updating drivers is a good way to F'up the whole system.

    If the driver has an issue, don't be a fool, remove it.

    Just because you can, does not mean you should.

    #5
    Posted 01/13/2018 03:24 PM   
    Yes I have done exactly as you have said multiple times. Its not hard to to do. Ive done it before you mentioned it. What im noticing is it has a boot problem. When I boot my computer from shutdown Gsync does not start. If I restart my computer it works for a couple of hours then quits. I know it doesnt prevent you from 144fps you just arent understanding what im saying. I KNOW I DONT GET 144 FPS. So when my monitor displays 144hz for its refresh rate instead of matching to my fps, then I know my G Sync isnt working.
    Yes I have done exactly as you have said multiple times. Its not hard to to do. Ive done it before you mentioned it.

    What im noticing is it has a boot problem. When I boot my computer from shutdown Gsync does not start. If I restart my computer it works for a couple of hours then quits.

    I know it doesnt prevent you from 144fps you just arent understanding what im saying.

    I KNOW I DONT GET 144 FPS. So when my monitor displays 144hz for its refresh rate instead of matching to my fps, then I know my G Sync isnt working.

    #6
    Posted 01/20/2018 09:14 PM   
    . Odd. I would think that if it is showing the 144Hz, then the G-Sync would be working as well cause that means the Cable is allowing proper bandwidth. The fact that it works for a bit, then stops, suggest (at least to me) a change it settings | power | Memory Are you [Alt]+[Tab]ing in and out of the game? Is this monitor one of those with OverClocking? Can the OC be disabled? Are you running FireFox in the background? Make sure the DP cable is CLICKED in. Sometimes these ports are to close to the slot edge and prevent the cable from locking. .
    .

    Odd. I would think that if it is showing the 144Hz, then the G-Sync would be working as well cause that means the Cable is allowing proper bandwidth.

    The fact that it works for a bit, then stops, suggest (at least to me) a change it settings | power | Memory


    Are you [Alt]+[Tab]ing in and out of the game?

    Is this monitor one of those with OverClocking? Can the OC be disabled?


    Are you running FireFox in the background?


    Make sure the DP cable is CLICKED in. Sometimes these ports are to close to the slot edge and prevent the cable from locking.

    .

    My Opinion is no more important or right than yours. But if your using the LATEST drivers, go back to the prior set.

    Piss Poor tech support blame all issues on drivers and assumes that your an idiot. Find a set that you know worked and see if the problem exists still.

    ""Don't f with it if it ain't broken!""
    Constantly updating drivers is a good way to F'up the whole system.

    If the driver has an issue, don't be a fool, remove it.

    Just because you can, does not mean you should.

    #7
    Posted 01/20/2018 09:36 PM   
    Scroll To Top