GTX-980 and 4k display problem in UEFI boot mode
Hi all, My system: MB: ASUS X99-A-USB3.1 Video: GeForce GTX-980 (model WindForce 3X GV-N980G1 GAMING-4GD (GDDR5)) Display: LG 31MU97 (displayport) System: Windows 10 x64, latest MB bios, latest drivers, latest video bios. Everything is ok (4096x2160@60 works) when MB boot mode set to legacy (CSM - enabled), but if boot mode changed to UEFI (CSM - disabled) then after boot i have low resolution and very limited resolution set available: Ultra HD, HD, SD: 720p, 1280x720 720p, 1176x664 480p, 720x480 PC: 1152x864 1024x768 800x600 If I switch display off and on - resolution restored to 4096x2160@60, so i am very tired with this problem, i need uefi and native (4k) resolution mode. I think video card GOP driver may have problems detecting display, but how to solve this? Any help is appreciated, Thanks in advance
Hi all,

My system:

MB: ASUS X99-A-USB3.1
Video: GeForce GTX-980 (model WindForce 3X GV-N980G1 GAMING-4GD (GDDR5))
Display: LG 31MU97 (displayport)
System: Windows 10 x64, latest MB bios, latest drivers, latest video bios.

Everything is ok (4096x2160@60 works) when MB boot mode set to legacy (CSM - enabled), but if boot mode changed to UEFI (CSM - disabled) then after boot i have low resolution and very limited resolution set available:

Ultra HD, HD, SD:
720p, 1280x720
720p, 1176x664
480p, 720x480

PC:
1152x864
1024x768
800x600

If I switch display off and on - resolution restored to 4096x2160@60, so i am very tired with this problem, i need uefi and native (4k) resolution mode. I think video card GOP driver may have problems detecting display, but how to solve this?

Any help is appreciated,
Thanks in advance

#1
Posted 11/30/2017 07:12 PM   
Scroll To Top