"There was a problem starting your game. Try Again"
  1 / 2    
Hi my name is Catalin, Geforce Now was working excellent until today, when I wanted to play Just Cause 3 It said "There was a problem starting your game. Try Again", and I tried with other games and same issue. I tought Central Europe servers are full, but I had this issue all day. iMac 27 (late 2013) I5 haswell 3.5 GHz, GT 755M 1 GB, 8 GB of RAM macOS High Sierra 10.13.1 RCS-RDS 300 Mb/s Dej, Cuj, Romania , 405200 Fiber Optic directly to my mac andrei_cat10@yahoo.com GeForce NOW app version 1.4.1.103/po (EU Central)
Hi my name is Catalin,

Geforce Now was working excellent until today, when I wanted to play Just Cause 3 It said "There was a problem starting your game. Try Again", and I tried with other games and same issue. I tought Central Europe servers are full, but I had this issue all day.

iMac 27 (late 2013) I5 haswell 3.5 GHz, GT 755M 1 GB, 8 GB of RAM
macOS High Sierra 10.13.1
RCS-RDS 300 Mb/s
Dej, Cuj, Romania , 405200
Fiber Optic directly to my mac
andrei_cat10@yahoo.com
GeForce NOW app version 1.4.1.103/po (EU Central)

#1
Posted 11/27/2017 06:49 PM   
same here... get error code 0x000001F8
same here... get error code 0x000001F8

#2
Posted 11/27/2017 08:15 PM   
same, :( I have tried everything, it's very likely server side. Look's like its been down a couple hours maybe? Will be following.
same, :( I have tried everything, it's very likely server side.

Look's like its been down a couple hours maybe?

Will be following.

#3
Posted 11/27/2017 08:24 PM   
any updates from the officlal guys? Same here in Germany.
any updates from the officlal guys?

Same here in Germany.

#4
Posted 11/27/2017 08:28 PM   
You guys got something for me? I have the same exact problem. And, in addition to that, everytime i get into the "geforce NOW" app this message pops out: "Failed to connect to NVIDIA." Ugh, this is painful, ahahah. I'm from Italy btw.
You guys got something for me? I have the same exact problem. And, in addition to that, everytime i get into the "geforce NOW" app this message pops out: "Failed to connect to NVIDIA."

Ugh, this is painful, ahahah.

I'm from Italy btw.

#5
Posted 11/27/2017 08:32 PM   
For me it's started yesterday, approximately at midnight UTC. Today I started to play at 4pm UTC and everything was fine until I decided to quit at sometime. From this moment I can not to play. My country is Belarus
For me it's started yesterday, approximately at midnight UTC.
Today I started to play at 4pm UTC and everything was fine until I decided to quit at sometime.
From this moment I can not to play.

My country is Belarus

#6
Posted 11/27/2017 08:32 PM   
[quote="DK_SPB"]For me it's started yesterday, approximately at midnight UTC. Today I started to play at 4pm UTC and everything was fine until I decided to quit at sometime. From this moment I can not to play. [/quote] The same thing happened to me.
DK_SPB said:For me it's started yesterday, approximately at midnight UTC.
Today I started to play at 4pm UTC and everything was fine until I decided to quit at sometime.
From this moment I can not to play.


The same thing happened to me.

#7
Posted 11/27/2017 08:33 PM   
[quote="FRANKOHRD"]You guys got something for me? I have the same exact problem. And, in addition to that, everytime i get into the "geforce NOW" app this message pops out: "Failed to connect to NVIDIA." Ugh, this is painful, ahahah. I'm from Italy btw. [/quote] I got this error too, Downloaded DMG from official site, reinstalled and it's helped, but can not to play anyway.
FRANKOHRD said:You guys got something for me? I have the same exact problem. And, in addition to that, everytime i get into the "geforce NOW" app this message pops out: "Failed to connect to NVIDIA."

Ugh, this is painful, ahahah.

I'm from Italy btw.


I got this error too,
Downloaded DMG from official site, reinstalled and it's helped, but can not to play anyway.

#8
Posted 11/27/2017 08:33 PM   
Same problem in Midwest USA, "There was a problem starting your game. Try again." Can not get any connectivity to game library.
Same problem in Midwest USA, "There was a problem starting your game. Try again." Can not get any connectivity to game library.

#9
Posted 11/27/2017 08:38 PM   
Unbelievably bad service and experience for me since I discovered this product :( Can't wait to join shadow when they open up.
Unbelievably bad service and experience for me since I discovered this product :(

Can't wait to join shadow when they open up.

#10
Posted 11/27/2017 08:41 PM   
Here we can monitor servers load level https://www.nvidia.co.uk/geforce/products/geforce-now/mac-pc/server-status/

#11
Posted 11/27/2017 08:42 PM   
Even though it is beta, its extremely frustrating to not get any updates or information from the officials regarding the servers.
Even though it is beta, its extremely frustrating to not get any updates or information from the officials regarding the servers.

#12
Posted 11/27/2017 08:43 PM   
[quote="DK_SPB"]Here we can monitor servers load level https://www.nvidia.co.uk/geforce/products/geforce-now/mac-pc/server-status/ [/quote] It keeps on saying the exact same thing. Servers are yellow and that's it, not even red. That doesn't make any sense, the app should work fine, but it doesn't, even though the servers are yellow.
DK_SPB said:Here we can monitor servers load level

https://www.nvidia.co.uk/geforce/products/geforce-now/mac-pc/server-status/





It keeps on saying the exact same thing. Servers are yellow and that's it, not even red. That doesn't make any sense, the app should work fine, but it doesn't, even though the servers are yellow.

#13
Posted 11/27/2017 08:44 PM   
[quote="DK_SPB"]Here we can monitor servers load level https://www.nvidia.co.uk/geforce/products/geforce-now/mac-pc/server-status/ [/quote] EU servers have been yellow for 2 weeks now.
DK_SPB said:Here we can monitor servers load level

https://www.nvidia.co.uk/geforce/products/geforce-now/mac-pc/server-status/





EU servers have been yellow for 2 weeks now.

#14
Posted 11/27/2017 08:45 PM   
[quote="adrien.siami"][quote="DK_SPB"]Here we can monitor servers load level https://www.nvidia.co.uk/geforce/products/geforce-now/mac-pc/server-status/ [/quote] EU servers have been yellow for 2 weeks now.[/quote] Exactly :P
adrien.siami said:
DK_SPB said:Here we can monitor servers load level

https://www.nvidia.co.uk/geforce/products/geforce-now/mac-pc/server-status/





EU servers have been yellow for 2 weeks now.


Exactly :P

#15
Posted 11/27/2017 08:47 PM   
  1 / 2    
Scroll To Top