Recently purchased a Shield TV and thus far, rather disappointed in it - so looking for help.
I had a steam link, and it worked fine - but every blue moon, sound would cut out - or something annoying would happen. When I 'complained' about it on the steam link forums (it just recently started), someone suggested a Shield was way better and I should check it out. So, I did a bit of research and decided to pick one up. But - I constantly get low to no bandwidth (even when wired) and I've never had that issue with the steam link... I'll start up (for instance) fallout 4 and it stutters or freezes (and admittedly, the sound still cuts out a bit - not nearly as bad as it was on the steam link.) The game is almost unplayable over the shield. I also have the problem with the shield where I go into gamestream (and thus steam goes into big picture mode) - I start a game (play for a while, etc...), but when I exit out of the game, it doesn't go back to the menu's (even though, I can look over at my PC and it's displaying menu's normally...) I also noticed it won't exit big picture mode at all. When I exit a game, the shield is showing that blueish screen (like when steam is doing something...) - but, I can hear sounds of navigating the menus (and like I said above, my PC shows the menu and it's running like normal...) Are these common occurrences? I'm really debating taking this back for a refund...
I had a steam link, and it worked fine - but every blue moon, sound would cut out - or something annoying would happen. When I 'complained' about it on the steam link forums (it just recently started), someone suggested a Shield was way better and I should check it out. So, I did a bit of research and decided to pick one up.

But - I constantly get low to no bandwidth (even when wired) and I've never had that issue with the steam link... I'll start up (for instance) fallout 4 and it stutters or freezes (and admittedly, the sound still cuts out a bit - not nearly as bad as it was on the steam link.) The game is almost unplayable over the shield.

I also have the problem with the shield where I go into gamestream (and thus steam goes into big picture mode) - I start a game (play for a while, etc...), but when I exit out of the game, it doesn't go back to the menu's (even though, I can look over at my PC and it's displaying menu's normally...) I also noticed it won't exit big picture mode at all. When I exit a game, the shield is showing that blueish screen (like when steam is doing something...) - but, I can hear sounds of navigating the menus (and like I said above, my PC shows the menu and it's running like normal...)

Are these common occurrences? I'm really debating taking this back for a refund...

#1
Posted 11/14/2017 06:38 PM   
Make sure drivers and GFE is the very latest version, always update your driver when one comes out, I've noticed n ot doing that can cause issues with Gamestream. Also try forcing 1080/60 in the settings of Gamestream>PC
Make sure drivers and GFE is the very latest version, always update your driver when one comes out, I've noticed n ot doing that can cause issues with Gamestream. Also try forcing 1080/60 in the settings of Gamestream>PC

#2
Posted 11/14/2017 11:50 PM   
Will do, thank you. It seems a couple others have posted similar problems, so hopefully it's a very fixable thing :)
Will do, thank you. It seems a couple others have posted similar problems, so hopefully it's a very fixable thing :)

#3
Posted 11/15/2017 03:50 AM   
or you can just stream remote desktop 1st and launch the steam 2nd. to remote desktop: open geforce experience on your computer -> settings -> shield -> gamestream -> add -> your main hard drive -> windows -> system32 -> mstsc.exe
or you can just stream remote desktop 1st and launch the steam 2nd.

to remote desktop: open geforce experience on your computer -> settings -> shield -> gamestream -> add -> your main hard drive -> windows -> system32 -> mstsc.exe

#4
Posted 11/15/2017 03:50 PM   
Scroll To Top