Green Flickering after drivers v. 388.13 and 388.31 (Epilepsy Warning!!!!) -- [SOLVED]
  1 / 3    
[b]Edit: [color="orange"]Issue solved[/color][/b]. The solution can be [url=https://forums.geforce.com/default/topic/1028579/geforce-drivers/green-flickering-epilepsy-warning-fixed-/post/5244648/#5244648]found in post n:o #40[/url] Has anyone an idea why I'm getting this weird green flickering when playing some games after installing Geforce Game Ready Driver v. 388.13? Ok, it doesn't affect all games, just few: Hellblade: Senua's Sacrifice and Space Hulk: Deathwing. All other games R just fine, such as Doom2016, Warframe, Wolfenstein: The New Colosseus, Mass Effect Andromeda, Dirt4, and so on. To workaround the issue is just to change the in-game resolution to another and revert back to 1080p. [img]https://i.imgur.com/9rsGBeO.gif[/img] My Rig is: Win10 Enterprise x64 v. 1709 i5 4690K Asus Strix GTX 1070 B85-PRO Gamer Micron 16GB RAM DDR3 SSD x2 Asus 24" VE247H (with HDMI) 650W psu SupremeFX Audio chip on mobo // aka Realtek HD Audio ALC1150 DX12 If I record the vid with shadowplay all is fine on the vid, but what I see on my screen is the green flickering when starting a game. And again: when I change the resolution in-game to another and roll back to 1080p all is fine.
Edit: Issue solved.
The solution can be found in post n:o #40

Has anyone an idea why I'm getting this weird green flickering when playing some games after installing Geforce Game Ready Driver v. 388.13? Ok, it doesn't affect all games, just few: Hellblade: Senua's Sacrifice and Space Hulk: Deathwing. All other games R just fine, such as Doom2016, Warframe, Wolfenstein: The New Colosseus, Mass Effect Andromeda, Dirt4, and so on.

To workaround the issue is just to change the in-game resolution to another and revert back to 1080p.

Image

My Rig is:
Win10 Enterprise x64 v. 1709
i5 4690K
Asus Strix GTX 1070
B85-PRO Gamer
Micron 16GB RAM DDR3
SSD x2
Asus 24" VE247H (with HDMI)
650W psu
SupremeFX Audio chip on mobo // aka Realtek HD Audio ALC1150 DX12

If I record the vid with shadowplay all is fine on the vid, but what I see on my screen is the green flickering when starting a game. And again: when I change the resolution in-game to another and roll back to 1080p all is fine.

#1
Posted 11/10/2017 09:17 PM   
. I would get off that driver: Download [url=http://www.wagnardsoft.com/content/display-driver-uninstaller-ddu-v17075-released]DDU[/url] (get the 17.0.7.5): [.]Install DDU[/.] Hold [SHIFT] and click on RESTART Windows. [.]you will end up in Safe mode[/.] Cannot use PIN, must use Account password to enter SAFE MODE Run DDU: [.]Select: NVIDIA software and Drivers[/.] [.]Select: Clean and Restart[/.] Run the [url=http://download.microsoft.com/download/f/2/2/f22d5fdb-59cd-4275-8c95-1be17bf70b21/wushowhide.diagcab]Microsoft Show hide tool[/url] [.]Hide all NVIDIA software and driver[/.] [.]Run it again to make sure there are no more, if more appear, [color="orange"]keep rerunning[/color][/.] Download this [url=http://us.download.nvidia.com/Windows/382.33/382.33-desktop-win10-64bit-international-whql.exe]382.33[/url] driver [.]Run DOWNLOAD package[/.] [.]Select: CUSTOM[/.] [.]Uncheck EVERYTHING excpet the GPU Driver and PHYSX[/.] [.]Check the CLEAN INSTALL box[/.] [.]Finish install[/.] [.][color="orange"]Reboot[/color][/.] .
.

I would get off that driver:

Download DDU (get the 17.0.7.5):
  • Install DDU

  • Hold [SHIFT] and click on RESTART Windows.
  • you will end up in Safe mode
  • Cannot use PIN, must use Account password to enter SAFE MODE

    Run DDU:
  • Select: NVIDIA software and Drivers
  • Select: Clean and Restart


  • Run the Microsoft Show hide tool
  • Hide all NVIDIA software and driver
  • Run it again to make sure there are no more, if more appear, keep rerunning

  • Download this 382.33 driver
  • Run DOWNLOAD package
  • Select: CUSTOM
  • Uncheck EVERYTHING excpet the GPU Driver and PHYSX
  • Check the CLEAN INSTALL box
  • Finish install
  • Reboot


  • .

    My Opinion is no more important or right than yours. But if your using the LATEST drivers, go back to the prior set.

    Piss Poor tech support blame all issues on drivers and assumes that your an idiot. Find a set that you know worked and see if the problem exists still.

    ""Don't f with it if it ain't broken!""
    Constantly updating drivers is a good way to F'up the whole system.

    If the driver has an issue, don't be a fool, remove it.

    Just because you can, does not mean you should.

    #2
    Posted 11/10/2017 11:34 PM   
    replace the hdmi cable, this is handshake corruption. the framebuffer is fine which is why there are no issues there.
    replace the hdmi cable, this is handshake corruption.

    the framebuffer is fine which is why there are no issues there.



    In Memory of Chris "ChrisRay" Arthington, 1982-2010

    Specs:
    CPU:Intel Xeon x5690 @ 4.2Ghz, Mainboard:Asus Rampage III Extreme, Memory:48GB Corsair Vengeance LP 1600
    Video:EVGA Geforce GTX 1080 Founders Edition, NVidia Geforce GTX 1060 Founders Edition
    Monitor:ROG PG279Q, BenQ BL2211, Sound:Creative XFI Titanium Fatal1ty Pro
    SDD:Crucial MX300 275, Crucial MX300 525, Crucial MX200 250
    HDD:500GB Spinpoint F3, 1TB WD Black, 2TB WD Red, 1TB WD Black
    Case:NZXT Phantom 820, PSU:Seasonic X-850, OS:Windows 7 SP1
    Cooler: ThermalRight Silver Arrow IB-E Extreme

    WIP:
    CPU:Intel Xeon x5660, Mainboard:Asus Rampage II Gene, Memory:16GB Corsair Vengeance 1600 LP
    Video:EVGA Geforce GTX 680+ 4GB, Palit Geforce GTX 550ti
    Monitor:Pending, Sound:Pending
    SDD:Pending
    HDD:Pending
    Case:NZXT Guardian 921RB, PSU:Corsair 620HX, OS:Windows 7 SP1
    Cooler: ThermalRight True Spirit 120M

    #3
    Posted 11/11/2017 01:09 AM   
    . [quote="Sora"]replace the hdmi cable, this is handshake corruption.[/quote] Nice :) That explains why is it not captured on the Vid. .
    .

    Sora said:replace the hdmi cable, this is handshake corruption.
    Nice :)

    That explains why is it not captured on the Vid.


    .

    My Opinion is no more important or right than yours. But if your using the LATEST drivers, go back to the prior set.

    Piss Poor tech support blame all issues on drivers and assumes that your an idiot. Find a set that you know worked and see if the problem exists still.

    ""Don't f with it if it ain't broken!""
    Constantly updating drivers is a good way to F'up the whole system.

    If the driver has an issue, don't be a fool, remove it.

    Just because you can, does not mean you should.

    #4
    Posted 11/11/2017 01:14 AM   
    [quote="Greybear"] . [quote="Sora"]replace the hdmi cable, this is handshake corruption.[/quote] Nice :) That explains why is it not captured on the Vid. .[/quote] HDMI is a negotiated signal much like PCI-E, it has a certain level of fault tolerance before it will dump the link and try again. In this case, the corruption is not enough to force a new link, but changing the resolution forces this when switching back hence why the issue is resolved. https://www.reddit.com/r/fireTV/comments/2nbupc/green_flicker_every_15_mins_or_so_with_new_fire/ there are cases on various forums on various hdmi devices going back years.
    Greybear said:
    .

    Sora said:replace the hdmi cable, this is handshake corruption.
    Nice :)

    That explains why is it not captured on the Vid.


    .


    HDMI is a negotiated signal much like PCI-E, it has a certain level of fault tolerance before it will dump the link and try again.

    In this case, the corruption is not enough to force a new link, but changing the resolution forces this when switching back hence why the issue is resolved.


    https://www.reddit.com/r/fireTV/comments/2nbupc/green_flicker_every_15_mins_or_so_with_new_fire/


    there are cases on various forums on various hdmi devices going back years.



    In Memory of Chris "ChrisRay" Arthington, 1982-2010

    Specs:
    CPU:Intel Xeon x5690 @ 4.2Ghz, Mainboard:Asus Rampage III Extreme, Memory:48GB Corsair Vengeance LP 1600
    Video:EVGA Geforce GTX 1080 Founders Edition, NVidia Geforce GTX 1060 Founders Edition
    Monitor:ROG PG279Q, BenQ BL2211, Sound:Creative XFI Titanium Fatal1ty Pro
    SDD:Crucial MX300 275, Crucial MX300 525, Crucial MX200 250
    HDD:500GB Spinpoint F3, 1TB WD Black, 2TB WD Red, 1TB WD Black
    Case:NZXT Phantom 820, PSU:Seasonic X-850, OS:Windows 7 SP1
    Cooler: ThermalRight Silver Arrow IB-E Extreme

    WIP:
    CPU:Intel Xeon x5660, Mainboard:Asus Rampage II Gene, Memory:16GB Corsair Vengeance 1600 LP
    Video:EVGA Geforce GTX 680+ 4GB, Palit Geforce GTX 550ti
    Monitor:Pending, Sound:Pending
    SDD:Pending
    HDD:Pending
    Case:NZXT Guardian 921RB, PSU:Corsair 620HX, OS:Windows 7 SP1
    Cooler: ThermalRight True Spirit 120M

    #5
    Posted 11/11/2017 02:10 AM   
    [quote="Carnaga"]Has anyone an idea why I'm getting this weird green flickering when playing some games after installing Geforce Game Ready Driver v. 388.13? Ok, it doesn't affect all games, just few: Hellblade: Senua's Sacrifice and Space Hulk: Deathwing. All other games R just fine, such as Doom2016, Warframe, Wolfenstein: The New Colosseus, Mass Effect Andromeda, Dirt4, and so on. To workaround the issue is just to change the in-game resolution to another and return back to 1080p. [img]https://i.imgur.com/9rsGBeO.gif[/img] My Rig is: Win10 Enterprise x64 v. 1709 i5 4690K Asus Strix GTX 1070 B85-PRO Gamer Micron 16GB RAM DDR3 SSD x2 Asus 24" VE247H (with HDMI) 650W psu If I record the vid with shadowplay all is fine on the vid, but what I see on my screen is the green flickering when starting a game. And again: when I change the resolution in-game to another and roll back to 1080p all is fine.[/quote] Does it go away if you play in windowed mode?
    Carnaga said:Has anyone an idea why I'm getting this weird green flickering when playing some games after installing Geforce Game Ready Driver v. 388.13? Ok, it doesn't affect all games, just few: Hellblade: Senua's Sacrifice and Space Hulk: Deathwing. All other games R just fine, such as Doom2016, Warframe, Wolfenstein: The New Colosseus, Mass Effect Andromeda, Dirt4, and so on.

    To workaround the issue is just to change the in-game resolution to another and return back to 1080p.

    Image

    My Rig is:
    Win10 Enterprise x64 v. 1709
    i5 4690K
    Asus Strix GTX 1070
    B85-PRO Gamer
    Micron 16GB RAM DDR3
    SSD x2
    Asus 24" VE247H (with HDMI)
    650W psu

    If I record the vid with shadowplay all is fine on the vid, but what I see on my screen is the green flickering when starting a game. And again: when I change the resolution in-game to another and roll back to 1080p all is fine.


    Does it go away if you play in windowed mode?

    We can't fix your bug if we can't reproduce it. Please provide as much details as possible including specs, steps to reproduce, graphics settings used, etc..

    For GeForce driver issues, please leave feedback in driver feedback form: Driver Feedback

    For SHIELD Tablet issues/requests, please leave feedback in the SHIELD Tablet feedback form: SHIELD Tablet Feedback

    For SHIELD Android TV issues/requests, please leave feedback in the SHIELD feedback form: SHIELD Feedback

    I am also available on Twitter:
    www.twitter.com/manuelguzman

    #6
    Posted 11/11/2017 03:08 AM   
    I have the same Problem as above Green Flickering with Driver 388.13 x64 Win10(Fully Updated) only all drivers before this working fine, I think this is not an HDMI Cable issue it happens only on 388.13 for me and Im on 385.69 this driver is almost stutter free for me and with 100% no Green flickering on all Games, Resolutions, Refreshrates. Hope this Helps a bit Sry for my Bad english :D RIG: [list] [.] OS: Windows 10 Pro 64-bit[/.] [.] GPU: Palit Geforce GTX1060 6GB DUAL [/.] [.] Screen1: Iiyama Blackhawk PL2730H (HDMI)[/.] [.] Screen2: LG Flattron W2242T (DVI)[/.] [.] MBoard: Gigabyte Z270 Gaming K3 (Rev 1.0)[/.] [.] CPU: Intel i5-7600K @ 4.2GHz[/.] [.] RAM: 16GB Corsair Vengeance LPX 2400 [/.] [.] PSU: Seasonic 620W[/.] [/list]
    I have the same Problem as above Green Flickering with Driver 388.13 x64 Win10(Fully Updated) only all drivers before this working fine, I think this is not an HDMI Cable issue it happens only on 388.13 for me and Im on 385.69 this driver is almost stutter free for me and with 100% no Green flickering on all Games, Resolutions, Refreshrates.

    Hope this Helps a bit

    Sry for my Bad english :D

    RIG:
    • OS: Windows 10 Pro 64-bit
    • GPU: Palit Geforce GTX1060 6GB DUAL
    • Screen1: Iiyama Blackhawk PL2730H (HDMI)

    • Screen2: LG Flattron W2242T (DVI)
    • MBoard: Gigabyte Z270 Gaming K3 (Rev 1.0)
    • CPU: Intel i5-7600K @ 4.2GHz
    • RAM: 16GB Corsair Vengeance LPX 2400
    • PSU: Seasonic 620W

    RIG:

    • OS: Windows 10 Pro 64-bit
    • GPU: Palit Geforce GTX1060 6GB DUAL
    • Screen1: Iiyama Blackhawk PL2730H (HDMI)
    • Screen2: LG Flattron W2242T (DVI)
    • MBoard: Gigabyte Z270 Gaming K3 (Rev 1.0)
    • CPU: Intel i5-7600K @ 4.2GHz(Cooling Scythe Ashura)
    • RAM: 16GB Corsair Vengeance LPX 2400
    • PSU: Seasonic 620W

    #7
    Posted 11/11/2017 04:39 AM   
    [quote="spawnkiller1001"]I have the same Problem as above Green Flickering with Driver 388.13 x64 Win10(Fully Updated) only all drivers before this working fine, I think this is not an HDMI Cable issue it happens only on 388.13 for me and Im on 385.69 this driver is almost stutter free for me and with 100% no Green flickering on all Games, Resolutions, Refreshrates. Hope this Helps a bit Sry for my Bad english :D RIG: [list] [.] OS: Windows 10 Pro 64-bit[/.] [.] GPU: Palit Geforce GTX1060 6GB DUAL [/.] [.] Screen1: Iiyama Blackhawk PL2730H (HDMI)[/.] [.] Screen2: LG Flattron W2242T (DVI)[/.] [.] MBoard: Gigabyte Z270 Gaming K3 (Rev 1.0)[/.] [.] CPU: Intel i5-7600K @ 4.2GHz[/.] [.] RAM: 16GB Corsair Vengeance LPX 2400 [/.] [.] PSU: Seasonic 620W[/.] [/list] [/quote] Same games? ManualG seems to have an idea of something going on, so do check if it occurs in windowed mode. It might not be the cable in this case after all, but it is definitely a corruption issue occuring on the hdmi interface, maybe a result of FCU driver changes. >..< to much jerry-rigging being done on an interface not intended to do it.
    spawnkiller1001 said:I have the same Problem as above Green Flickering with Driver 388.13 x64 Win10(Fully Updated) only all drivers before this working fine, I think this is not an HDMI Cable issue it happens only on 388.13 for me and Im on 385.69 this driver is almost stutter free for me and with 100% no Green flickering on all Games, Resolutions, Refreshrates.

    Hope this Helps a bit

    Sry for my Bad english :D

    RIG:
    • OS: Windows 10 Pro 64-bit
    • GPU: Palit Geforce GTX1060 6GB DUAL
    • Screen1: Iiyama Blackhawk PL2730H (HDMI)

    • Screen2: LG Flattron W2242T (DVI)
    • MBoard: Gigabyte Z270 Gaming K3 (Rev 1.0)
    • CPU: Intel i5-7600K @ 4.2GHz
    • RAM: 16GB Corsair Vengeance LPX 2400
    • PSU: Seasonic 620W





    Same games?

    ManualG seems to have an idea of something going on, so do check if it occurs in windowed mode.

    It might not be the cable in this case after all, but it is definitely a corruption issue occuring on the hdmi interface, maybe a result of FCU driver changes.

    >..< to much jerry-rigging being done on an interface not intended to do it.



    In Memory of Chris "ChrisRay" Arthington, 1982-2010

    Specs:
    CPU:Intel Xeon x5690 @ 4.2Ghz, Mainboard:Asus Rampage III Extreme, Memory:48GB Corsair Vengeance LP 1600
    Video:EVGA Geforce GTX 1080 Founders Edition, NVidia Geforce GTX 1060 Founders Edition
    Monitor:ROG PG279Q, BenQ BL2211, Sound:Creative XFI Titanium Fatal1ty Pro
    SDD:Crucial MX300 275, Crucial MX300 525, Crucial MX200 250
    HDD:500GB Spinpoint F3, 1TB WD Black, 2TB WD Red, 1TB WD Black
    Case:NZXT Phantom 820, PSU:Seasonic X-850, OS:Windows 7 SP1
    Cooler: ThermalRight Silver Arrow IB-E Extreme

    WIP:
    CPU:Intel Xeon x5660, Mainboard:Asus Rampage II Gene, Memory:16GB Corsair Vengeance 1600 LP
    Video:EVGA Geforce GTX 680+ 4GB, Palit Geforce GTX 550ti
    Monitor:Pending, Sound:Pending
    SDD:Pending
    HDD:Pending
    Case:NZXT Guardian 921RB, PSU:Corsair 620HX, OS:Windows 7 SP1
    Cooler: ThermalRight True Spirit 120M

    #8
    Posted 11/11/2017 05:34 AM   
    [quote="ManuelGuzmanNV"]Does it go away if you play in windowed mode?[/quote] Yes, it goes away when I run the games in windowed mode (borderless/windowed) and/or if I go to game settings and swap the resolution. [quote="Greybear"] . I would get off that driver: Download [url=http://www.wagnardsoft.com/content/display-driver-uninstaller-ddu-v17075-released]DDU[/url] (get the 17.0.7.5): [.]Install DDU[/.] Hold [SHIFT] and click on RESTART Windows. [.]you will end up in Safe mode[/.] Cannot use PIN, must use Account password to enter SAFE MODE Run DDU: [.]Select: NVIDIA software and Drivers[/.] [.]Select: Clean and Restart[/.] Run the [url=http://download.microsoft.com/download/f/2/2/f22d5fdb-59cd-4275-8c95-1be17bf70b21/wushowhide.diagcab]Microsoft Show hide tool[/url] [.]Hide all NVIDIA software and driver[/.] [.]Run it again to make sure there are no more, if more appear, [color="orange"]keep rerunning[/color][/.] Download this [url=http://us.download.nvidia.com/Windows/382.33/382.33-desktop-win10-64bit-international-whql.exe]382.33[/url] driver [.]Run DOWNLOAD package[/.] [.]Select: CUSTOM[/.] [.]Uncheck EVERYTHING excpet the GPU Driver and PHYSX[/.] [.]Check the CLEAN INSTALL box[/.] [.]Finish install[/.] [.][color="orange"]Reboot[/color][/.] .[/quote] Alright! I will do the clean installation with DDU :) thank you for the tip! [quote="Sora"]replace the hdmi cable, this is handshake corruption. the framebuffer is fine which is why there are no issues there.[/quote] Ok, this is kind of cheap way to test/narrow down the prob. I will try with another HDMI/DVI cable. Thank you for the tip :)
    ManuelGuzmanNV said:Does it go away if you play in windowed mode?

    Yes, it goes away when I run the games in windowed mode (borderless/windowed) and/or if I go to game settings and swap the resolution.

    Greybear said:
    .

    I would get off that driver:

    Download DDU (get the 17.0.7.5):
  • Install DDU

  • Hold [SHIFT] and click on RESTART Windows.
  • you will end up in Safe mode
  • Cannot use PIN, must use Account password to enter SAFE MODE

    Run DDU:
  • Select: NVIDIA software and Drivers
  • Select: Clean and Restart


  • Run the Microsoft Show hide tool
  • Hide all NVIDIA software and driver
  • Run it again to make sure there are no more, if more appear, keep rerunning

  • Download this 382.33 driver
  • Run DOWNLOAD package
  • Select: CUSTOM
  • Uncheck EVERYTHING excpet the GPU Driver and PHYSX
  • Check the CLEAN INSTALL box
  • Finish install
  • Reboot


  • .

    Alright! I will do the clean installation with DDU :) thank you for the tip!

    Sora said:replace the hdmi cable, this is handshake corruption.

    the framebuffer is fine which is why there are no issues there.

    Ok, this is kind of cheap way to test/narrow down the prob. I will try with another HDMI/DVI cable. Thank you for the tip :)

    #9
    Posted 11/11/2017 09:36 AM   
    [url=https://forums.geforce.com/default/topic/1028579/geforce-drivers/green-flickering-epilepsy-warning-and-yes-creartors-update-installed/post/5241582/#5241582]@Sora[/url], swapping the HDMI cable to a new one didn't fix the issue. I got the same Green flickering with v.388.13 drivers. [url=https://forums.geforce.com/default/topic/1028579/geforce-drivers/green-flickering-epilepsy-warning-and-yes-creartors-update-installed/post/5241541/#5241541]@Greybear[/url], I followed you steps and ran DDU in safe-mode, performing the clean installation and I installed the old v. 382.33 drivers. [color="orange"]This did the trick! No green flickering![/color] and both games (Hellblade: Sensuas Sacrifice, Space Hulk: Deathwing) works as they should. Thought I cannot run Wolfenstein II: The New Colossus :( It prompts me with this error: [img]https://i.imgur.com/NYq3Hmn.png[/img] [color="orange"]Anyways: no green flickering with v. 382.33 drivers[/color] So I prolly should just swap the drivers between 328.33 <-- --> 388.0 if playing Wolfenstein II. Or just go with the new drivers and perform the in-game resolution swap to get rid of the green flickering. Or test if 388.0 drivers would work better than the 388.13.
    @Sora, swapping the HDMI cable to a new one didn't fix the issue. I got the same Green flickering with v.388.13 drivers.

    @Greybear, I followed you steps and ran DDU in safe-mode, performing the clean installation and I installed the old v. 382.33 drivers. This did the trick! No green flickering! and both games (Hellblade: Sensuas Sacrifice, Space Hulk: Deathwing) works as they should.

    Thought I cannot run Wolfenstein II: The New Colossus :( It prompts me with this error:
    Image

    Anyways: no green flickering with v. 382.33 drivers

    So I prolly should just swap the drivers between 328.33 <-- --> 388.0 if playing Wolfenstein II. Or just go with the new drivers and perform the in-game resolution swap to get rid of the green flickering. Or test if 388.0 drivers would work better than the 388.13.

    #10
    Posted 11/11/2017 10:32 AM   
    Ok. [color="orange"]Partially fixed the issue![/color] After following [b][url=https://forums.geforce.com/default/topic/1028579/geforce-drivers/green-flickering-epilepsy-warning-and-yes-creartors-update-installed/post/5241541/#5241541]@Greybear[/url][/b] suggestion with clean installation and reverting the drivers to 328.33 and installing only Graphics Driver and PhysX, I decided to update the drivers to 388.0 -- this time without installing the additional components (3D Vision / HD-Audio / Geforce Experience). Now I can run those 'old' games without the green flickering! Addition to this I can also launch and play Wolfenstein II: The New Colossus. While writing, I'm installing the Geforce Experience (shadowplay) because I want to record the all the stunts I'm making. And now that GF Experinece is installed all seems to be working fine with 388.0 drivers. So on my case the green flickering issue is somewhat fixed. To sum up the steps I made are: 1) Clean GF Drivers installation in safe-mode with DDU 2) Installed v. 328.33 drivers without additional components: just the drivers and PhysX 3) Updated the drivers to 388.0 without additional components: just the drivers and PhysX and GF Experience So basically reverting to v. 388.0 and without installing 3D-vision/HD-audio components all seems to be working fine! The next step I'm going to perform is to update the drivers from 388.0 -> 388.13 without those additional nVidia components. Lets see what happens :)
    Ok. Partially fixed the issue!

    After following @Greybear suggestion with clean installation and reverting the drivers to 328.33 and installing only Graphics Driver and PhysX, I decided to update the drivers to 388.0 -- this time without installing the additional components (3D Vision / HD-Audio / Geforce Experience). Now I can run those 'old' games without the green flickering! Addition to this I can also launch and play Wolfenstein II: The New Colossus.

    While writing, I'm installing the Geforce Experience (shadowplay) because I want to record the all the stunts I'm making. And now that GF Experinece is installed all seems to be working fine with 388.0 drivers.

    So on my case the green flickering issue is somewhat fixed. To sum up the steps I made are:

    1) Clean GF Drivers installation in safe-mode with DDU
    2) Installed v. 328.33 drivers without additional components: just the drivers and PhysX
    3) Updated the drivers to 388.0 without additional components: just the drivers and PhysX and GF Experience

    So basically reverting to v. 388.0 and without installing 3D-vision/HD-audio components all seems to be working fine!

    The next step I'm going to perform is to update the drivers from 388.0 -> 388.13 without those additional nVidia components. Lets see what happens :)

    #11
    Posted 11/11/2017 10:57 AM   
    [color="orange"]Installing v. 388.13 drivers brought back the green flickering[/color] on those older games. So I'm going to revert back to 388.0.
    Installing v. 388.13 drivers brought back the green flickering on those older games. So I'm going to revert back to 388.0.

    #12
    Posted 11/11/2017 11:07 AM   
    I really appreciate all the help you guys have given to narrow down the issue with Green Flickering. So thank you sooooo much for helping me out!!! :) To summarize: Green flickering occurs only with GF Drivers v. 388.13 and with bit older games/releases and while using Full Screen mode. To workaround the issue with v. 388.13 drivers -- swapping the in-game resolution and reverting the resolution settings back helps. Also running the game in windowed mode (including borderless) helps to get rid off the Green Flickering (returning to Full Screen mode brings the flickering back but you can fix this by swapping the in-game resolution and reverting the resolution back to normal -- in my case 1080p). To fix the issue permanently, reverting the drivers from 388.13 back to 388.0 with DDU (clean installation) solves it. Edit1: yes, I tried with brand new HDMI Cable so Cable is not the source of the problem. Edit2: I'm thinking to upgrade my monitor to 144hz version (once I get the money xD) and go with Display Port.
    I really appreciate all the help you guys have given to narrow down the issue with Green Flickering. So thank you sooooo much for helping me out!!! :)

    To summarize:

    Green flickering occurs only with GF Drivers v. 388.13 and with bit older games/releases and while using Full Screen mode. To workaround the issue with v. 388.13 drivers -- swapping the in-game resolution and reverting the resolution settings back helps. Also running the game in windowed mode (including borderless) helps to get rid off the Green Flickering (returning to Full Screen mode brings the flickering back but you can fix this by swapping the in-game resolution and reverting the resolution back to normal -- in my case 1080p).

    To fix the issue permanently, reverting the drivers from 388.13 back to 388.0 with DDU (clean installation) solves it.

    Edit1: yes, I tried with brand new HDMI Cable so Cable is not the source of the problem.
    Edit2: I'm thinking to upgrade my monitor to 144hz version (once I get the money xD) and go with Display Port.

    #13
    Posted 11/11/2017 12:02 PM   
    . Thank you for that information. Just an Update. I would do more testing on the drivers above the 385.xx range. I would use the drivers I gave and this time, install all the Junk you need. To get through Wolfenstien and other games, use this [url=https://forums.geforce.com/default/topic/962633/pc-games/bypassing-the-driver-version-check-of-a-game-/]method[/url] But if youre happy where you are, I cannot stop you. Also, if you get another HDMI cable that is good, and you decide to test the 388.13 again. Please come back with an update, I am real curious. The issue could be a POWER change in the 388.13 that shows with a weak/bad cable. .
    .

    Thank you for that information.


    Just an Update. I would do more testing on the drivers above the 385.xx range.

    I would use the drivers I gave and this time, install all the Junk you need.

    To get through Wolfenstien and other games, use this method


    But if youre happy where you are, I cannot stop you.

    Also, if you get another HDMI cable that is good, and you decide to test the 388.13 again. Please come back with an update, I am real curious. The issue could be a POWER change in the 388.13 that shows with a weak/bad cable.


    .

    My Opinion is no more important or right than yours. But if your using the LATEST drivers, go back to the prior set.

    Piss Poor tech support blame all issues on drivers and assumes that your an idiot. Find a set that you know worked and see if the problem exists still.

    ""Don't f with it if it ain't broken!""
    Constantly updating drivers is a good way to F'up the whole system.

    If the driver has an issue, don't be a fool, remove it.

    Just because you can, does not mean you should.

    #14
    Posted 11/11/2017 03:03 PM   
    [b][url=https://forums.geforce.com/default/topic/1028579/geforce-drivers/green-flickering-epilepsy-warning-partially-solved-by-reverting-drivers-back-to-388-0-/post/5241773/#5241773]@Greybear[/url][/b], so basically I can swap the api by copy-paste/renaming nvapi64.dll between the old and new one to bypass the driver version check..? Thanks for the tip and for the easy and simplified batch! Need to try it in the future: so far all games are working just fine with previous v. 388.0 drivers.
    @Greybear, so basically I can swap the api by copy-paste/renaming nvapi64.dll between the old and new one to bypass the driver version check..?

    Thanks for the tip and for the easy and simplified batch! Need to try it in the future: so far all games are working just fine with previous v. 388.0 drivers.

    #15
    Posted 11/13/2017 09:03 AM   
      1 / 3    
    Scroll To Top