Google Assistant w/ Spotify
Has anybody had success getting Google Assistant to show results from Spotify? For me it always returns Youtube playlists and never anything from Spotify. I've tried a variety of commands like "OK Google, listen to Queens of the Stone Age on Spotify" varying "on" with "with" and "in". And some other variations. I have linked Spotify with Google Home. It always shows "No results found on Spotify. Showing results from other apps.". I have tried with other simpler band names too.
Has anybody had success getting Google Assistant to show results from Spotify? For me it always returns Youtube playlists and never anything from Spotify. I've tried a variety of commands like "OK Google, listen to Queens of the Stone Age on Spotify" varying "on" with "with" and "in". And some other variations. I have linked Spotify with Google Home. It always shows "No results found on Spotify. Showing results from other apps.". I have tried with other simpler band names too.

#1
Posted 09/28/2017 05:03 PM   
"Play Queens of the Stone age" doesn't work for me. However, just "Queens of the Stone Age" shows results from Youtube and Spotify. I'm in Germany so Google Assistant hasn't been fully released here.
"Play Queens of the Stone age" doesn't work for me. However, just "Queens of the Stone Age" shows results from Youtube and Spotify. I'm in Germany so Google Assistant hasn't been fully released here.

#2
Posted 09/28/2017 06:34 PM   
My issue is that I cannot seem to actually link my Spotify account to Assistant...? When I try to get Assistant to play a song in Spotify she says "Your music account needs to be linked first. You can do that in the Google Assistant settings" Well first I searched through all the Shield settings to no avail (there is only options to enable/disable app access, Spotify is enabled). And there is no Google Home or Assistant apps/settings for Android TV? I tried through iOS using the Google Home app. There are no options to "link" any accounts. Same with the Google Assistant app. I am guessing this is because I do not have any Google Home hardware? So how the hell do I link my Spotify account?
My issue is that I cannot seem to actually link my Spotify account to Assistant...?

When I try to get Assistant to play a song in Spotify she says "Your music account needs to be linked first. You can do that in the Google Assistant settings"

Well first I searched through all the Shield settings to no avail (there is only options to enable/disable app access, Spotify is enabled). And there is no Google Home or Assistant apps/settings for Android TV?

I tried through iOS using the Google Home app. There are no options to "link" any accounts. Same with the Google Assistant app. I am guessing this is because I do not have any Google Home hardware?

So how the hell do I link my Spotify account?

#3
Posted 09/28/2017 08:00 PM   
I'm not sure if this is the right way (and maybe why I don't get any results) buy I did so through an Android tablet I own using Google Home. That message stopped occurring when I did that. Again, still no results though.
I'm not sure if this is the right way (and maybe why I don't get any results) buy I did so through an Android tablet I own using Google Home. That message stopped occurring when I did that. Again, still no results though.

#4
Posted 09/28/2017 08:02 PM   
Well I figured out how to link the Spotify account. There was nothing in the iOS Google Home app but in the Google Assistant app... Top Right Button > Settings > Music > Spotify. Not sure why I did not see this the first 3+ times I searched through the app. Not at home now to test how/if it works with the Shield's Assistant but will respond back once I test it!
Well I figured out how to link the Spotify account. There was nothing in the iOS Google Home app but in the Google Assistant app... Top Right Button > Settings > Music > Spotify. Not sure why I did not see this the first 3+ times I searched through the app.

Not at home now to test how/if it works with the Shield's Assistant but will respond back once I test it!

#5
Posted 09/28/2017 10:28 PM   
So yeah, all Assistant is doing is showing YouTube playlists. Very annoying.
So yeah, all Assistant is doing is showing YouTube playlists. Very annoying.

#6
Posted 09/29/2017 01:29 AM   
First obstacle for me with this was finding instructions, even from Google, that matched what I actually had to do!! I have no 'Home' devices as such, just the Shield and using an iPhone there was no way anywhere to link Spotify to the Google Assistant account, the Shield was showing as a linked device. There's also seemingly no way to add any service to Google Assistant via a web GUI. Also, no way to link anything via the Shield itself. That rapidly cuts down the options!!!! Luckily my main phone is an Android device, but again the instructions don't reflect reality. There was no 'Music' tab to enter which I guess is as a result of there being no actual 'Home' devices on the network. So I had to go into 'Account Preferences' on the Google app and go to 'Linked Media Accounts' (an option that does not appear on the iOS app on my iPad or iPhone) and link it there. Finally all up and working but about as much use as an ashtray on a motorbike really, as has been pointed out above it just returns YouTube playlists!! WTF!!! Search returns need to come from the app you are IN, not some other damn app / service on the device!!! It'd be the same as returning a YouTube video if searching in Netflix, pointless. If I wanted YouTube Playlists I'd open and search the YouTube app!!! In Spotify, surprise, surprise, I want SPOTIFY playlists!! So the 'OK Google' search function is a useless addition to Spotify for me.
First obstacle for me with this was finding instructions, even from Google, that matched what I actually had to do!! I have no 'Home' devices as such, just the Shield and using an iPhone there was no way anywhere to link Spotify to the Google Assistant account, the Shield was showing as a linked device. There's also seemingly no way to add any service to Google Assistant via a web GUI. Also, no way to link anything via the Shield itself. That rapidly cuts down the options!!!!

Luckily my main phone is an Android device, but again the instructions don't reflect reality. There was no 'Music' tab to enter which I guess is as a result of there being no actual 'Home' devices on the network. So I had to go into 'Account Preferences' on the Google app and go to 'Linked Media Accounts' (an option that does not appear on the iOS app on my iPad or iPhone) and link it there. Finally all up and working but about as much use as an ashtray on a motorbike really, as has been pointed out above it just returns YouTube playlists!! WTF!!!

Search returns need to come from the app you are IN, not some other damn app / service on the device!!! It'd be the same as returning a YouTube video if searching in Netflix, pointless. If I wanted YouTube Playlists I'd open and search the YouTube app!!! In Spotify, surprise, surprise, I want SPOTIFY playlists!! So the 'OK Google' search function is a useless addition to Spotify for me.

#7
Posted 09/29/2017 04:28 AM   
You both are seriously clueless. You didn't turn "ON" spotify under Google's Searchable apps in settings. And even if you do, it's crappy and hardly finds results. It even told me there's no Michael Jackson on Spotify at one point. Please complain about something right than complain about something NVIDIA is gonna say is easily fixable...especially when Google Assistant is domineering crap.
You both are seriously clueless. You didn't turn "ON" spotify under Google's Searchable apps in settings. And even if you do, it's crappy and hardly finds results. It even told me there's no Michael Jackson on Spotify at one point.

Please complain about something right than complain about something NVIDIA is gonna say is easily fixable...especially when Google Assistant is domineering crap.

#8
Posted 09/29/2017 04:52 AM   
Tried playing multiple artists via GA and spotify yesterday and all worked good.
Tried playing multiple artists via GA and spotify yesterday and all worked good.

#9
Posted 09/29/2017 06:52 AM   
[quote="CaptainJackHarkness"]You both are seriously clueless. You didn't turn "ON" spotify under Google's Searchable apps in settings. And even if you do, it's crappy and hardly finds results. It even told me there's no Michael Jackson on Spotify at one point. [/quote] It is on. It has always been on. That is the first setting I found while searching for the magical setting in an app on a totally different platform to link my Spotify account. [quote="CaptainJackHarkness"] Please complain about something right than complain about something NVIDIA is gonna say is easily fixable...especially when Google Assistant is domineering crap. [/quote] What you just said makes absolutely no sense. We are just trying to figure out a way to make it work. EDIT: Turns out the Searchable Apps setting randomly toggles itself back off. See here: https://www.reddit.com/r/ShieldAndroidTV/comments/73582w/anyone_figure_out_how_to_get_the_assistant_to/dnnxcvr/?context=1 Sounds like it might be an easily fixable problem with an update. Or maybe we just should not talk about it as you insist.
CaptainJackHarkness said:You both are seriously clueless. You didn't turn "ON" spotify under Google's Searchable apps in settings. And even if you do, it's crappy and hardly finds results. It even told me there's no Michael Jackson on Spotify at one point.


It is on. It has always been on. That is the first setting I found while searching for the magical setting in an app on a totally different platform to link my Spotify account.


CaptainJackHarkness said: Please complain about something right than complain about something NVIDIA is gonna say is easily fixable...especially when Google Assistant is domineering crap.


What you just said makes absolutely no sense. We are just trying to figure out a way to make it work.

EDIT: Turns out the Searchable Apps setting randomly toggles itself back off. See here: https://www.reddit.com/r/ShieldAndroidTV/comments/73582w/anyone_figure_out_how_to_get_the_assistant_to/dnnxcvr/?context=1

Sounds like it might be an easily fixable problem with an update. Or maybe we just should not talk about it as you insist.

#10
Posted 09/29/2017 01:43 PM   
I finally got it linked via the iOS assistant app (had to restart it before Music appeared in settings) but now I get the “sorry,something went wrong try again in a few minutes” whoever I try and ask Google to play music in Spotify. Really frustrating. Reboots and logout/login in the Spotify app did nothing.
I finally got it linked via the iOS assistant app (had to restart it before Music appeared in settings) but now I get the “sorry,something went wrong try again in a few minutes” whoever I try and ask Google to play music in Spotify. Really frustrating.

Reboots and logout/login in the Spotify app did nothing.

#11
Posted 09/29/2017 05:58 PM   
Same issue as Roamerick. I'm just yelling at my TV and wondering where my life is going.
Same issue as Roamerick. I'm just yelling at my TV and wondering where my life is going.

#12
Posted 09/29/2017 09:34 PM   
When it works it's good but the only thing I can get GA to work reliably with is Netflix. It's the ONLY app where I can say "Play X on Netflix" and have GA a) Open the app and b) (more importantly) PLAY it without me having to interact with the Shield or remote again! Try it with Plex and it opens the app AT the desired movie or whatever and you then have to say play again or press play on the remote. Spotify REALLY demonstrates bizarre behaviour! I can say "Play Let it Be" on Spotify and it'll respond saying "Sure, Let it Be by the Beatles - here it is on Spotify' and promptly, nothing happens!!! Make the mistake of saying "Play Let it be" and it'll start playing it on YouTube!! What is it with this application's fixation with bloody YouTube!!! Then just a few moments ago, it will respond by playing either an artist or even a specific named track (this being without any changes to the device settings). Really confused as to why this behaviour is so random. Maybe something the Spotify end. When it was working the Spotify app wasn't even open and when I did open it it showed nothing playing???? Now I've turned it off and on again and can't get it to play at all??? No idea what I did to get it working, no idea how to get it working again. Too much hassle. What I also found is that if I uninstalled Spotify and told GA to play a song on Spotify, it would still say "OK, playing X on Spotify". Not sure how it can play something if the app isn't even installed?? It's almost as if, for me at least, if it does work, it's interacting with Spotify in a way that isn't via the installed app. Because when it was working, when I open the app, what was playing wasn't actually showing. Tried a few times since and even though I have the Spotify app installed and open, when it DOES work, the command will open a separate Spotify 'home screen' on which nothing else is visible than the currently playing track with no forward or back options available on the remote, just pause / play. Can't figure exactly what interface it's using?? Basically, a croc of s**t for me, total waste of time. The 'always listening' on the Gamepad I find really patchy. Sometimes work, sometimes doesn't, never works if I've recently used the Shield Remote. I've had the bottom of the screen light up waiting for the voice input but totally miss what I'm saying FAR more times than I've ever had it actually work, if a movie or music is playing, forget it. Seems to screw up Plex Voice search now which I can never get to work. Bit of a mixed bag for me at the moment. Not sure if it's worth the time and effort expended in getting it working or trying to fathom what needs to be done to get it to work across different apps consistently. Given the frustration of will it / won't it work, having to interact with the device a second or third time to get it to actually play as instructed, coupled with the annoyance of having commands intended for GA on the phone (which is a FAR more capable app) responded to with a 'Responding on another device' I'm contemplating switching it off altogether for now, for me it's something that sounds great in theory but poorly executed and too much of a hassle (and time waster) to use.
When it works it's good but the only thing I can get GA to work reliably with is Netflix. It's the ONLY app where I can say "Play X on Netflix" and have GA a) Open the app and b) (more importantly) PLAY it without me having to interact with the Shield or remote again!

Try it with Plex and it opens the app AT the desired movie or whatever and you then have to say play again or press play on the remote.

Spotify REALLY demonstrates bizarre behaviour! I can say "Play Let it Be" on Spotify and it'll respond saying "Sure, Let it Be by the Beatles - here it is on Spotify' and promptly, nothing happens!!! Make the mistake of saying "Play Let it be" and it'll start playing it on YouTube!! What is it with this application's fixation with bloody YouTube!!! Then just a few moments ago, it will respond by playing either an artist or even a specific named track (this being without any changes to the device settings). Really confused as to why this behaviour is so random. Maybe something the Spotify end. When it was working the Spotify app wasn't even open and when I did open it it showed nothing playing???? Now I've turned it off and on again and can't get it to play at all??? No idea what I did to get it working, no idea how to get it working again. Too much hassle.

What I also found is that if I uninstalled Spotify and told GA to play a song on Spotify, it would still say "OK, playing X on Spotify". Not sure how it can play something if the app isn't even installed?? It's almost as if, for me at least, if it does work, it's interacting with Spotify in a way that isn't via the installed app. Because when it was working, when I open the app, what was playing wasn't actually showing. Tried a few times since and even though I have the Spotify app installed and open, when it DOES work, the command will open a separate Spotify 'home screen' on which nothing else is visible than the currently playing track with no forward or back options available on the remote, just pause / play. Can't figure exactly what interface it's using?? Basically, a croc of s**t for me, total waste of time.

The 'always listening' on the Gamepad I find really patchy. Sometimes work, sometimes doesn't, never works if I've recently used the Shield Remote. I've had the bottom of the screen light up waiting for the voice input but totally miss what I'm saying FAR more times than I've ever had it actually work, if a movie or music is playing, forget it. Seems to screw up Plex Voice search now which I can never get to work. Bit of a mixed bag for me at the moment. Not sure if it's worth the time and effort expended in getting it working or trying to fathom what needs to be done to get it to work across different apps consistently.

Given the frustration of will it / won't it work, having to interact with the device a second or third time to get it to actually play as instructed, coupled with the annoyance of having commands intended for GA on the phone (which is a FAR more capable app) responded to with a 'Responding on another device' I'm contemplating switching it off altogether for now, for me it's something that sounds great in theory but poorly executed and too much of a hassle (and time waster) to use.

#13
Posted 09/30/2017 04:39 AM   
Done some further messing with this. It seems to be very random as to whether it will work or not. Sometimes it does, sometimes not. I use two separate Google accounts. One for all my general stuff such as sites, book marks, YouTube favourites and Maps etc. and one for Play Store purchases. I was wondering if there was an account conflict causing problems. However, I've checked and all devices are on the same account insofar as Google Home / Assistant is concerned. Both the phone and Shield TV are only logged in to the Play Store ID in the Play Store itself. On top of that, it doesn't seem to matter what is set to what as any number of combinations of account settings CAN work. It's just replicating how to get GA to work with Spotify reliably. I'm wondering also if it's because I'm not in the USA and have the US keyboard enabled and location disabled to get it to work? The other thing is that it does work reliably every time after a Restart. After a while though it'll stop working. All manner of things wont't get it to work again. Just now I tried using GA to open the Spotify app. Then said "Play Rolling Stones" and it did so? Whatever happens though it never plays from within Spotify app itself, it seems to bring up a stand alone Spotify screen with the Spotify logo and merely the track name and artwork, the only control being the Pause / Play button. If I open Google Home on the phone, then Spotify, the track playing is within Spotify, as are the rest of the tracks in the current album, and the other info. Doesn't do the same with the Spotify app on the Shield. Seems to play outside of the installed Spotify app altogether. Another thing I noticed is that 3-4 tracks in the sound just stops. The track looks like it's playing, but nothing, as if it's lost connection. Close out of the screen it's displaying and presto, doesn't work at all, AGAIN. Further, sometimes, after leaving it for half an hour or so, come back and it'll work, until it just stops, or you do something after which it packs up again. Finally, another bizarre behaviour. Entering the Search Screen on the Spotify app you can actually use the microphone button on the Remote to search within Spotify. So I search for Rolling Stones for instance and it brings up several hits within Spotify. Click to go up and look at them but after a few seconds that screen is promptly replaced by You Tube results!!!! Without doubt though the most bizarre behaviour is when you say "OK Google, Play this track by this band on Spotify" and it says "OK, here's blah blah blah" then nothing happens, and if Spotify is open playing a track, it just continues to play. Waste of space. Just seems to be like it's full of bugs at the moment and doesn't work reliably. Users simply shouldn't have to faff about so much to get something sort of half working, sometimes, when it feels like, and not at all consistently. Spend more time trying to sort this out and snatching for the remote to take you back to where you want to be than just disabling this and using the remote in the first place. Time to throw the towel in on trying to get this dog's breakfast to work.
Done some further messing with this. It seems to be very random as to whether it will work or not. Sometimes it does, sometimes not.

I use two separate Google accounts. One for all my general stuff such as sites, book marks, YouTube favourites and Maps etc. and one for Play Store purchases. I was wondering if there was an account conflict causing problems. However, I've checked and all devices are on the same account insofar as Google Home / Assistant is concerned. Both the phone and Shield TV are only logged in to the Play Store ID in the Play Store itself. On top of that, it doesn't seem to matter what is set to what as any number of combinations of account settings CAN work. It's just replicating how to get GA to work with Spotify reliably.

I'm wondering also if it's because I'm not in the USA and have the US keyboard enabled and location disabled to get it to work?

The other thing is that it does work reliably every time after a Restart. After a while though it'll stop working. All manner of things wont't get it to work again. Just now I tried using GA to open the Spotify app. Then said "Play Rolling Stones" and it did so?

Whatever happens though it never plays from within Spotify app itself, it seems to bring up a stand alone Spotify screen with the Spotify logo and merely the track name and artwork, the only control being the Pause / Play button. If I open Google Home on the phone, then Spotify, the track playing is within Spotify, as are the rest of the tracks in the current album, and the other info. Doesn't do the same with the Spotify app on the Shield. Seems to play outside of the installed Spotify app altogether.

Another thing I noticed is that 3-4 tracks in the sound just stops. The track looks like it's playing, but nothing, as if it's lost connection. Close out of the screen it's displaying and presto, doesn't work at all, AGAIN. Further, sometimes, after leaving it for half an hour or so, come back and it'll work, until it just stops, or you do something after which it packs up again. Finally, another bizarre behaviour. Entering the Search Screen on the Spotify app you can actually use the microphone button on the Remote to search within Spotify. So I search for Rolling Stones for instance and it brings up several hits within Spotify. Click to go up and look at them but after a few seconds that screen is promptly replaced by You Tube results!!!! Without doubt though the most bizarre behaviour is when you say "OK Google, Play this track by this band on Spotify" and it says "OK, here's blah blah blah" then nothing happens, and if Spotify is open playing a track, it just continues to play. Waste of space.

Just seems to be like it's full of bugs at the moment and doesn't work reliably. Users simply shouldn't have to faff about so much to get something sort of half working, sometimes, when it feels like, and not at all consistently. Spend more time trying to sort this out and snatching for the remote to take you back to where you want to be than just disabling this and using the remote in the first place. Time to throw the towel in on trying to get this dog's breakfast to work.

#14
Posted 09/30/2017 08:46 AM   
Scroll To Top