How to Get Started with Google Assistant on SHIELD TV
  1 / 4    
Here are some help guides to help you get started with Google Assistant on SHIELD TV: Learn About Google Assistant on SHIELD - FAQ http://nvidia.custhelp.com/app/answers/detail/a_id/4554 How to Set Up “OK Google” http://nvidia.custhelp.com/app/answers/detail/a_id/4543 What Can I Do with Google Assistant on SHIELD http://nvidia.custhelp.com/app/answers/detail/a_id/4556 Please note: [.]New users who install the Software Upgrade 6.0 and enroll assistant without agreeing to the playstore terms will see limited functionality of Assistant. (for instance photos wont work)[/.] [.]Version 11.5.17 is *required* for full assistant functionality. [/.] To solve this, please follow below: [.]Go to Play Store and accept Terms & Conditions.[/.] [.]Wait about a minute for apps to be updated, then go to Settings > Apps > Google Play Services and confirm that the version is 11.5.17 or higher.[/.]
Here are some help guides to help you get started with Google Assistant on SHIELD TV:

Learn About Google Assistant on SHIELD - FAQ
http://nvidia.custhelp.com/app/answers/detail/a_id/4554

How to Set Up “OK Google”
http://nvidia.custhelp.com/app/answers/detail/a_id/4543

What Can I Do with Google Assistant on SHIELD
http://nvidia.custhelp.com/app/answers/detail/a_id/4556

Please note:
  • New users who install the Software Upgrade 6.0 and enroll assistant without agreeing to the playstore terms will see limited functionality of Assistant. (for instance photos wont work)
  • Version 11.5.17 is *required* for full assistant functionality.

  • To solve this, please follow below:
  • Go to Play Store and accept Terms & Conditions.
  • Wait about a minute for apps to be updated, then go to Settings > Apps > Google Play Services and confirm that the version is 11.5.17 or higher.
  • We can't fix your bug if we can't reproduce it. Please provide as much details as possible including specs, steps to reproduce, graphics settings used, etc..

    For GeForce driver issues, please leave feedback in driver feedback form: Driver Feedback

    For SHIELD Tablet issues/requests, please leave feedback in the SHIELD Tablet feedback form: SHIELD Tablet Feedback

    For SHIELD Android TV issues/requests, please leave feedback in the SHIELD feedback form: SHIELD Feedback

    I am also available on Twitter:
    www.twitter.com/manuelguzman

    #1
    Posted 09/28/2017 09:08 AM   
    And to try Google Assistant outside of the US in the meantime - just change the language to English (US) - though of course you will have to put up with US locale settings.
    And to try Google Assistant outside of the US in the meantime - just change the language to English (US) - though of course you will have to put up with US locale settings.

    #2
    Posted 09/28/2017 03:56 PM   
    Hi! Does anyone know if Google Assistant and the always-on microphone are both ON by default and is there a way to delete Google Assistant and turn off the mic always being on? I don't want to update anything before knowing this. There is zero chance I'm going to have that spyware on any device in my house. I would never want to use it, and even if I did, it's not worth the privacy tradeoff. Definite downgrade and makes me regret my two Shield purchases. Answered here: No, it's not On by default. You have to setup GA before you can use it. The "Always on" feature can be disabled as I stated here: https://forums.geforce.com/default/topic/1025430/shield-tv/shield-experience-upgrade-6-0-for-shield-tv/post/5219655/#5219655 You can't delete Assistant as it's built into the Google Services Framework.
    Hi! Does anyone know if Google Assistant and the always-on microphone are both ON by default and is there a way to delete Google Assistant and turn off the mic always being on? I don't want to update anything before knowing this. There is zero chance I'm going to have that spyware on any device in my house. I would never want to use it, and even if I did, it's not worth the privacy tradeoff. Definite downgrade and makes me regret my two Shield purchases.

    Answered here:

    No, it's not On by default. You have to setup GA before you can use it. The "Always on" feature can be disabled as I stated here: https://forums.geforce.com/default/topic/1025430/shield-tv/shield-experience-upgrade-6-0-for-shield-tv/post/5219655/#5219655

    You can't delete Assistant as it's built into the Google Services Framework.

    #3
    Posted 09/28/2017 05:57 PM   
    In case anyone had the problem I had and couldn't get the always on feature working, look in settings/google to turn it on the first time, after that the setting to enable/disable it is found in settings/controller
    In case anyone had the problem I had and couldn't get the always on feature working, look in settings/google to turn it on the first time, after that the setting to enable/disable it is found in settings/controller

    #4
    Posted 09/28/2017 09:50 PM   
    I can't figure out how to set up a home control device. For example I'm trying to set up my Nest thermostat to voice control from the new assistant feature. When I say "Set the temperature to 70 degrees" the Google Assistant responds "It looks like that device hasn't been setup yet. Just open Assistant Settings and go to Home Control to add a device". But I can not find that Settings option anywhere.
    I can't figure out how to set up a home control device. For example I'm trying to set up my Nest thermostat to voice control from the new assistant feature.

    When I say "Set the temperature to 70 degrees" the Google Assistant responds "It looks like that device hasn't been setup yet. Just open Assistant Settings and go to Home Control to add a device". But I can not find that Settings option anywhere.

    #5
    Posted 09/29/2017 12:11 AM   
    [quote="leebickmtu"]I can't figure out how to set up a home control device. For example I'm trying to set up my Nest thermostat to voice control from the new assistant feature. When I say "Set the temperature to 70 degrees" the Google Assistant responds "It looks like that device hasn't been setup yet. Just open Assistant Settings and go to Home Control to add a device". But I can not find that Settings option anywhere.[/quote] Im having a similar issue with Phillips Hue control; there seems to be no way to set it up. The typical android options to add a home control device are missing.
    leebickmtu said:I can't figure out how to set up a home control device. For example I'm trying to set up my Nest thermostat to voice control from the new assistant feature.

    When I say "Set the temperature to 70 degrees" the Google Assistant responds "It looks like that device hasn't been setup yet. Just open Assistant Settings and go to Home Control to add a device". But I can not find that Settings option anywhere.


    Im having a similar issue with Phillips Hue control; there seems to be no way to set it up. The typical android options to add a home control device are missing.

    #6
    Posted 09/29/2017 12:36 AM   
    Missing explanation, how it works on the controller 2015!!
    Missing explanation, how it works on the controller 2015!!

    #7
    Posted 09/29/2017 05:37 AM   
    You have to use the google assistant on your android phone then you can control hue lights for instance. Theres no assistand settings on the shiled itself.
    You have to use the google assistant on your android phone then you can control hue lights for instance.
    Theres no assistand settings on the shiled itself.

    #8
    Posted 09/29/2017 06:37 AM   
    For anyone signing into Google with a GSuite account (rather then a GMail style account) on their device and getting an endless Voice assistant setup loop like this: https://youtu.be/v79wT1RCOzo The reason you get this is apparently permissions in GSuite deny the permission "Web & App Activity" by default ([i]and the Shield doesn't give the standard app permission denied prompts to notify you of this which I assume is a bug, as it will impact virtually everyone using GSuite I would suspect nVidia are working on this already but if not - there you go guys![/i]) To resolve this you need your GSuite administrator to login and go to: [b]Apps > Additional Google Services[/b] and enable the permission [b]Web & App Activity[/b] which immediately resolves the problem And credit to this post which led me to find this: [url]https://forums.geforce.com/default/topic/1025461/shield-tv/google-assistant-doesn-t-work/post/5219964/#5219964[/url]
    For anyone signing into Google with a GSuite account (rather then a GMail style account) on their device and getting an endless Voice assistant setup loop like this:
    https://youtu.be/v79wT1RCOzo

    The reason you get this is apparently permissions in GSuite deny the permission "Web & App Activity" by default (and the Shield doesn't give the standard app permission denied prompts to notify you of this which I assume is a bug, as it will impact virtually everyone using GSuite I would suspect nVidia are working on this already but if not - there you go guys!)

    To resolve this you need your GSuite administrator to login and go to:
    Apps > Additional Google Services and enable the permission Web & App Activity which immediately resolves the problem

    And credit to this post which led me to find this:
    https://forums.geforce.com/default/topic/1025461/shield-tv/google-assistant-doesn-t-work/post/5219964/#5219964

    #9
    Posted 09/29/2017 07:56 AM   
    I was having some issues with Google Assistant. It was mostly working bu it would not play music from Google Play Music or search my Google Photos. Google Music would become deselected in the searchable apps list every time I went back to the prefs page. I fixed this issue by Clearing the data for the Google Play Services app. After doing that Assistant is now working properly.
    I was having some issues with Google Assistant. It was mostly working bu it would not play music from Google Play Music or search my Google Photos. Google Music would become deselected in the searchable apps list every time I went back to the prefs page.

    I fixed this issue by Clearing the data for the Google Play Services app. After doing that Assistant is now working properly.

    #10
    Posted 09/29/2017 11:52 AM   
    [quote="whitworth"]And to try Google Assistant outside of the US in the meantime - just change the language to English (US) - though of course you will have to put up with US locale settings.[/quote] I only see the SmartThings Link for NVIDIA SHIELD available in amazon us to buy, not in other places. Will it be available in Europe?
    whitworth said:And to try Google Assistant outside of the US in the meantime - just change the language to English (US) - though of course you will have to put up with US locale settings.


    I only see the SmartThings Link for NVIDIA SHIELD available in amazon us to buy, not in other places. Will it be available in Europe?

    #11
    Posted 09/29/2017 04:30 PM   
    [quote="Tagus"][quote="whitworth"]And to try Google Assistant outside of the US in the meantime - just change the language to English (US) - though of course you will have to put up with US locale settings.[/quote] I only see the SmartThings Link for NVIDIA SHIELD available in amazon us to buy, not in other places. Will it be available in Europe? [/quote] You can also get the SmartThings Link direct from smartthings.com and at the intro price ($15) though free shipping requires $25+ purchase. Not sure if they ship to Europe though. [url]https://shop.smartthings.com/smartthings-link[/url]
    Tagus said:
    whitworth said:And to try Google Assistant outside of the US in the meantime - just change the language to English (US) - though of course you will have to put up with US locale settings.


    I only see the SmartThings Link for NVIDIA SHIELD available in amazon us to buy, not in other places. Will it be available in Europe?



    You can also get the SmartThings Link direct from smartthings.com and at the intro price ($15) though free shipping requires $25+ purchase. Not sure if they ship to Europe though.

    https://shop.smartthings.com/smartthings-link

    #12
    Posted 09/29/2017 04:45 PM   
    I was having some issues with Google Assistant. It was mostly working bu it would not play music from Google Play Music or search my Google Photos. Google Music would become deselected in the searchable apps list every time I went back to the prefs page. I fixed this issue by Clearing the data for the Google Play Services app. After doing that Assistant is now working properly. Thankyou justinbyoung for posting solution saved me time, I hope more people will do the same.
    I was having some issues with Google Assistant. It was mostly working bu it would not play music from Google Play Music or search my Google Photos. Google Music would become deselected in the searchable apps list every time I went back to the prefs page.

    I fixed this issue by Clearing the data for the Google Play Services app. After doing that Assistant is now working properly.


    Thankyou justinbyoung for posting solution saved me time, I hope more people will do the same.

    #13
    Posted 09/29/2017 07:04 PM   
    I'm getting the "Something went wrong, try again later" toast message while setting up Assistant. ----> Please take a look at your searchable apps in the Google option of the Settings. Do you see Netflix, Youtube or Google Play Movies in there? Some say they do but I dont. When you search for a movie, do you get matches from other apps like SPMC and whatnot? https://forums.geforce.com/default/topic/1025497/shield-tv/assistant-universal-search-kodi-plex-arc-browser-/ I think this is all related. Also: are you guys on the Google app and/or Play Services Beta program by any chance?! This also might have an impact.
    I'm getting the "Something went wrong, try again later" toast message while setting up Assistant.




    ----> Please take a look at your searchable apps in the Google option of the Settings.

    Do you see Netflix, Youtube or Google Play Movies in there? Some say they do but I dont.


    When you search for a movie, do you get matches from other apps like SPMC and whatnot?

    https://forums.geforce.com/default/topic/1025497/shield-tv/assistant-universal-search-kodi-plex-arc-browser-/


    I think this is all related.

    Also: are you guys on the Google app and/or Play Services Beta program by any chance?! This also might have an impact.

    #14
    Posted 09/30/2017 01:44 AM   
    I'm stuck in the "Meet Your Google Assistant" loop too. Made sure both my admin and personal account had "Web & App Activity" turned on. Nothing. It's a vicious cycle. Works fine on all my other Android devices. -------------- WOW what a pain! "Web & App Activity" is at the very bottom of "Additional Google Services" I completely missed it. Turned the setting on and it works. Forgetting my admin account email/user name was a pain.
    I'm stuck in the "Meet Your Google Assistant" loop too.

    Made sure both my admin and personal account had "Web & App Activity" turned on.

    Nothing.

    It's a vicious cycle.

    Works fine on all my other Android devices.

    --------------

    WOW what a pain! "Web & App Activity" is at the very bottom of "Additional Google Services"

    I completely missed it. Turned the setting on and it works.

    Forgetting my admin account email/user name was a pain.

    #15
    Posted 09/30/2017 02:13 AM   
      1 / 4    
    Scroll To Top