NVIDIA GeForce GTS 360M - DEAD or Not DEAD???
I have a NVIDIA GeForce GTS 360M on an Asus Republic of Gamers Notebook I cannot boot the notebook as it continuously re-boot. however I can boot in SAFE MODE, when I do so I can also disable the device (NVIDIA graphic card) and then the notebook boots normally and I can do everything I need, but I have a lousy display. I tried to download a new driver, but the same thing is happening I think the NVIDIA graphic card may be dead! what are the new craphic card which could replace/upgrade the old NVIDIA GeForce GTS 360M and where do I get them??? thanks, Yvoneg
I have a NVIDIA GeForce GTS 360M on an Asus Republic of Gamers Notebook
I cannot boot the notebook as it continuously re-boot.
however I can boot in SAFE MODE, when I do so I can also disable the device (NVIDIA graphic card) and then the notebook boots normally and I can do everything I need, but I have a lousy display.
I tried to download a new driver, but the same thing is happening

I think the NVIDIA graphic card may be dead!

what are the new craphic card which could replace/upgrade the old NVIDIA GeForce GTS 360M and where do I get them???
thanks, Yvoneg

#1
Posted 09/12/2017 02:31 AM   
The GPU on that laptop (G60JX) is not able to be "upgraded" any further than it already is. You can purchase a "used" Asus 360M MxM card but the prices are outrageous; especially considering the 300-series is no longer supported (End of Life). It would be in your best interest to simply purchase a new laptop.
The GPU on that laptop (G60JX) is not able to be "upgraded" any further than it already is.
You can purchase a "used" Asus 360M MxM card but the prices are outrageous; especially considering the 300-series is no longer supported (End of Life).

It would be in your best interest to simply purchase a new laptop.

Facebook PC parts Trade/Sales page

Help fight Cancer, Diabetes, Neuro-degenerative, and other disease's while you sleep!

MS-Physics (Thermal Dynamics)/BA-IT/BS-Electronic Engineering
Asus,HP/CQ,MSI,Toshiba mobile service center

My main rig:
OS- Win8.1 x64
CPU- i7-4790k @ 4.8Ghz 1.289v (Turbo OFF) Liquid Cooled
RAM-16GB TEAM Xtreme DDR3 @ 2400Mhz (9-12-11-30)1.625v
Motherboard- Gigabyte Z97X Gamer GT
Main Graphics- 2-way SLI EVGA GTX1070
Power Supply- Corsair RM-1000i
3X Surround Samsung 27" (7680 x 1440p)

Radio Server/ Scientific Simulator
CPU1- Xeon X5650 @ 3.2Ghz (locked)
CPU2- Xeon X5650 @ 3.2Ghz (locked)
Motherboard- Asus Z8PE-D12X
RAM- G-Skill RipJaws 24Gb (6x4Gb) DDR3 @ 1600Mhz Cas8
Graphics- GTX780 + GTX560
HDDs- WD RED 3TB (3x3TB) Raid 0= 9TB +1 3Tb back up
PSU- Corsair CX750M
Monitor- 768p Dell P.O.S

STILL working Nvidia GPUs-FX5200,FX5700,6800GT,7900GT(x2),8800GTS(x2),9800GTX,GTX275(x2),GTX285(x2),GTX295(x2),GTX470(x3),GTX480,GTX660ti(x3)GTX770(x3)HWbot Overclocking results

OVERCLOCKING LEAGUE RANKING
Worldwide: #1771 out of 51912
Extreme League: #1255 out of 2826
National: #213 of 20048 in United States
Team: #70 of 3166 in Overclock.net

#2
Posted 09/12/2017 03:33 AM   
thanks, will do Yvon
thanks, will do
Yvon

#3
Posted 09/12/2017 03:28 PM   
Scroll To Top