Cannot Install Drivers Windows 10(GTX 580)
Hi All, I have recently been having a problem installing drivers on my windows 10 machine. Whenever I run the installer from NVIDIA, it always gives me a black screen when it gets to the installing graphics driver part of the installer. The computer screen becomes black and the windows 10 USB disconnect sound can be heard, now then there is about a 50/50 chance that I will hear the windows 10 USB connect sound after that, except that sound is all garbled up. I then proceed to reboot my machine and Windows gets stuck on the logo. I then have to re-boot into safe mode and use DDU to un-install the drivers from there. Then I proceed to restart the machine and then windows can boot into regular mode. I am at a loss of words. I have used almost every different version of driver available to download from the NVIDIA website and have run them with the clean install box checked. They all give me the same problem. Specs: OS: Windows 10 64 Bit, Version: 1703, Build: 15063.540 CPU: Intel Core i7-960 @3.20GHz Motherboard: Gigabyte X58A-UD3R GPU: GTX 580 Ram: 8GB DDR3 120GB SSD with Windows on it 1TB HDD PSU: Antec 630W If anything else is needed please ask. Thank you in advance.
Hi All,

I have recently been having a problem installing drivers on my windows 10 machine. Whenever I run the installer from NVIDIA, it always gives me a black screen when it gets to the installing graphics driver part of the installer. The computer screen becomes black and the windows 10 USB disconnect sound can be heard, now then there is about a 50/50 chance that I will hear the windows 10 USB connect sound after that, except that sound is all garbled up. I then proceed to reboot my machine and Windows gets stuck on the logo. I then have to re-boot into safe mode and use DDU to un-install the drivers from there. Then I proceed to restart the machine and then windows can boot into regular mode. I am at a loss of words.

I have used almost every different version of driver available to download from the NVIDIA website and have run them with the clean install box checked. They all give me the same problem.

Specs:
OS: Windows 10 64 Bit, Version: 1703, Build: 15063.540
CPU: Intel Core i7-960 @3.20GHz
Motherboard: Gigabyte X58A-UD3R
GPU: GTX 580
Ram: 8GB DDR3
120GB SSD with Windows on it
1TB HDD
PSU: Antec 630W

If anything else is needed please ask.

Thank you in advance.

#1
Posted 08/23/2017 10:22 PM   
The latest drivers for Win10 that normally support the 5xx series are v378.92
The latest drivers for Win10 that normally support the 5xx series are v378.92

#2
Posted 11/09/2017 10:24 AM   
HI, i have the same issue with a gtx 470 graphic card. Any idea? When i install the latest driver after a reboot i see a windows logo and after this a black screen... :( Any idea?
HI, i have the same issue with a gtx 470 graphic card. Any idea? When i install the latest driver after a reboot i see a windows logo and after this a black screen... :(

Any idea?

#3
Posted 11/20/2017 08:59 PM   
Scroll To Top